Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: dpkg -i & apt-get install

  1. #1
    Join Date
    Jun 2013
    Beans
    8

    dpkg -i & apt-get install

    Hello All,

    I am learning Linux and waned to install a package hv3_3.0~fossil20110109-2_all.deb

    Came to know about two command available dpkg -i & apt-get install , Of which later one is better

    But when i am trying to install it with dpkg -i Its getting installed although not completely ( iu )but with apt-get no progress ( un )

    Please advise

    root@ubuntu:/home/bdss/Downloads# ls
    hv3_3.0~fossil20110109-2_all.deb
    root@ubuntu:/home/bdss/Downloads# dpkg -i hv3_3.0~fossil20110109-2_all.deb
    Selecting previously deselected package hv3.
    (Reading database ... 123283 files and directories currently installed.)
    Unpacking hv3 (from hv3_3.0~fossil20110109-2_all.deb) ...
    dpkg: dependency problems prevent configuration of hv3:
    hv3 depends on tk (>= 8.5.0-1); however:
    Package tk is not installed.
    hv3 depends on tk-html3; however:
    Package tk-html3 is not installed.
    hv3 depends on libsqlite3-tcl; however:
    Package libsqlite3-tcl is not installed.
    hv3 depends on tcllib; however:
    Package tcllib is not installed.
    dpkg: error processing hv3 (--install):
    dependency problems - leaving unconfigured
    Processing triggers for gnome-menus ...
    Processing triggers for desktop-file-utils ...
    Processing triggers for bamfdaemon ...
    Rebuilding /usr/share/applications/bamf.index...
    Processing triggers for man-db ...
    Errors were encountered while processing:
    hv3
    root@ubuntu:/home/bdss/Downloads# dpkg -l hv3
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name Version Description
    +++-=============================-=============================-================================================== ========================
    iU hv3 3.0~fossil20110109-2 Lightweight web browser


    root@ubuntu:/home/bdss/Downloads# dpkg -P hv3
    (Reading database ... 123339 files and directories currently installed.)
    Removing hv3 ...
    Purging configuration files for hv3 ...
    Processing triggers for man-db ...
    Processing triggers for gnome-menus ...
    Processing triggers for desktop-file-utils ...
    Processing triggers for bamfdaemon ...
    Rebuilding /usr/share/applications/bamf.index...

    root@ubuntu:/home/bdss/Downloads# dpkg -l hv3
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name Version Description
    +++-=============================-=============================-================================================== ========================
    un hv3 <none> (no description available)

    root@ubuntu:/home/bdss/Downloads# apt-get install hv3_3.0~fossil20110109-2_all.deb
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package hv3_3.0~fossil20110109-2_all.deb
    E: Couldn't find any package by regex 'hv3_3.0~fossil20110109-2_all.deb'
    root@ubuntu:/home/bdss/Downloads# dpkg -l hv3
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name Version Description
    +++-=============================-=============================-================================================== ========================
    un hv3 <none> (no description available)


    Thanks In Advance

  2. #2
    Join Date
    Jun 2013
    Beans
    8

    aptitude

    Hi ,

    What needs to be done for enable aptitude and use it

    root@ubuntu:/home/bdss/Downloads# aptitude install hv3_3.0~fossil20110109-2_all.deb
    The program 'aptitude' can be found in the following packages:
    * aptitude
    * aptitude-gtk

    Thanks In Advance

  3. #3
    Join Date
    Jun 2007
    Location
    Porirua, New Zealand
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: aptitude

    aptitude hasn't been included by default for a couple of releases now, you will need to install it before using it:
    Code:
    sudo apt-get install aptitude
    Forum DOs and DON'Ts
    Never assume that information you find using a search engine is up-to-date.

  4. #4
    Join Date
    Jan 2009
    Location
    Santander, Spain
    Beans
    1,822
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: aptitude

    what ubuntu are you using?

    In 12.04, aptitude is in the repositories, not need to download from other sites.

    In a xterm, simply run
    Code:
    sudo apt-get install aptitude
    you are asked for your pass, introduce it and it is all.

  5. #5
    Join Date
    May 2009
    Location
    Indiana
    Beans
    1,829
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: aptitude

    For that matter, there's probably no reason the OP needs to use aptitude.
    Bdss, I'm guessing you copied that install command from somewhere. Would you mind telling us where? The instructions you have are probably out-of-date or sub-optimal.
    Jane, stop this crazy thing!

  6. #6
    Join Date
    May 2009
    Location
    Indiana
    Beans
    1,829
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: aptitude

    Just did a Google search for the package you were trying to install with aptitude. It's in the Ubuntu repositories, so you should be able to install it with the Software Center or apt-get. No web browser download needed. No aptitude needed.
    Jane, stop this crazy thing!

  7. #7
    Join Date
    Jan 2009
    Location
    Santander, Spain
    Beans
    1,822
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: dpkg -i & apt-get install

    What for do you want the package hv3_3.0~fossil20110109-2_all.deb ?

    Where have you downloaded from?.

    running the command:

    Code:
    dpkg -i hv3_3.0~fossil20110109-2_all.deb
    advice you that there is a dependency problem between the package and the software in your system. For this reason, it is not installed.

    I recommend you look for the appropriate package for your ubuntu release. You can look for it through software center or synaptic.

  8. #8
    Join Date
    May 2009
    Location
    Indiana
    Beans
    1,829
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: dpkg -i & apt-get install

    There are major differences between dpkg and apt-get. Apt-get installs packages from the software sources you have set up in your machine (the repos by default), while dpkg installs from specified files. Apt-get takes care of dependencies. Dpkg does not.

    Also, it's not really good practice to run as root. It's better to use sudo.

    Try this:
    Code:
     sudo apt-get install hv3
    Jane, stop this crazy thing!

  9. #9
    Join Date
    Jun 2013
    Beans
    8

    Re: dpkg -i & apt-get install

    Quote Originally Posted by newb85 View Post
    There are major differences between dpkg and apt-get. Apt-get installs packages from the software sources you have set up in your machine (the repos by default), while dpkg installs from specified files. Apt-get takes care of dependencies. Dpkg does not.

    Also, it's not really good practice to run as root. It's better to use sudo.

    Try this:
    Code:
     sudo apt-get install hv3

    Thanks for the reply

    Actually i downloaded it from "http://www.debian.org/distrib/packages#view "

    & this is URL not included in /etc/apt/sources.list file

    Is that the reason , why its not getting installed using apt-get ?

    Also if I want to install new software using apt-get , do i have to add it url ( ex "http://www.debian.org/distrib/packages#view " ) to my sources.list file

  10. #10
    Join Date
    Jun 2013
    Beans
    8

    Re: aptitude

    Quote Originally Posted by claracc View Post
    what ubuntu are you using?

    In 12.04, aptitude is in the repositories, not need to download from other sites.

    In a xterm, simply run
    Code:
    sudo apt-get install aptitude
    you are asked for your pass, introduce it and it is all.
    Thanks for the reply.

    Mine is Ubuntu 11.10 ,

    Do i need to install aptitude before being able to use it ?

    Also i downloaded hv3_3.0~fossil20110109-2_all.deb from http://www.debian.org/distrib/packages#view to my local disk and now is trying to install it.Will the installation of hv3 using aptitude work ?

    *Its not there in my /etc/apt/sources.list file

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •