Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Can't install fonts on Ubuntu

  1. #1
    Join Date
    Jun 2013
    Beans
    7

    Can't install fonts on Ubuntu

    I'm dualbooting Ubuntu 12.04 LTS on a Windows-based laptop, and I can't seem to install fonts.

    Every time I attempt to install a font, it comes up with "Install Failed", and I can't manually place them in the file system because the administrator account doesn't have root permissions.

    Help?

  2. #2
    Join Date
    Mar 2006
    Beans
    308
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: Can't install fonts on Ubuntu

    Which kind of font are you trying to install?

  3. #3
    Join Date
    Jun 2013
    Beans
    7

    Re: Can't install fonts on Ubuntu

    Quote Originally Posted by cub View Post
    which kind of font are you trying to install?
    otf.

  4. #4
    Join Date
    Nov 2011
    Beans
    2,304
    Distro
    Ubuntu

    Re: Can't install fonts on Ubuntu

    Quote Originally Posted by Datzy View Post
    I'm dualbooting Ubuntu 12.04 LTS on a Windows-based laptop, and I can't seem to install fonts.

    Every time I attempt to install a font, it comes up with "Install Failed", and I can't manually place them in the file system because the administrator account doesn't have root permissions.

    Help?
    Are you unable to use sudo in Ubuntu? If so, something's wrong.

    System fonts are located in /usr/share/fonts. A "sudo cp -R <MyFontFolder> /usr/share/fonts" will do the trick. Follow up with "fc-cache -fv", and "sudo fc-cache -fv" for system-wide enabling. Fonts can also be stashed in ~/.fonts, ie., a .fonts directory in your ./home folder.

  5. #5
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Can't install fonts on Ubuntu

    If I remember correctly, when I was using 12.04 that also happened to me. Try opening Libreoffice Writer. You may see that font as one of the listed fonts. If so then it is installed despite the message saying it is not.

    If the administrator account does not have root privileges, then it is not the administrator account. You do not need administrator privileges to create a .font folder in your home folder.

    Open the file manager and in the View menu select Show Hidden files. Then when you open your home folder you will see all the hidden files and folders. They will have a dot ( . ) in front of the name. That is what hides them from normal view. Right click the window background and select New Folder. Rename it to .fonts and stick that font in there.

    Regards.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  6. #6
    Join Date
    Jun 2013
    Beans
    7

    Re: Can't install fonts on Ubuntu

    I did what both of you said, and nothing's working. Should I just do a clean reinstall?

  7. #7
    Join Date
    Nov 2011
    Beans
    2,304
    Distro
    Ubuntu

    Re: Can't install fonts on Ubuntu

    Have you checked the directory you placed the files in to make sure they are actually there?

    Did you run the "fc-cache -fv" commands? Did they produce screen output?

    What is displaying that "Install Failed" message? I've never seen that when I install fonts. It's not a message that the shell would display.

    When you open a terminal and prefaced one of those commands with "sudo", were you prompted for your password, and did the command run to completion? If so, then you ran the command with administrative privileges.

    I'm not sure what you mean by "administrator account" in Ubuntu. Ubuntu does not enable switching to root via su. The default user, the one created during the install, is allowed to use sudo, instead.
    Last edited by buzzingrobot; June 30th, 2013 at 02:10 PM.

  8. #8
    Join Date
    Jun 2013
    Beans
    7

    Re: Can't install fonts on Ubuntu

    Quote Originally Posted by buzzingrobot View Post
    Have you checked the directory you placed the files in to make sure they are actually there?

    Did you run the "fc-cache -fv" commands? Did they produce screen output?

    What is displaying that "Install Failed" message? I've never seen that when I install fonts. It's not a message that the shell would display.

    When you open a terminal and prefaced one of those commands with "sudo", were you prompted for your password, and did the command run to completion? If so, then you ran the command with administrative privileges.

    I'm not sure what you mean by "administrator account" in Ubuntu. Ubuntu does not enable switching to root via su. The default user, the one created during the install, is allowed to use sudo, instead.
    I ran fc-cache -fv, it produced screen output.

    I know how to use sudo, and yes, I was prompted for my password.

    What I mean is that I can't manually move things to the /___/ filesystem, like /usr/share/fonts.

    I'm assuming it was an installation error since it should be working as far as I know, I don't have anything important. After I do the clean reinstall I'll come back to you.

  9. #9
    Join Date
    May 2009
    Location
    Indiana
    Beans
    1,965
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Can't install fonts on Ubuntu

    Quote Originally Posted by buzzingrobot View Post
    I'm not sure what you mean by "administrator account" in Ubuntu. Ubuntu does not enable switching to root via su. The default user, the one created during the install, is allowed to use sudo, instead.
    Actually, in the terminal, one can switch to root with
    Code:
    sudo su
    but it's usually better practice to simply preface the commands requiring superuser privileges with sudo.

    Also, Ubuntu does differentiate between Standard and Administrator accounts. Administrator accounts may use sudo. Standard accounts may not. Neither are superuser or root by default.
    Jane, stop this crazy thing!

  10. #10
    Join Date
    Nov 2011
    Beans
    2,304
    Distro
    Ubuntu

    Re: Can't install fonts on Ubuntu

    Quote Originally Posted by newb85 View Post
    Code:
    sudo su
    I always use "sudo -i" when I have a lot of things to run off in succession. Think it sets up a slightly different environment than "sudo su", so the difference might be important on occasion.

    In other distros, I usually edit sudoers so I can play fast and loose without the password prompt. I agree, sort of, with Ubuntu's premise that forcing use of sudo and a password can enhance security. It doesn't, though, stop people from running dangerous commands.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •