Results 1 to 3 of 3

Thread: Ubuntu Server LTS 12.04 Adding SSL to webserver causes hang on boot?

  1. #1
    Join Date
    May 2007
    Beans
    18

    Ubuntu Server LTS 12.04 Adding SSL to webserver causes hang on boot?

    Added SSL to a webserver only to find that when the prompt comes up to enter the password, no time is offered to actually type it in. Apparently additional processes take over with the new default concurrent bootup. The system later hangs. I CAN boot using the recovery mode + resume normal bootup, as this gives me the time to enter the passphrase. Editing the startup in /etc/init.d/rc by changing concurrency to "none" didn't help.

  2. #2
    Join Date
    Jan 2005
    Location
    Illinois USA
    Beans
    1,045

    Re: Ubuntu Server LTS 12.04 Adding SSL to webserver causes hang on boot?

    Either set your HTTP server to use your passphrase, or remove the passphrase from the certificate.
    CloudRck.com - Host on CloudRck
    I sponsor open source projects and support users of such technologies. PM for details

  3. #3
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu Server LTS 12.04 Adding SSL to webserver causes hang on boot?

    Quote Originally Posted by DJ_Max View Post
    Either set your HTTP server to use your passphrase, or remove the passphrase from the certificate.
    This. Make sure the passphrase-less key is set to only be readable by root.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •