Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Problem connecting to google.com port 80 after about 2 days uptime

  1. #1
    Join Date
    May 2013
    Beans
    6

    Problem connecting to google.com port 80 after about 2 days uptime

    Hello,
    I've been having a very strange problem over the past few months:
    After about 2 days of uptime, suddenly my computer can't connect to any google.com servers on port 80.
    It doesn't matter what browser I'm using, even telnet to port 80 doesn't work.
    ping works just fine as does nslookup so this isn't a DNS problem.
    The computer is connected via ethernet cable to a router, other computers on the network don't have any problems.
    Taking out the cable and reconnecting it does not help, and neither does ifconfig eth0 down or restarting the network services.
    Only solution so far is to restart the computer.
    I found another thread with someone who had the exact same problem, unfortunately it does not end with a solution:
    http://ubuntuforums.org/showthread.php?t=1954064
    If anyone has any idea what else might work I'd be happy to try, this is starting to drive me crazy.

  2. #2
    Join Date
    Mar 2010
    Location
    Metro-ATL; PM free zone.
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Problem connecting to google.com port 80 after about 2 days uptime

    Can you connect to other systems on the internet or is it only google stuff?
    Are you trying from a corporate or university network? That could block based on the OS.
    Did you enable any new plugins?
    Is the firewall enabled and blocking?
    Could a "friend" be screwing with your system? Do the exact same DNS results come back from working systems vs the system that is not working? check the DNS server AND every IP for the google.com results. Check the /etc/hosts file for google entries and check the /etc/resolv.conf and /etc/nsswitch.conf for screwy settings.

    Testing the ping was a good idea - provided the resulting response is actually from a google server - it may not be.

    Or could your system have been compromised?

  3. #3
    Join Date
    May 2013
    Beans
    6

    Re: Problem connecting to google.com port 80 after about 2 days uptime

    Quote Originally Posted by TheFu View Post
    Can you connect to other systems on the internet or is it only google stuff?
    The rest of the internet work fine except for pages that have elements from google (adsense, cdn scripts etc.) which are very slow/don't work at all/

    Quote Originally Posted by TheFu View Post
    Are you trying from a corporate or university network? That could block based on the OS.
    This is from a home network. I haven't had the computer connected long enough to any other network to know if it occurs on other networks as well.

    Quote Originally Posted by TheFu View Post
    Did you enable any new plugins?
    No, and as this occurs from all browsers it obviously has nothing to do with plugins.

    Quote Originally Posted by TheFu View Post
    Is the firewall enabled and blocking?
    Firewall isn't enabled.

    Quote Originally Posted by TheFu View Post
    Could a "friend" be screwing with your system? Do the exact same DNS results come back from working systems vs the system that is not working? check the DNS server AND every IP for the google.com results. Check the /etc/hosts file for google entries and check the /etc/resolv.conf and /etc/nsswitch.conf for screwy settings.
    Nobody else has access to the computer, nothing screwy looking in the conf files (see them attached below).

    Quote Originally Posted by TheFu View Post
    Testing the ping was a good idea - provided the resulting response is actually from a google server - it may not be.

    Or could your system have been compromised?
    I doubt this very much.

    /etc/hosts:


    127.0.0.1 localhost127.0.1.1 telperion


    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters


    /etc/resolv.conf :


    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.1.1

    /etc/nsswitch.conf:


    # /etc/nsswitch.conf
    #
    # Example configuration of GNU Name Service Switch functionality.
    # If you have the `glibc-doc-reference' and `info' packages installed, try:
    # `info libc "Name Service Switch"' for information about this file.


    passwd: compat
    group: compat
    shadow: compat


    hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4 wins
    networks: files


    protocols: db files
    services: db files
    ethers: db files
    rpc: db files


    netgroup: nis

  4. #4
    Join Date
    Mar 2010
    Location
    Metro-ATL; PM free zone.
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Problem connecting to google.com port 80 after about 2 days uptime

    Quote Originally Posted by tbrisker View Post
    /etc/resolv.conf :


    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.1.1
    If you aren't running a properly configured local DNS server, then this is the issue. Mine points to the DNS server that the DHCP server provides, not the localhost.
    Which version of Ubuntu are you running? Somewhere inside Network Manager is probably where the config issue sits, if you are on a recent Ubuntu Desktop. For Ubuntu Server, check the /etc/network/interfaces file and dns-nameservers entry.

  5. #5
    Join Date
    May 2013
    Beans
    6

    Re: Problem connecting to google.com port 80 after about 2 days uptime

    I'm currently running Ubuntu desktop 13.04. Inside the network manager dns is defined to use DHCP, and connection information shows that the DHCP settings are being applied. However, using nslookup goes to the localhost (which works).

  6. #6
    Join Date
    Mar 2010
    Location
    Metro-ATL; PM free zone.
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Problem connecting to google.com port 80 after about 2 days uptime

    Quote Originally Posted by tbrisker View Post
    I'm currently running Ubuntu desktop 13.04. Inside the network manager dns is defined to use DHCP, and connection information shows that the DHCP settings are being applied. However, using nslookup goes to the localhost (which works).
    I still think that
    If you aren't running a properly configured local DNS server, then this is the issue.
    OTOH, the ideas that there is something in the network stack (drivers, IP, etc) that isn't working correct just for Google makes me think either your system or someone else along the network chain are modifying the packets.

    Can you point to a specific external DNS server or does your ISP force theirs down to you? If you have control, pick any of the reputable DNS servers (opendns, level-3, at&t, etc...) and see if that doesn't fix it for this box. My ISP started redirecting any port 53 target traffic to their DNS servers a few years ago - and broke a few things doing that. Took about a day to figure out they were screwing around and get my account excluded.

    Besides that, I haven't a clue. 13.04 is too new for my use. I'm on 12.04 until around June of 2014.

  7. #7
    Join Date
    May 2013
    Beans
    6

    Re: Problem connecting to google.com port 80 after about 2 days uptime

    I added 8.8.8.8 to the dns servers in the network manager, but it doesn't seem to change anything. Not sure if the requests actually get there or are they being rerouted by my ISP.
    I'm not sure about the DNS explanation tough - as it seems only port 80 traffic is affected, not other ports, and nslookup still works.

  8. #8
    Join Date
    Mar 2010
    Location
    Metro-ATL; PM free zone.
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Problem connecting to google.com port 80 after about 2 days uptime

    If only HTTP traffic is impacted, can you switch to HTTPS to bypass the slowdown?
    Is it possible that your ISP is running a transparent proxy? Smaller ISPs do this all the time. Heck, I suspect AT&T and Comcast do this for known static content too. Even if they only refresh their local cache every minute, for the larger networks, that can save TB of data per month.

  9. #9
    Join Date
    May 2013
    Beans
    6

    Re: Problem connecting to google.com port 80 after about 2 days uptime

    I tried using https, and for google.com it worked, however for mail.google.com it did not for some reason.
    Also any site loading content from google (analytics, cdn, etc) stalls while trying to load and never finished loading.
    I'm quite stumped as to what could be the cause. I doubt it's related to the ISP as other computers on the network are not effected, and resetting the router does not solve the problem either - so it must be something related to my computer.

  10. #10
    Join Date
    Mar 2010
    Location
    Metro-ATL; PM free zone.
    Beans
    Hidden!
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Problem connecting to google.com port 80 after about 2 days uptime

    I doubt it is hardware, so that leaves software and/or configuration.

    Are there any facts and data that you can share to prove the issue to the development team? They'd need numbers and comparisons against a working system on exactly the same hardware. For example, could you spare 10G of disk and load 12.04 and show that this is not an issue on it? Think about gathering facts - numbers that can be compared between the different installs. Can you run an nmap scan from both systems when it works and when it breaks? Can you show dig outputs that work before and after the issue? Things like that. Timing a lynx google.com page retrieve could be helpful too. Facts.

    You know that the nslookup command is deprecated? dig is the command that we've been using for 4+ yrs on UNIX systems. I doubt that matters, just a point.

    You make claims that the firewall is off - but didn't provide any proof. Are you sure? sudo iptables -L I'm just asking, because it is often the things we assume that bite us. I could have sworn that I'd opened a specific port only to find that I had, but a reboot reset the setting. It wasn't permanent. Double checking doesn't hurt. Double checking things over and over is useful - things change that we assume didn't change. Checking other things that you've already marked off as correct last week would be a good idea too.

    I'm still concerned that your DNS points to a localhost address (.1.1) and not to the router or to a public DNS server (using only IP addresses). I'm completely unfamiliar with 13.xx, but on my 12.04 systems, they point to a non-localhost address for DNS. No localhost DNS-caching server running on each machine is involved here.

    The more I think about this, the more it seems that DNS-caching on the local system is the culprit. Remove that program/service and you'll remove the issue. http://www.thelinuxguy.nl/how-tos/ho...n-ubuntulinux/ should help.

    I think mail.google.com is http-only. There's a different URL for HTTPS connections - something to do with universities needing to protect their networks, if I recall correctly. OTOH, I don't recall any of the details since I block most of the google URLs you are trying to access at the router. I'm not into being tracked everywhere on the internet. Of course, I could be wrong about the different URLs. Won't be the first time.

    Sorry that I'm running out of ideas. All of these things are shots in the dark.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •