Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: squid As A Proxy Server (External IP's Using This Server)

  1. #11
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    9,861
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: squid As A Proxy Server (External IP's Using This Server)

    Originally you said this was a problem with your "home PC" so I've been working from that assumption all along.

    If you are behind a corporate firewall, that is a very different story. The firewalls I build for clients would not let you connect to a high port either. In fact we block all traffic originating on high ports behind the firewall destined for high ports on remote servers. There is no reason ordinary users need that kind of access since they should be connecting to servers listening on ports below 1024 like 80, 443, etc.

    Letting people send random traffic from high ports behind the firewall to high ports on remote machines is just an invitation for them to run torrents, play games, or engage in other non-work-related activities that oftentimes consume bandwidth unnecessarily.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  2. #12
    Join Date
    Dec 2013
    Beans
    1

    Re: squid As A Proxy Server (External IP's Using This Server)

    hi there,

    I am new to the squid proxy and have followed these steps from this website -->http://www.danscourses.com/Linux-Fun...in-ubuntu.html

    Once i put my ip address in firefox and finish the steps upto here
    --> To re-enable web access uncomment line 676
    #http_access allow localnet
    to
    http_access allow localnet To verify the Web is now working, save your changes to the squid.conf file and restart your Squid server.
    service squid restart (or "sudo service squid restart" if you are no longer root)

    I get a mseesage "The proxy server is refusing connections'.

    I ran this test setup in vmware to test it. both guest and host networks show the same thing in the browser.

    I have DHCP enabled on my router. Could this conflict with the proxy settings? Do I have to turn DHCP off to get rid of that message that displays on the browser?

    Thanks.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •