Results 1 to 3 of 3

Thread: Get wlan0 to connect before MOUNT on 13.04 boot

  1. #1
    Join Date
    Jul 2011
    Beans
    15

    Question Get wlan0 to connect before MOUNT on 13.04 boot

    I have an old Toshiba Satellite laptop that I installed 13.04 on for my kids to play on. Normally boot time isn't an issue unless the ETH isn't connected and it falls back to WiFi.

    The way I have it setup currently, during the boot, it loads network before running mount so that network shares are mounted by Automount during the boot sequence.

    The problem is that if the eth isn't connected, I have to wait for the desktop to come up and the WiFi to connect, then manually run sudo mount -a to get the NFS shares mounted from my internal server.

    Is there a means by which I can get the WiFi to load, authenticate the WPA key and connect the shares for Automount on boot the way the ethernet does?

  2. #2
    Join Date
    Apr 2012
    Beans
    5,412

    Re: Get wlan0 to connect before MOUNT on 13.04 boot

    Not (afaik) using NetworkManager - you would need to do it via /etc/network/interfaces (and possibly disable NM) I think

    Alternatively you could consider using autofs to mount the network shares on demand from 'userland'

  3. #3
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    5,566
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Get wlan0 to connect before MOUNT on 13.04 boot

    Hi,

    change "false" to "true" in the /etc/NetworkManager/NetworkManager.conf and configure the interface in the respective file
    Code:
    auto wlan0
    iface wlan0 inet dhcp
    Did you check in your BIOS settings if the wireless is booted before the OS (if applicable)?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •