Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Fan goes at full speed

  1. #1
    Join Date
    Jun 2013
    Beans
    6

    Fan goes at full speed

    Hi guys,
    im sorry if anything is not acording to what its suposte to do i am new in this thing's of linux or forum and sorry again for my rusty english.
    Here it is my problem when i put my laptop its an HP 6730b [Intel® Core™2 Duo CPU P8400 @ 2.26GHz × 2, Mobile Intel® GM45 Express Chipset x86/MMX/SSE2 and i have installed ubuntu 13.04 whit windows 7 at the same time] but my problem is when i suspend my laptop when i restore again the fan goes at maximu speed and continue for ever until i shutdown, more strange is that the air that come out of the fan its cold so i think its not a problem of overheating.
    im a tired of shuthing of my pc...


    thank you

  2. #2
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Fan goes at full speed

    Hello and welcome to the forums.

    There is an existing bug report for this exact problem. See: https://bugs.launchpad.net/ubuntu/+s...x/+bug/1173997.

    Can you try the acpi_osi=Linux kernel parameter? See the "Kernel Boot Parameters" link in my signature for information on how to test the parameter. It would also be interesting to see your dmesg log file. From a terminal window, enter this command:
    Code:
    pastebinit /var/log/dmesg
    ...and post back the link that is generated.

  3. #3
    Join Date
    Jun 2013
    Beans
    6

    Re: Fan goes at full speed

    hi again Toz, how stupid is that im not able to type "=" on the kernel boot parameteres im using a portuguese keyboard and i tryed every single key and the equal dont show up :S
    so thats why i cant post back the link. any sugestion to solve this keybord problem?

  4. #4
    Join Date
    Jan 2008
    Location
    Ohio
    Beans
    71
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Fan goes at full speed

    a workaround... you could type it in your phone as an email.. save as draft. Then access your email on your computer and copy the text.

    Silly...but it will work.
    Warprunner
    This is one race of people for whom psychoanalysis is of no use whatsoever.
    ...Sigmund Freud (about the Irish)

  5. #5
    Join Date
    Jun 2013
    Beans
    6

    Re: Fan goes at full speed

    but on ubuntu i am able to type "=" only on kernel parameters window when i start the system im not able to type the equal, and i dont know how to copy on the terminal

  6. #6
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Fan goes at full speed

    Quote Originally Posted by dpedro View Post
    hi again Toz, how stupid is that im not able to type "=" on the kernel boot parameteres im using a portuguese keyboard and i tryed every single key and the equal dont show up :S
    so thats why i cant post back the link. any sugestion to solve this keybord problem?
    Try following the instructions under "Permanently Add a Kernel Boot Parameter" from within an ubuntu session. Your = key should work there. Make sure to run the "sudo update-grub" command as well then reboot.

  7. #7
    Join Date
    Jun 2013
    Beans
    6

    Re: Fan goes at full speed

    It worked men here it is dmesg log file, should i remove the kernel parameter?
    http://paste.ubuntu.com/5789972/
    this is enought to solve the problem ?

  8. #8
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Fan goes at full speed

    Quote Originally Posted by dpedro View Post
    It worked men here it is dmesg log file, should i remove the kernel parameter?
    http://paste.ubuntu.com/5789972/
    this is enought to solve the problem ?
    Does this solve your fan problem? If so, you'll need to leave the kernel parameter there (don't remove it).

  9. #9
    Join Date
    Jun 2013
    Beans
    6

    Re: Fan goes at full speed

    but it doesnt work like that unfortunately my fan continue going the same after suspend :S

  10. #10
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Fan goes at full speed

    In that case, you can remove the kernel parameter.

    Lets try this (from this kernel bug report):

    Code:
    gksu gedit /etc/pm/sleep.d/99_fanfix
    ...then copy/paste this code:
    Code:
    #!/bin/bash
    case $1 in
            thaw|resume)
               for x in /sys/class/thermal/cooling_device*/cur_state; do
                  echo 0 > $x
               done
            ;;
    esac
    ..then save the file and make it executable:
    Code:
    sudo chmod +x /etc/pm/sleep.d/99_fanfix
    Now try a suspend/resume and see if the fans behave.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •