Results 1 to 7 of 7

Thread: Wine won't work

  1. #1
    Join Date
    Jun 2013
    Beans
    3

    Wine won't work

    I hope I'm posting this in the right place.

    Anyway, I can't make Wine 1.6 work. No matter what I do, it brings the same monologue back up. I'm new-ish to Ubuntu. I know a few basic commands, but nothing too complicated.

    So, I just installed Ubuntu on this box on Monday, try to set up wine, and get this code:

    # sudo add-apt-repository ppa:ubuntu-wine/ppa
    You are about to add the following PPA to your system:
    Welcome to the Wine Team PPA. Here you can get the latest available Wine betas for every supported version of Ubuntu. This PPA is managed by Scott Ritchie and Maarten Lankhorst.
    More info: https://launchpad.net/~ubuntu-wine/+archive/ppa
    Press [ENTER] to continue or ctrl-c to cancel adding it

    gpg: keyring `/tmp/tmpPnXT64/secring.gpg' created
    gpg: keyring `/tmp/tmpPnXT64/pubring.gpg' created
    gpg: requesting key F9CB8DB0 from hkp server keyserver.ubuntu.com
    gpg: /tmp/tmpPnXT64/trustdb.gpg: trustdb created
    gpg: key F9CB8DB0: public key "Launchpad PPA for Ubuntu Wine Team" imported
    gpg: no ultimately trusted keys found
    gpg: Total number processed: 1
    gpg: imported: 1 (RSA: 1)
    OK

    # sudo apt-get update
    Hit http://us.archive.ubuntu.com precise Release.gpg
    Get:1 http://us.archive.ubuntu.com precise-updates Release.gpg [198 B]
    Hit http://us.archive.ubuntu.com precise-backports Release.gpg
    Hit http://us.archive.ubuntu.com precise Release
    Get:2 http://us.archive.ubuntu.com precise-updates Release [49.6 kB]
    Get:3 http://extras.ubuntu.com precise Release.gpg [72 B]
    Hit http://ppa.launchpad.net precise Release.gpg
    Get:4 http://security.ubuntu.com precise-security Release.gpg [198 B]
    Hit http://us.archive.ubuntu.com precise-backports Release
    Hit http://ppa.launchpad.net precise Release
    Hit http://extras.ubuntu.com precise Release
    Get:5 http://security.ubuntu.com precise-security Release [49.6 kB]
    Hit http://us.archive.ubuntu.com precise/main Sources
    Hit http://us.archive.ubuntu.com precise/restricted Sources
    Hit http://us.archive.ubuntu.com precise/universe Sources
    Hit http://us.archive.ubuntu.com precise/multiverse Sources
    Hit http://us.archive.ubuntu.com precise/main i386 Packages
    Hit http://us.archive.ubuntu.com precise/restricted i386 Packages
    Hit http://us.archive.ubuntu.com precise/universe i386 Packages
    Hit http://us.archive.ubuntu.com precise/multiverse i386 Packages
    Hit http://us.archive.ubuntu.com precise/main TranslationIndex
    Hit http://us.archive.ubuntu.com precise/multiverse TranslationIndex
    Hit http://us.archive.ubuntu.com precise/restricted TranslationIndex
    Hit http://us.archive.ubuntu.com precise/universe TranslationIndex
    Get:6 http://us.archive.ubuntu.com precise-updates/main Sources [396 kB]
    Hit http://ppa.launchpad.net precise/main Sources
    Hit http://extras.ubuntu.com precise/main Sources
    Hit http://ppa.launchpad.net precise/main i386 Packages
    Ign http://ppa.launchpad.net precise/main TranslationIndex
    Hit http://extras.ubuntu.com precise/main i386 Packages
    Ign http://extras.ubuntu.com precise/main TranslationIndex
    Get:7 http://security.ubuntu.com precise-security/main Sources [80.9 kB]
    Get:8 http://us.archive.ubuntu.com precise-updates/restricted Sources [5,467 B]
    Get:9 http://us.archive.ubuntu.com precise-updates/universe Sources [90.9 kB]
    Get:10 http://us.archive.ubuntu.com precise-updates/multiverse Sources [6,571 B]
    Get:11 http://us.archive.ubuntu.com precise-updates/main i386 Packages [657 kB]
    Get:12 http://security.ubuntu.com precise-security/restricted Sources [2,494 B]
    Get:13 http://security.ubuntu.com precise-security/universe Sources [26.3 kB]
    Get:14 http://security.ubuntu.com precise-security/multiverse Sources [1,383 B]
    Get:15 http://security.ubuntu.com precise-security/main i386 Packages [307 kB]
    Get:16 http://us.archive.ubuntu.com precise-updates/restricted i386 Packages [10.0 kB]
    Get:17 http://us.archive.ubuntu.com precise-updates/universe i386 Packages [209 kB]
    Get:18 http://us.archive.ubuntu.com precise-updates/multiverse i386 Packages [13.8 kB]
    Hit http://us.archive.ubuntu.com precise-updates/main TranslationIndex
    Hit http://us.archive.ubuntu.com precise-updates/multiverse TranslationIndex
    Hit http://us.archive.ubuntu.com precise-updates/restricted TranslationIndex
    Hit http://us.archive.ubuntu.com precise-updates/universe TranslationIndex
    Hit http://us.archive.ubuntu.com precise-backports/main Sources
    Hit http://us.archive.ubuntu.com precise-backports/restricted Sources
    Hit http://us.archive.ubuntu.com precise-backports/universe Sources
    Hit http://us.archive.ubuntu.com precise-backports/multiverse Sources
    Hit http://us.archive.ubuntu.com precise-backports/main i386 Packages
    Ign http://extras.ubuntu.com precise/main Translation-en_US
    Hit http://us.archive.ubuntu.com precise-backports/restricted i386 Packages
    Hit http://us.archive.ubuntu.com precise-backports/universe i386 Packages
    Hit http://us.archive.ubuntu.com precise-backports/multiverse i386 Packages
    Hit http://us.archive.ubuntu.com precise-backports/main TranslationIndex
    Hit http://us.archive.ubuntu.com precise-backports/multiverse TranslationIndex
    Ign http://ppa.launchpad.net precise/main Translation-en_US
    Hit http://us.archive.ubuntu.com precise-backports/restricted TranslationIndex
    Hit http://us.archive.ubuntu.com precise-backports/universe TranslationIndex
    Hit http://us.archive.ubuntu.com precise/main Translation-en
    Hit http://us.archive.ubuntu.com precise/multiverse Translation-en
    Hit http://us.archive.ubuntu.com precise/restricted Translation-en
    Hit http://us.archive.ubuntu.com precise/universe Translation-en
    Hit http://us.archive.ubuntu.com precise-updates/main Translation-en
    Hit http://us.archive.ubuntu.com precise-updates/multiverse Translation-en
    Hit http://us.archive.ubuntu.com precise-updates/restricted Translation-en
    Hit http://us.archive.ubuntu.com precise-updates/universe Translation-en
    Ign http://extras.ubuntu.com precise/main Translation-en
    Hit http://us.archive.ubuntu.com precise-backports/main Translation-en
    Hit http://us.archive.ubuntu.com precise-backports/multiverse Translation-en
    Hit http://us.archive.ubuntu.com precise-backports/restricted Translation-en
    Hit http://us.archive.ubuntu.com precise-backports/universe Translation-en
    Ign http://ppa.launchpad.net precise/main Translation-en
    Get:19 http://security.ubuntu.com precise-security/restricted i386 Packages [4,620 B]
    Get:20 http://security.ubuntu.com precise-security/universe i386 Packages [78.6 kB]
    Get:21 http://security.ubuntu.com precise-security/multiverse i386 Packages [2,367 B]
    Hit http://security.ubuntu.com precise-security/main TranslationIndex
    Hit http://security.ubuntu.com precise-security/multiverse TranslationIndex
    Hit http://security.ubuntu.com precise-security/restricted TranslationIndex
    Hit http://security.ubuntu.com precise-security/universe TranslationIndex
    Hit http://security.ubuntu.com precise-security/main Translation-en
    Hit http://security.ubuntu.com precise-security/multiverse Translation-en
    Hit http://security.ubuntu.com precise-security/restricted Translation-en
    Hit http://security.ubuntu.com precise-security/universe Translation-en
    Fetched 1,992 kB in 4s (407 kB/s)
    Reading package lists... Done


    # sudo apt-get install wine1.6
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    wine1.6 : Depends: wine1.6-i386 (= 1.6~rc2-0ubuntu1~ppa3) but 1.6~rc2-0ubuntu1~ppa1 is to be installed
    wine1.6-i386 : Depends: wine1.6 (= 1.6~rc2-0ubuntu1~ppa1) but 1.6~rc2-0ubuntu1~ppa3 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

    And so, I did what it asked;


    root@andersons-eM250:~# sudo apt-get install -f
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
    wine1.6 wine1.6-i386
    Suggested packages:
    dosbox
    The following packages will be upgraded:
    wine1.6 wine1.6-i386
    2 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
    2 not fully installed or removed.
    Need to get 0 B/25.5 MB of archives.
    After this operation, 12.3 kB disk space will be freed.
    Do you want to continue [Y/n]? y
    dpkg: dependency problems prevent configuration of wine1.6:
    wine1.6 depends on wine1.6-i386 (= 1.6~rc2-0ubuntu1~ppa2); however:
    Version of wine1.6-i386 on system is 1.6~rc2-0ubuntu1~ppa1.
    dpkg: error processing wine1.6 (--configure):
    dependency problems - leaving unconfigured
    No apport report written because the error message indicates its a followup error from a previous failure.
    dpkg: dependency problems prevent configuration of wine1.6-i386:
    wine1.6-i386 depends on wine1.6:any (= 1.6~rc2-0ubuntu1~ppa1); however:
    Version of wine1.6 on system is 1.6~rc2-0ubuntu1~ppa2.
    dpkg: error processing wine1.6-i386 (--configure):
    dependency problems - leaving unconfigured
    No apport report written because the error message indicates its a followup error from a previous failure.
    Errors were encountered while processing:
    wine1.6
    wine1.6-i386
    E: Sub-process /usr/bin/dpkg returned an error code (1)



    I don't know what to do, and I kind of need to get this fixed by the end of the week. Thank y'all!

  2. #2
    Join Date
    May 2007
    Beans
    13,132

    Re: Wine won't work

    Different versions of Wine tend to work better with different versions of Ubuntu -- so, what version of Ubuntu are you using?

    Also, it says you have unmet dependencies, which means some packages are missing. Could be a repository issue.

    Sorry, I don't use Wine (personal reasons) ... so you'll have to wait for someone else to come along.
    Last edited by Mark Phelps; June 20th, 2013 at 09:10 PM.
    Ubuntu 15.04 Mate, Mint 17.1; MS Win 8.1, Win10 TP.
    Will not respond to PM requests for support -- use the forums.

  3. #3
    Join Date
    Jun 2013
    Beans
    3

    Re: Wine won't work

    I'm using 12.04 LTS for 32-bit

  4. #4
    Join Date
    May 2007
    Beans
    13,132

    Re: Wine won't work

    Maybe you should read through this thread: http://ubuntuforums.org/showthread.php?t=2154621
    Ubuntu 15.04 Mate, Mint 17.1; MS Win 8.1, Win10 TP.
    Will not respond to PM requests for support -- use the forums.

  5. #5
    Join Date
    Jun 2013
    Beans
    3

    Re: Wine won't work

    Thanks, it worked!

  6. #6
    Join Date
    Jun 2013
    Beans
    5

    Re: Wine won't work

    jnanderson96 Edit the post and mark it as solved so people don't get confused.

  7. #7
    Join Date
    Aug 2011
    Location
    Melbourne, Australia.
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Wine won't work

    Quote Originally Posted by noasad View Post
    jnanderson96 Edit the post and mark it as solved so people don't get confused.
    Hi, Here's how to mark your first post as solved -

    https://wiki.ubuntu.com/UnansweredPo.../SolvedThreads

    Cheers -
    PopularPages: A very handy Documentation Search Tool used by many.
    PopularPages Wiki Thread
    My New Blog

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •