Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: HP Pavilion dv7, video card issues

  1. #1
    Join Date
    Jun 2013
    Beans
    11

    HP Pavilion dv7, video card issues

    Hello I am very new to ubuntu but jumped all in on it. I have a hp pavilion dv7 which was having some issues with windows 7 so I decided to put ubuntu 12.04 on here. I now cannot use my hdmi port on the pc and also if I try to make a video full screen it lags really bad on the video but you can hear the audio perfectly fine. I really need some help I read that I may need a proprietary driver but it has been so long since I have dealt with the video card in this laptop I have forgotten which one is in here. Is this something I can find out through the terminal? And once I find this out how do I install a proprietary driver?

  2. #2
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    7,237
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Video card issues

    Hi hondaprelude.

    Could you post the output of this command?
    Code:
    lspci -nnk | grep -iA2 vga
    Regards.

  3. #3
    Join Date
    Jun 2013
    Beans
    11

    Re: Video card issues

    Ok so I found the lspci command and this is the information I got:

    01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS880M [Mobility Radeon HD 4200 Series] (prog-if 00 [VGA controller])
    Subsystem: Hewlett-Packard Company Device 1641
    Flags: bus master, fast devsel, latency 0, IRQ 18
    Memory at d0000000 (32-bit, prefetchable) [size=256M]
    I/O ports at 4000 [size=256]
    Memory at f0400000 (32-bit, non-prefetchable) [size=64K]
    Memory at f0300000 (32-bit, non-prefetchable) [size=1M]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: radeon
    Kernel modules: radeon


    02:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Robson CE [AMD Radeon HD 6300 Series] (prog-if 00 [VGA controller])
    Subsystem: Hewlett-Packard Company Device 1641
    Flags: bus master, fast devsel, latency 0, IRQ 44
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    Memory at f0200000 (64-bit, non-prefetchable) [size=128K]
    I/O ports at 3000 [size=256]
    [virtual] Expansion ROM at f0240000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: radeon
    Kernel modules: radeon


    02:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Cedar HDMI Audio [Radeon HD 5400/6300 Series]
    Subsystem: Hewlett-Packard Company Device 1641
    Flags: bus master, fast devsel, latency 0, IRQ 45
    Memory at f0220000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd-hda-intel

    I do have a switchable video card for when its plugged in or unplugged from power is this some of my issue any and all help will be much appreciated.

  4. #4
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    7,237
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Video card issues

    Thanks.

    The result is a little odd to me, as you had 2 discrete graphic cards (may be one is the mobo's integrated graphics).

    Any way, open the application 'Additional Drivers'. There it should be listed the proprietary AMD driver so you can install it. It may require restart the machine to take effect.

    Let us know how it goes.
    Regards.

  5. #5
    Join Date
    Jun 2013
    Beans
    11

    Re: Video card issues

    Ok so an update I found 3 proprietary drivers in the additional driver application but none of them helped they didn't make it worse but at the same time they didn't make it any different. here is a screen shot of the drivers I tried to install.
    [IMG][/IMG]

  6. #6
    Join Date
    Jun 2013
    Beans
    11

    Re: Video card issues

    Has anyone encountered this issue before. I still am unable to use my hdmi cord or watch a video full screen because of this.

  7. #7
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    10,095
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Video card issues

    You have a machine with hybrid video. Go into the BIOS and switch to "fixed mode". Afterwards, try installing the driver again.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  8. #8
    Join Date
    Jun 2013
    Beans
    11

    Re: Video card issues

    Ok thank you I will try that and let everyone know how it goes.

  9. #9
    Join Date
    Jun 2013
    Beans
    11

    Re: Video card issues

    There is no option in the BIOS for this laptop to change it to only use a single graphics card instead of the hybrid system.

  10. #10
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    7,237
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Video card issues

    Set that, and then run this command to know which one got selected (with luck it'll be the 6300):
    Code:
    lspci -nnk | grep -iA2 vga
    Regards.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •