Results 1 to 3 of 3

Thread: alt gr not working

  1. #1
    Join Date
    Apr 2013
    Beans
    2

    alt gr not working

    ( Sorry, the title should be ' "alt gr"-key is not working properly' )

    Hi

    I just installed ubuntu 13.10 and now my 'alt gr' key is not working how it should.

    When i run xev, pressing 'alt gr' gives:

    Code:
    KeyPress event, serial 41, synthetic NO, window 0x3800001,
         root 0x256, subw 0x0, time 597707, (-545,157), root:(245,209),
         state 0x10, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
         XKeysymToKeycode returns keycode: 92     XLookupString gives 0 bytes:
         XmbLookupString gives 0 bytes:
         XFilterEvent returns: False
    
      KeyRelease event, serial 41, synthetic NO, window 0x3800001,
         root 0x256, subw 0x0, time 597787, (-545,157), root:(245,209),
         state 0x98, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
         XKeysymToKeycode returns keycode: 92
        XLookupString gives 0 bytes:
         XFilterEvent returns: False
    and ISO_Level3_Shift should be right ... but the key seems to function more like an 'alt'-key ( 'alt-gr'+E does not produce an euro-sign (like it should on a french keyboard), but instead opens the menu 'Edit' ... but 'alt-gr'+Tab does not change windows)

    Setting "Key to choose 3rd level" in Keyboard > Layout Settings to "Right Alt" does not make it better.

    Any ideas ?
    Last edited by wildgeier; June 20th, 2013 at 04:51 PM.

  2. #2
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,617
    Distro
    Ubuntu Development Release

    Re: alt gr not working

    Thread moved to Ubuntu +1.
    Join us on irc at #ubuntuforums. For web chat see here

    If you believe everything you read, you better not read. ~ Japanese Proverb

    Do not read newspapers on an empty stomach ~ Russian Proverb ~ BrunoLotse

  3. #3
    Join Date
    Apr 2013
    Beans
    2

    Re: alt gr not working

    This work-around worked for me:

    -map keycode 108 to "Mode_switch" instead of "ISO_Level3_Shift"

    -edit the .Xmodmap file (copy the "ISO_Level3_Shift" column to the "Mode_switch" column)
    Last edited by wildgeier; June 22nd, 2013 at 11:18 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •