Results 1 to 9 of 9

Thread: problem with apt-get upgrade

  1. #1
    Join Date
    Jun 2012
    Beans
    9

    problem with apt-get upgrade

    when I run
    Code:
    sudo apt-get upgrade
    , the following error rises

    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages have been kept back:
      mysql-client-5.5 mysql-server-5.5 mysql-server-core-5.5
    The following packages will be upgraded:
      accountsservice apport apt apt-transport-https apt-utils aptitude bash bash-completion bind9-host curl dbus dmsetup dnsutils icedtea-6-jre-cacao
      icedtea-6-jre-jamvm iptables isc-dhcp-client isc-dhcp-common language-selector-common libaccountsservice0 libapt-inst1.4 libapt-pkg4.12 libasound2
      libbind9-80 libc-bin libc-dev-bin libc6 libc6-dev libcups2 libcupsimage2 libcurl3 libcurl3-gnutls libdbus-1-3 libdevmapper1.02.1 libdns81
      libdrm-intel1 libdrm-nouveau1a libdrm-radeon1 libdrm2 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libgnutls26 libisc83 libisccc80 libisccfg82
      liblwres80 libmysqlclient-dev libmysqlclient18 libnspr4 libnss3 libnss3-1d libplymouth2 libservlet2.5-java libssl-dev libssl-doc libssl1.0.0
      libtiff4 libtomcat6-java libudev0 libx11-6 libx11-data libx11-xcb1 libxcb-glx0 libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb1 libxext6
      libxfixes3 libxi6 libxinerama1 libxml2 libxrender1 libxslt1.1 libxt6 libxtst6 libxv1 libxxf86dga1 libxxf86vm1 linux-libc-dev multiarch-support
      mysql-client mysql-client-core-5.5 mysql-common mysql-server nginx nginx-common nginx-full openjdk-6-jre-headless openjdk-6-jre-lib openssh-client
      openssh-server openssl perl perl-base perl-modules plymouth plymouth-theme-ubuntu-text python-apport python-apt python-apt-common python-mysqldb
      python-paramiko python-problem-report rsyslog tomcat6 tomcat6-admin tomcat6-common tomcat6-docs tomcat6-examples udev
    112 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
    Need to get 0 B/88.4 MB of archives.
    After this operation, 204 kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    dpkg-deb: error: subprocess tar was killed by signal (Segmentation fault), core dumped
    dpkg: error processing /var/cache/apt/archives/bash_4.2-2ubuntu2.1_i386.deb (--unpack):
     subprocess dpkg-deb --control returned error exit status 2
    No apport report written because MaxReports is reached already
                                                                  Errors were encountered while processing:
     /var/cache/apt/archives/bash_4.2-2ubuntu2.1_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    EDIT:
    When I run:
    Code:
    sudo apt-get install --reinstall tar
    it outputs:
    Code:
    dpkg-deb: error: subprocess tar was killed by signal (Segmentation fault), core dumpeddpkg: error processing /var/cache/apt/archives/tar_1.26-4ubuntu1_i386.deb (--unpack):
     subprocess dpkg-deb --control returned error exit status 2
    Errors were encountered while processing:
     /var/cache/apt/archives/tar_1.26-4ubuntu1_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Last edited by amrnegm; June 19th, 2013 at 11:47 AM.

  2. #2
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    Re: problem with apt-get upgrade

    Try...
    Code:
    sudo apt-get clean && sudo apt-get upgrade
    It looks like the bash_4.2-2ubuntu2.1_i386.deb package on your system is corrupted.
    Cheesemill

  3. #3
    Join Date
    Jun 2012
    Beans
    9

    Re: problem with apt-get upgrade

    Quote Originally Posted by Cheesemill View Post
    Try...
    Code:
    sudo apt-get clean && sudo apt-get upgrade
    It looks like the bash_4.2-2ubuntu2.1_i386.deb package on your system is corrupted.
    I tried it, but it outputs the same error

  4. #4
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    8,164
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: problem with apt-get upgrade

    amrnegm;
    That is odd as "apt-get clean" should have cleaned out the /archive ...what results then this code:
    Code:
    dpkg --contents /var/cache/apt/archives/bash_4.2-2ubuntu2.1_i386.deb
    sometimes I wonder, and other times I just do not know
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  5. #5
    Join Date
    Jun 2013
    Beans
    54

    Re: problem with apt-get upgrade

    It appears that tar segfaulted. This is quite unusual. Try: sudo apt-get install --reinstall tar

  6. #6
    Join Date
    Jun 2012
    Beans
    9

    Re: problem with apt-get upgrade

    when I run the command:
    Code:
    dpkg --contents /var/cache/apt/archives/bash_4.2-2ubuntu2.1_i386.deb
    it outputs:
    Code:
    dpkg-deb: error: subprocess tar was killed by signal (Segmentation fault), core dumped

  7. #7
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    8,164
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: problem with apt-get upgrade

    amrnegm; Hey !

    I have given some thought...what results:
    Code:
    ls -ld /var/cache/apt/archives/bash_4.2-2ubuntu2.1_i386.deb ##just to see what happens.
    sudo rm -f /var/cache/apt/archives/bash_4.2-2ubuntu2.1_i386.deb ##remove it as it is corrupted.
    sudo apt-get install --reinstall bash
    

    no harm in try'n

    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  8. #8
    Join Date
    Jun 2012
    Beans
    9

    Re: problem with apt-get upgrade

    thanks Bashing-om,

    when I try your suggestion it outputs the following error:
    Code:
    dpkg-deb: error: subprocess tar was killed by signal (Segmentation fault), core dumped
    dpkg: error processing /var/cache/apt/archives/bash_4.2-2ubuntu2.1_i386.deb (--unpack):
     subprocess dpkg-deb --control returned error exit status 2
    Errors were encountered while processing:
     /var/cache/apt/archives/bash_4.2-2ubuntu2.1_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    I think the problem is with tar itself, since it outputs the following error for just typing 'tar' in the shell:
    Code:
    Segmentation fault (core dumped)
    I tried to install tar itself, but nothing changed.
    Last edited by amrnegm; June 21st, 2013 at 10:00 PM.

  9. #9
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    8,164
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: problem with apt-get upgrade

    amrnegm;

    Ok, let's see what the package manager has to say about "tar" :
    Code:
    dpkg -l tar
    will give a system status of that package.

    Truly can not do much if "tar" is broke !

    regards

    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •