Results 1 to 6 of 6

Thread: Openvpn server doesn't start

  1. #1
    Join Date
    Dec 2012
    Beans
    3

    Question Openvpn server doesn't start

    Hi,

    I'm not an expert user but trying to run a vpn server on Ubuntu.
    I followed this tutorial https://help.ubuntu.com/11.10/serverguide/openvpn.html
    and installation went well but the openvpn server doesn't start. I get this error:

    # /etc/init.d/openvpn start

    * Starting virtual private network daemon(s)...
    * Autostarting VPN 'server' S
    IOCSIFADDR: No such device
    : ERROR while getting interface flags: No such device
    SIOCSIFDSTADDR: No such device
    : ERROR while getting interface flags: No such device
    SIOCSIFMTU: No such device

    # /etc/init.d/openvpn status
    * VPN 'server' is not running

    It seems that tun interface isn't created but I'm not sure.
    Can anyone help, please?

    Thanks

  2. #2
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    8,604
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Openvpn server doesn't start

    Add "dev tun" to the top of the OpenVPN configuration file and see if it helps.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  3. #3
    Join Date
    Dec 2012
    Beans
    3

    Re: Openvpn server doesn't start

    dev tun was uncommented

  4. #4
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    8,604
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Openvpn server doesn't start

    What do you seen in /var/log/syslog? For instance in this discussion, the problem was that it wanted to create the tun device in /dev/net/tun, but there was no such directory or device. However, I just installed OpenVPN from the repositories (with "sudo apt-get install openvpn"), and see this:

    Code:
    root@vid:/# ls /dev/net -l
    total 0
    crw-rw-rwT 1 root root 10, 200 Nov 26 13:27 tun
    Did you install the repository version or install it some other way? The repository version has always worked for me.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  5. #5
    Join Date
    Dec 2012
    Beans
    3

    Re: Openvpn server doesn't start

    # ls /dev/net -l
    ls: cannot access /dev/net: No such file or directory

    I re-installed openvpn from the repositories and it didn't help.

    Apparently, there isn't a tun device on my OS.
    I just found out that this is due to kernel not installed properly.
    Last edited by ksylian; December 8th, 2012 at 06:42 PM.

  6. #6
    Join Date
    May 2010
    Location
    France
    Beans
    13

    Re: Openvpn server doesn't start

    Here what solved my problem :
    Code:
    # mkdir /dev/net 
    # mknod /dev/net/tun c 10 200  
    # chmod 666 /dev/net/tun
    And here is the problem I had (syslog also complained about directory net that doesn't exist)
    Code:
    service openvpn start
     * Starting virtual private network daemon(s)...                                         *   Autostarting VPN 'server'                                                          SIOCSIFADDR: No such device
    : ERROR while getting interface flags: No such device
    SIOCSIFDSTADDR: No such device
    : ERROR while getting interface flags: No such device
    SIOCSIFMTU: No such device

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •