Page 4 of 4 FirstFirst ... 234
Results 31 to 39 of 39

Thread: Dell Latitude E6230 Wireless Issues

  1. #31
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues

    Hmm, very interesting!

    I didn't do anything "special" to get that version...just got it through apt-get as I was told by Dell to do. They say that driver is the correct one for this computer. I'm not sure of how to "downgrade" drivers exactly--especially since this was not a specially downloaded driver--I got it straight from the Ubuntu repositories.

    Just to ask:

    I did NOT make it persistent and here's why: I note that I can only run the command as sudo. If I put "sudo [anything]" in rc.local how does the machine operate on that? I mean, doesn't a password have to be entered once the machine hits the "sudo" command in rc.local?

    Also, it says in the file that the rc.local is disabled and to "change the execution bits" to enable it. I assume that this means to set user, group and world to "execute" using chmod? Right now I did an "ls -la" on the file and it appears to be set already to 755. So, although there is nothing in the file, it is ALREADY executing, correct?

    This is actually a question that I've had all along--if I have a "sudo" in a script and a user with less-than-admin privs goes to run it how does Linux handle that? Does it prompt for a PW? Does it depend on how the said file is chmod'ed?

    Thanks!

    Ron
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

  2. #32
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,407
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Dell Latitude E6230 Wireless Issues

    This is actually a question that I've had all along--if I have a "sudo" in a script and a user with less-than-admin privs goes to run it how does Linux handle that? Does it prompt for a PW? Does it depend on how the said file is chmod'ed?
    I'm not an expert on scripts, but I doubt it is advisable to include sudo in them. I believe the idea is to require sudo to run the entire script instead of its component parts.
    Code:
    sudo some_script
    I did NOT make it persistent and here's why: I note that I can only run the command as sudo. If I put "sudo [anything]" in rc.local how does the machine operate on that? I mean, doesn't a password have to be entered once the machine hits the "sudo" command in rc.local?
    /etc/rc.local is run in its entirety by the system with full (~sudo) priveleges. Therefor, you can put the commands in without sudo; for example:
    Code:
    <snip>
    # By default this script does nothing.
    
    modprobe -r wl
    sleep 3
    modprobe wl
    iw reg set US
    
    exit 0
    it appears to be set already to 755. So, although there is nothing in the file, it is ALREADY executing, correct?
    Correct, although until you add something it is only executing 'exit 0'. I suppose one could, for reasons unknown to me, disable rc.local by chmodding to 600 so it was readable and writable by root only but not executable.

    Just for the fun of it, let's try rc.local and let me know the result. Off to lunch.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #33
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues

    Thank you for such a detailed and great post! I learned a lot of things that I had always wondered about. So basically everything in /etc/rc.local is run with root privileges, correct? So all I need to do is basically apply a chmod 755 to the file and it will run, as root, and run the commands as "sudo" automatically. So, basically, this file IS exactly what I was referring to--the Linux equivalent to an "autoexec.bat" file, right? Any commands/calls that I have in this file will run at startup. That is, if I am right about that.

    Another question: do you think that I should simply do pretty much exactly what you just did there and add nearly the same snip of code to my rc.local? By the looks of it that will basically run the commands that I've been running "by hand" to get the wifi to work.

    It may not be the "right" way to do it, precisely, but the cool thing is that it looks to me like that would work. What's your opinion on this? A better question would be: are there any disadvantages to doing things like this that way? I mean, I can't think of any off the top of my head. The only thing that I wonder is when, exactly, is the rc.local run? Will the correct system resources already be up and loaded? What I'm getting at: if I put the modprobe commands in the rc.local will the hardware be ready to accept them? Is there a "rule" on this? Is the rc.local run near last when the system is starting up? I ask because, since its a file, it won't show up in a ps. If/when it runs it should show up in boot.log or some other log, correct?

    It really, at this point, doesn't matter to me how or why this isn't working. What we DO know is that those modprobe commands get it to fire up. And the person that is to be using this machine will never, ever open a terminal I'm guessing.

    Thanks for the help on this one Chilii! If you give the green light I will just go ahead and get these commands into the rc.local...and be done with this issue.

    Ron
    Last edited by rondamato; June 24th, 2013 at 06:34 PM.
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

  4. #34
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues

    Just to let you know, I added this to the rc.local (before the exit 0)

    Code:
    sudo modprobe -r wl
    sleep 3
    sudo modproe wl
    iw reg set US
    It did not work. Rather, the locale setting worked, the network settings did not.

    I surmise the reason is this: when I cold-boot the computer, it takes about 30 sec to 1 minute for "Guest" to show up in the list of available wireless networks. For some reason the first two (the protected ones) show up nearly instantly, but "Guest" takes longer.

    If I wait about 45 seconds to be safe and run:

    Code:
    sudo modprobe -r wl
    sudo modprobe wl
    it works; the machine connects to "Guest" right away.

    So it was a good idea...but it didn't do the trick. Hey, at least I am now SURE of how the rc.local file works, and I have you to thank for that!
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

  5. #35
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Dell Latitude E6230 Wireless Issues

    Hi, change the rc file to..
    Code:
    sleep 60
    this will give it a full minute to execute
    the reloading of the wl driver...so by that
    time...your guest wap will be available.
    then do..
    Code:
    sudo gedit /etc/modules
    remove wl
    save and close gedit.
    this will prevent /etc/modules and rc.local from
    fighting over who gets to load the wl dirver.
    Last edited by Hadaka; June 24th, 2013 at 07:04 PM.
    Craving anchovy, herring and squid pizza.....with clam sauce

  6. #36
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues

    Hello!

    OK, went into /etc/modules and commented out the "wl" line.

    I then replaced the
    Code:
    sleep 3
    line with
    Code:
    sleep 60
    . I even tried a short sleep before all of the modprobes.

    For some reason, it still will not work. When I type the password and the desktop comes up, the wifi icon is "outlined" and the pop-up says "Disconnected-You are now offline."

    In the meantime (before the 60 seconds is up) I looked in the drop-down for the wireless icon. There are no APs listed there. The APs do not show up until the sleep is commenced...and by that time it's too late. It runs the modprobes but, since "Guest" just popped into the list, it does not connect to it.

    After 60 seconds the icon starts "scanning" and the list of APs populates...however, the machine does not connect to "Guest"--even if I pick it from the drop-down.

    Since this did not work I went and un-commented the "wl" line from /etc/modules and then re-commented every line in /etc/rc.local except for the
    Code:
    iw reg set US
    line.

    Rebooted and am back to where I was. I, of course, can still simply wait until the drop-down populates and then issue the modprobe commands to get the wifi connected.

    It seems that, if there were a way to run those lines AFTER the desktop were loaded we'd be good.

    Anyhow, thank you again!

    R
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

  7. #37
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,407
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Dell Latitude E6230 Wireless Issues

    Code:
    sudo modprobe -r wl
    sleep 3
    sudo modproe wl
    iw reg set US
    It did not work. Rather, the locale setting worked, the network settings did not.
    Doctor! After all we discussed!!

    Please try, instead:
    Code:
    modprobe -r wl
    sleep 3
    modprobe wl
    iw reg set US
    I still want to address the version you have; in particular:
    just got it through apt-get as I was told by Dell to do.
    How or where did Dell tell you to do this?

    I wonder if this is perhaps actually a Network Manager issue. Obviously, when you unload wl, NM can't connect and then can't start trying again until it's reloaded.
    So all I need to do is basically apply a chmod 755 to the file and it will run, as root, and run the commands as "sudo" automatically.
    I think it is such already. You needn't chmod at all; you simply need to add some things to run to get it to work.
    It may not be the "right" way to do it, precisely, but the cool thing is that it looks to me like that would work
    Perhaps it would work; however, there seems to be another underlying problem. In most cases wl connects like a champ with no human intervention. We need to correct that deficiency.

    When you right-click the NM icon and select 'Edit Connections' is it set to automatically connect to anything? To Guest? To something else?? Please see attached.
    Attached Images Attached Images
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  8. #38
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues

    Hello,

    I am not at work now but let me clarify some things:

    First of all, the sleep was set to THIRTY, not three. Also I DID type "modprobe." My trusty IBM Model M keyboard has been skipping certain letters and spaces...think that I may be overloading the buffer...but that's another matter. ALSO...when I added those lines I did not prefix the modprobe commands with "sudo"--that was just me blasting out a post without thinking of what I was writing. I am aware that sudo is not needed in the rc.local file. Well, at least NOW I am aware of that! ; ')

    My company is HUGE and has all of its computers supplied by Dell. We have MANY "support specialists" dedicated solely to us. One of these specialists (who's title says that she is an 'Ubuntu Support Specialist') told me to use ONLY the Ubuntu Software Center or the apt-get utility (of course I went with apt-get since I HATE guis) to install the "bcmwl-kernel-source" package because they would "automatically blacklist the right drivers" (which, btw, she was wrong about--I blacklisted them myself). I simply ran
    Code:
    sudo apt-get bcmwl-kernel-source
    and the machine installed the driver from the Ubuntu repos. I did NOT at any time install any other drivers. I guess that this is the very first laptop that Dell has actually certified for Ubuntu--and will allow you to order with 12.04LTS pre-installed, although this machine had Win7 installed on it. I simply re-partitioned the drive and put Ubuntu on it from a bootable USB stick.

    Sorry about that--I will be more dilligent about proofreading my posts in the future!

    Anyhow, I put it back to the way that it was; I fired up vim and commented out the lines that I added in the /etc/rc.local file and also uncommented the "wl" driver in /etc/modules...so I am back to where I started. The
    Code:
    modprobe -r wl
    followed by the
    Code:
    modprobe wl
    gets the wireless up and running with absolutely no issues.

    I even tried to create a very simple shell-script called "wifi" which could be run from the user's homedir...but that didn't work. I got an error telling me, in essence, that the script could not unload (-r) the wl driver. I suppose that this was due to a permissions violation. I have not done any shellscripting in many years and could not remember if I could put sudos in there.

    Anyhow, glad to clarify all of that. When I am back at work tomorrow morning with the computer in question I will try what you told me to try and see where we are left, OK?

    Thank you guys very much, as usual!

    Ron
    Last edited by rondamato; June 25th, 2013 at 02:34 AM.
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

  9. #39
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,407
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Dell Latitude E6230 Wireless Issues

    My company is HUGE and has all of its computers supplied by Dell. We have MANY "support specialists" dedicated solely to us.
    Very interesting. I had not been aware of such a thing previously. I certainly thought a hardware vendor would station support specialists at a major customer, but since Ubuntu is such a niche, I am enlightened to find that a Dell Ubuntu specialist would be provided! Are there many Ubuntu computers there?
    One of these specialists (who's title says that she is an 'Ubuntu Support Specialist') told me to use ONLY the Ubuntu Software Center or the apt-get utility
    Very good advice. As an experiment, I will load up a live CD and install linux-image-3.5.0-23-generic and bcmwl-kernel-source and see what I get. I'm not saying it's incorrect; I'm saying it's puzzling.

    Going back to the thought that i may actually be a Network Manager issue, instead of unloading and reloading wl, please reboot and then try:
    Code:
    sudo service network-manager stop
    sudo service network-manager start
    Does it connect? If this lappy is staying at work, you may consider removing NM altogether and coding the connection details into /etc/network/interfaces.

    Are there any clues as to what's wrong here, run immediately after boot?
    Code:
    cat /var/log/syslog | grep -e wl -e etwork -e eth1 | tail -n25
    After you do connect, let's see:
    Code:
    nm-tool
    Last edited by chili555; June 25th, 2013 at 03:49 PM.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 4 of 4 FirstFirst ... 234

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •