Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 39

Thread: Dell Latitude E6230 Wireless Issues

  1. #21
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues

    Hey Hadaka...

    Just though you should know this:

    I booted the machine up and ran a
    Code:
    dmesg|grep wl
    . The results were interesting:

    [11.740771] wl: module license mixed/proprietary taints kernel.
    [11.781207] wl 0000:02:00.0: enabling device (0000 -> 0002)
    [11.811902] INFO @wl_cfg80211_attach : Registered CFG80211 phy

    Of course, it will still not connect to wireless (I have an "outline") although the APs DO show up and wireless is enabled.

    Thought that bit about "taints kernel" might interest you.

    Thanks for ALL of your help!!!

    Ron
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

  2. #22
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,958
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Dell Latitude E6230 Wireless Issues

    Hadaka has left the building....but only temporarily. He has asked the doctor for a fee-splitting consultation.
    Thought that bit about "taints kernel" might interest you.
    It doesn't affect us at all! Parts of the Broadcom STA driver are proprietary and parts are free and open source. The proprietary parts make the kernel no longer 100% completely pure as the driven snow free and open source; just 99.99%. It's a trivial disclaimer that has no effect on your ability to connect.

    Please reboot so we have a clean slate with no connection at all. Before you do anything, do:
    Code:
    dmesg > rond.txt
    lsmod >> rond.txt
    lspci -nn -d 14e4: >> rond.txt
    iwconfig >> rond.txt
    cat /etc/rc.local >> rond.txt
    Find the text file rond.txt in your user directory. Connect by whatever means and attach it to your reply using the paperclip tool at the top of the reply box.

    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #23
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues

    Hey Doc!

    Good to see you.

    Before I send this let me make the disclaimer that I DID reboot and run those commands first thing. However--before I rebooted (a few hours ago) I also disabled wireless to get rid of the boxes popping up telling me about the impossibility of a connection. So if you need me to either enable it before creating/appending that textfile or enable and connect using the modprobe commands before creating I can do either of those. Right now I am connected with a piece of RJ...and by the way, sorry for taking so long to reply! I'm out of here in an hour so if we don't get this solved today I'll be back in on Monday at 5:30am CST.

    Without further adieu, here is the Very Long Textfile (attached--I think. This upload manager kind of sucks).

    Thanks!!

    Ron

    PS--The upload manager will NOT let me upload the file...it's telling me the maximum filesize is 19.5k and this file is 145k...what to do? I can PM you the file...
    PSS--No, actually I cannot PM it...or send it to you in any other way, it seems. I uploaded it to GDrive. It is at <https://docs.google.com/file/d/0B15bGf2Ud1KbeEZwbTBrNnE1SlU/edit?usp=sharing> and named "ubuntu textfile."
    Last edited by rondamato; June 21st, 2013 at 07:10 PM.
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

  4. #24
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,958
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Dell Latitude E6230 Wireless Issues

    Before I send this let me make the disclaimer that I DID reboot and run those commands first thing. However--before I rebooted (a few hours ago) I also disabled wireless to get rid of the boxes popping up telling me about the impossibility of a connection. So if you need me to either enable it before creating/appending that textfile or enable and connect using the modprobe commands before creating I can do either of those.
    I thought my meaning was quite clear:
    Please reboot so we have a clean slate with no connection at all. Before you do anything, do:
    I didn't mean by that, 'reboot a few hours ago, make a bunch of changes, hope it's OK and run the commands.' Your dmesg file has an ending timestamp of 11521.653087 implying that the machine was booted about 3 1/2 hours before the diagnostics were taken; not what I'd hoped for.

    Before you go back and do the process as I requested, I see the following:
    [11511.869446] ACPI: EC: input buffer is not empty, aborting transaction
    [11511.869457] ACPI Exception: AE_TIME, Returned by Handler for [EmbeddedControl] (20120320/evregion-501)
    [11511.869475] ACPI Error: Method parse/execution failed [\_SB_.PCI0.LPCB.ECDV.ECR1] (Node ffff880212892c58), AE_TIME (20120320/psparse-536)
    [11511.869496] ACPI Error: Method parse/execution failed [\ECBT] (Node ffff880212892d70), AE_TIME (20120320/psparse-536)
    [11511.869511] ACPI Error: Method parse/execution failed [\ECG2] (Node ffff880212892e88), AE_TIME (20120320/psparse-536)
    [11511.869523] ACPI Error: Method parse/execution failed [\ECG6] (Node ffff880212892fa0), AE_TIME (20120320/psparse-536)
    [11511.869537] ACPI Error: Method parse/execution failed [\_SB_.BAT0._BST] (Node ffff880212893780), AE_TIME (20120320/psparse-536)
    [11511.869557] ACPI Exception: AE_TIME, Evaluating _BST (20120320/battery-455)
    There are many, perhaps dozens, of repeats of this error. I suggest you try to find out more about this and try to fix it. I'm not an expert in ACPI, so I have no ideas.
    lib80211_crypt: registered algorithm 'TKIP'
    Is your router set to TKIP encryption? Many, perhaps most wireless drivers will refuse to connect at N speeds with TKIP. The preferred encryption method is AES.
    cfg80211: Updating information on frequency 2412 MHz for a 20 MHz width channel with regulatory rule: blank
    In this context, a blank means default, one size may or may not fit all. I suggest we set the country code explicitly:
    Code:
    sud iw reg set US
    Does this help you connect? If so, we'll amend one file and make it persistent.

    Please run:
    Code:
    nm-tool
    Does it report that your wireless access point uses WPA and WPA2 in mixed mode? WPA2 only is preferred. Is this a change you could try?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #25
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues

    Hello,

    First of all, sorry about that! I rebooted and walked away I thought. I don't remember running any commands. I told you this quite clearly so very very sorry for any misunderstandings. YOU were clear also and I should have listened instead of rebooting and walking away.

    But, just to make it all right, I rebooted fresh, connected to my home network using the modprobe commands, and made another "rond.txt" file.

    This is in Google Drive as "Ubuntu Textfile #2" Link here: <https://docs.google.com/document/d/1kufBsH6G8mZZLP7vzkqtiFVki2UfcKP3QzikRDE1_7o/edit?usp=sharing>

    I tried running the
    Code:
    sudo iw reg set US
    and that went through with no errors.

    Then for the nm-tool. Here is the output (long):

    NetworkManager Tool

    State: connected (global)

    - Device: eth2 [linksys] ------------------------------------------------------
    Type: 802.11 WiFi
    Driver: wl
    State: connected
    Default: yes
    HW Address: 1C:3E:84:C481

    Capabilities:
    Speed: 24 Mb/s

    Wireless Properties
    WEP Encryption: yes
    WPA Encryption: yes
    WPA2 Encryption: yes

    Wireless Access Points (* = current AP)
    2WIRE461: Infra, B0:E7:54:CA:9A:E1, Freq 2447 MHz, Rate 54 Mb/s, Strength 72 WPA WPA2
    wml: Infra, 5C9:98:68:B6:36, Freq 2412 MHz, Rate 54 Mb/s, Strength 54 WPA WPA2
    ATT8224: Infra, 4C:60E:BA:5A:F0, Freq 2412 MHz, Rate 54 Mb/s, Strength 30 WPA2
    donteventry: Infra, 20:10:7A:C3:4C:BE, Freq 2462 MHz, Rate 54 Mb/s, Strength 30 WPA2
    2WIRE357: Infra, B0:E7:54:2B:A3:01, Freq 2437 MHz, Rate 54 Mb/s, Strength 25 WPA WPA2
    HOME-9FE8: Infra, B8:9B:C9:69:9F:E8, Freq 2462 MHz, Rate 54 Mb/s, Strength 25 WPA WPA2
    linksys: Infra, 00:0F:66:A9:B3:ED, Freq 2437 MHz, Rate 54 Mb/s, Strength 30 WEP
    *linksys: Infra, 00:23:69:2A:ED:C7, Freq 2462 MHz, Rate 54 Mb/s, Strength 63 WEP

    IPv4 Settings:
    Address: 192.168.1.106
    Prefix: 24 (255.255.255.0)
    Gateway: 192.168.1.1

    DNS: 75.75.75.75
    DNS: 75.75.76.76


    - Device: eth0 -----------------------------------------------------------------
    Type: Wired
    Driver: e1000e
    State: unavailable
    Default: no
    HW Address: B8:CA:3A:CF0:78

    Capabilities:
    Carrier Detect: yes

    Wired Properties
    Carrier: off



    As I said, I am connected at home right now by firing off the two modprobe commands. I can then pick my home AP (WEP), enter the key, and it connects. I will reboot, then edit this post to tell you if it successfully connects without the modprobes.

    Thanks!!!

    Ron


    PS--I shut the machine down and rebooted...and it connected! No modprobes, no nothing. It just worked. Not sure how or why...but it worked! Thank you.

    I will not know for SURE if this works with our un-protected "guest" network at Headquarters until I get back to work so I'm going to hold off on marking this solved until Monday morning (if you think I should)--but is it correct to assume that, if it connects upon reboot here and NOT at work that the issue is with the AP? I mean, other machines connect to it with no issue including my two desktop Ubuntu machines (10.04 and 12.04)--which are both Dell 5430s. But for now, Doctor, I think this problem is knocked. I don't know HOW exactly (and I'd really like to know if you do) but it is.

    Hadaka, thank YOU also for all your hard work and advice. You taught me a LOT of good stuff and that's very important to me. Thank you again so very much.
    Last edited by rondamato; June 22nd, 2013 at 01:40 PM. Reason: additions to issue
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

  6. #26
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,958
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Dell Latitude E6230 Wireless Issues

    I will not know for SURE if this works with our un-protected "guest" network at Headquarters until I get back to work so I'm going to hold off on marking this solved until Monday morning
    We look forward to your report. My belief is that it's not solved until you are happy, so we'll read your report on Monday.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #27
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues

    Hello friends,

    Well, I'm back at work...and the news is not good.

    At home, I run a cheap Linksys router with WEP enabled. The computer found the WAP, allowed me to enter the key, and let me reboot-restart it many times...all the while it connected (automatically, I may add) right to the AP. No issues.

    Back at work today...the machine cannot connect to the unprotected "guest" AP. It just keeps "scanning." It cannot connect to either of the other two WPA-2 protected APs either. It will ask me for creds but then just scans...and eventually times out.

    This is really confounding me. EVERY computer on my desk is connected to the Guest AP--many computers here at the headquarters use it. As I typed this I just connected to it first-time (as in...I never connected to it before with this device) with my ASUS Transformer II. It connected instantly.

    Well...at least we know that this thing effortlessly connects to the protected network in my home...and will NOT connect to the unprotected network here unless the modprobe commands that I've mentioned a few dozen times before are entered into a terminal.

    I've been hacking on Ubuntu for about 5-6 years and Windows for FAR longer and have NEVER seen anything like this. To be honest--I am fresh out of ideas here. Even the computer that I am typing this on is connected to "Guest" (a Dell Lat E5430) but it's running Windows. More telling, my Ubuntu 12.04 desktop running Xubuntu can connect to it as well without issues...it's also a Dell, just not the same model as the "problem" machine.

    I'm ready to just let this one go as it seems completely non-sensible as to why these VERY strange symptoms would occur. I am now THOROUGHLY confused with this.

    To summarize:

    1) Machine will NOT connect to unprotected "Guest" AP unless I use the "modprobe" commands.
    2) Machine will not connect to any other AP in this building protected or not. Even if I turn on ICS on a Mac or something it won't connect to THAT either (without the modprobe commands).
    3) Machine connects to WEP-protected network at home with no issues whatsoever. No modprobe commands need be used. It worked EXACTLY the way it should from the get-go.

    That's all I have. Again, I thank the Community LOADS for helping me to troubleshoot and solve this incident!

    Ron
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

  8. #28
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,958
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Dell Latitude E6230 Wireless Issues

    The modprobe -r b43 ssb etal shouldn't have any real effect because those modules are blacklisted and not loaded on boot; unless, of course, your ethernet device is also a Broadcom, some of which use b44 and ssb. When you cold boot and then check the loaded modules, are those loaded?
    Code:
    lsmod | grep -e b43 -e ssb -e brcmsmac -e wl
    I suspect only wl is loaded, the driver created by bcmwl-kernel-source. Therefor, I'd assume the modprobe commands could simply be:
    Code:
    sudo modprobe -r wl
    sudo modprobe wl
    Does that work?

    Perhaps there is a later version of bcmwl-kernel-source that would work better. Which version do you have?
    Code:
    dpkg -s bcmwl-kernel-source | grep Version
    uname -r
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  9. #29
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues

    Hey Chili,

    OK, now doing exactly what you told me. I am on the affected laptop using eth0 for the network connection, but wireless IS enabled...just not working.

    OK--tried the first command and got:

    wl 3074942 0
    cfg80211 208382 1 wl
    lib80211 14382 2 lib80211_crypt_tkip,wl


    I pulled the RJ temporarily and yes, simply entering:

    Code:
    sudo modprobe -r wl
    Code:
    sudo modprobe wl
    does indeed bring up the wifi, and allow the machine to connect to "guest" almost instantaneously. Of course, when I reboot I lose connectivity and must enter these commands again.

    Version shows up as being "6.20.155.1+bdcom-0ubuntu0.0.1." Kernel version is 3.5.0-23-generic.

    Now that we know that those commands will get the wireless running is there any way to make them persistent? Any way, that is, other than putting the commands into the Linux version of "autoexec.bat" (which I'm guessing is init.d here in Ubuntu)?

    I'm nearly 100% sure that I understand what you are doing here...does the
    Code:
    sudo modprobe -r wl
    remove the wl driver from resident memory (or something like that) and the

    Code:
    sudo modprobe wl
    put it back in?

    Thanks again for all your help. Not only are we solving the issue--I am learning a LOT which, to me, is FAR more important than getting this machine's wireless to actually "work" correctly.

    What steps can I take from here to make those commands persistent and allow the wireless to work each and every time the machine is cold-booted?

    Thanks again friend!

    Ron
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

  10. #30
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,958
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Dell Latitude E6230 Wireless Issues

    Version shows up as being "6.20.155.1+bdcom-0ubuntu0.0.1." Kernel version is 3.5.0-23-generic.
    Ohhh? Here it says the version for your kernel is altogether different: http://packages.ubuntu.com/quantal/bcmwl-kernel-source
    bcmwl-kernel-source (5.100.82.112+bdcom-0ubuntu3)
    Where or how did you get 6.20.155?

    I'd prefer to get the correct version running correctly, if we can, rather than any other trickery.
    I'm nearly 100% sure that I understand what you are doing here...does the
    Code:

    sudo modprobe -r wl

    remove the wl driver from resident memory (or something like that) and the

    Code:

    sudo modprobe wl

    put it back in?
    It removes it from loaded modules and reloads it.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •