Page 1 of 4 123 ... LastLast
Results 1 to 10 of 39

Thread: Dell Latitude E6230 Wireless Issues

  1. #1
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Dell Latitude E6230 Wireless Issues

    Let me tell you what's happening--perhaps you can tell me if what I THINK is happening is indeed happening. This is a Dell Latitude E6230 laptop running 12.04LTS...and yes, a lot of this post is copypasta'ed from last week--same issue!

    When I restart the computer the same thing that I posted about last week again happens--no wireless. We have a "Guest" network that requires no security--this is what I am trying to connect to.

    When I start I am told that there are “wireless networks available.” When I try to connect the wireless icon at the top of the screen just “scans” until the machine errors out with “Wireless Network—Disconnected.”

    The only way that I can connect is, when the machine is logged into and a term window is opened, I issue these commands:

    Code:
    sudo modprobe -r b43 ssb wl brcmfmac brcmsmac bcma
    ...and the wireless icon changes from a "scanning" icon to a solid "outline" of the icon.

    To connect to the network though I must enter:

    Code:
    sudo modprobe wl

    After this the icon turns solid and the computer informs me that I am connected to "guest." But ONLY after I type this line.

    When I look in the /etc/modules file the only modules that are shown are lp, rtc, and wl.

    So...I have no trouble getting this to work as long as I issue the above commands--what I'm not understanding is WHY these commands are not persistent...ie, why do I HAVE to run them each and every time the computer is booted and what can I do to prevent this?

    I appreciate all of your help and I'm sorry that I'm not "getting" this--trust me, it's frustrating especially since my deadline for this machine's completion is in about two hours!

    Thanks again,

    Ron


    PS--Thought it might help to know that I cannot enter ONE of those lines and get it to work. Thought just the "modprobe wl" would suffice but it does not--I must enter

    Code:
    sudo modprobe -r b43 ssb wl brcmfmac brcmsmac bcma
    first and then

    Code:
    sudo modprobe wl

    After this the computer automatically connects to the "Guest" account in about 8-10 seconds.

    I have tried blacklisting b43, ssb, bcma, and brcmsmac in /etc/modprobe.d/blacklist.conf and it’s still the same story…I thought that I had this fixed but upon reboot it just cycles until the wifi eventually gives out. If I enter the above modprobe lines it all works though.

    I have tried to run a

    Code:
    sudo apt-get update && apt-get upgrade

    Also…to no effect. This is infuriating as it worked last week and I shut the computer down for the weekend…now it no longer works—which just doesn’t make sense.
    Anybody have any ideas?

    As always thank you--the Ubuntu community is THE BEST--in fact the community is WHY I run this OS (besides for it kicking serious ass). So thanks!
    Last edited by rondamato; June 17th, 2013 at 03:43 PM.

  2. #2
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Dell Latitude E6230 Wireless Issues...AGAIN!

    Hi, give this a try...
    Code:
    sudo apt-get install --reinstall bcmwl-kernel-source
    sudo modprobe wl
    Craving anchovy, herring and squid pizza.....with clam sauce

  3. #3
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues...AGAIN!

    Hello,

    Nope, same story.

    The wireless networks show up in the drop-down, but selecting one just shows the icon scanning...scanning...until finally it says "Network Disconnected--You are now offline"--and then the scanning again.

    If I try to select "Guest" I get "Wireless Network--you are now disconnected" and the scanning...scanning...until the icon goes to an outline and I get "Wireless Network--You are now offline."

    Keep in mind that a

    Code:
    sudo modprobe -r b43 ssb wl brcmfmac brcmsmac bcma
    followed by a

    Code:
    sudo modprobe wl
    allows it to connect to "Guest" WITHOUT ME DOING ANYTHING. No selecting, no nothing--it just works. Arrrgh!!

    Thanks Hadaka and everyone else--this is driving me batty. If any of you need specific output just let me know.

    Ron

  4. #4
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Dell Latitude E6230 Wireless Issues...AGAIN!

    ok,lets look at some stuff..
    please post the output of..
    Code:
    lsmod
    cat /etc/modules
    cat /etc/network/interfaces
    cat /etc/modprobe.d/blacklist.conf | grep blacklist
    thanks.
    Craving anchovy, herring and squid pizza.....with clam sauce

  5. #5
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues...AGAIN!

    Hello friends!

    OK, sorry for the delay. I will send that output now. Keep in mind that I am ON the machine in question right now--connected through wireless on the "guest" account using the procedure that I described a few messages ago.

    Code:
    lsmod
    Module Size Used by
    wl 3074942 0
    cfg80211 208382 1 wl
    snd_hda_codec_hdmi 32476 1
    snd_hda_codec_idt 70774 1
    rfcomm 47562 0
    bnep 18240 2
    bluetooth 211812 10 rfcomm,bnep
    nls_iso8859_1 12714 1
    coretemp 13642 0
    kvm_intel 137888 0
    kvm 422160 1 kvm_intel
    ghash_clmulni_intel 13221 0
    aesni_intel 51134 0
    cryptd 20531 2 ghash_clmulni_intel,aesni_intel
    aes_x86_64 17256 1 aesni_intel
    dell_wmi 12682 0
    sparse_keymap 13891 1 dell_wmi
    ppdev 17114 0
    dell_laptop 17426 0
    dcdbas 14491 1 dell_laptop
    snd_hda_intel 34117 3
    snd_hda_codec 135141 3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
    snd_hwdep 17765 1 snd_hda_codec
    microcode 23030 0
    snd_pcm 97523 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
    snd_seq_midi 13325 0
    snd_rawmidi 30750 1 snd_seq_midi
    snd_seq_midi_event 14900 1 snd_seq_midi
    snd_seq 61931 2 snd_seq_midi,snd_seq_midi_event
    psmouse 102075 0
    serio_raw 13216 0
    lpc_ich 17145 0
    mei 41410 0
    i915 530857 3
    drm_kms_helper 49259 1 i915
    drm 290344 4 i915,drm_kms_helper
    i2c_algo_bit 13565 1 i915
    snd_timer 29990 2 snd_pcm,snd_seq
    snd_seq_device 14498 3 snd_seq_midi,snd_rawmidi,snd_seq
    snd 83674 16 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel ,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_s eq,snd_timer,snd_seq_device
    soundcore 15092 1 snd
    snd_page_alloc 18573 2 snd_hda_intel,snd_pcm
    lib80211_crypt_tkip 17391 0
    parport_pc 32867 0
    wmi 19257 1 dell_wmi
    video 19598 1 i915
    lib80211 14382 2 wl,lib80211_crypt_tkip
    mac_hid 13254 0
    lp 17800 0
    parport 46563 3 ppdev,parport_pc,lp
    sdhci_pci 18749 0
    sdhci 33145 1 sdhci_pci
    e1000e 198734 0

    Code:
    cat /etc/modules
    # /etc/modules: kernel modules to load at boot time.
    #
    # This file contains the names of kernel modules that should be loaded
    # at boot time, one per line. Lines beginning with "#" are ignored.

    lp
    rtc
    wl

    Code:
    cat /etc/network/interfaces
    auto lo
    iface lo inet loopback

    Code:
    cat /etc/modprobe.d/blacklist.conf | grep blacklist
    blacklist evbug
    blacklist usbmouse
    blacklist usbkbd
    blacklist eepro100
    blacklist de4x5
    blacklist eth1394
    blacklist snd_intel8x0m
    blacklist snd_aw2
    blacklist i2c_i801
    blacklist prism54
    blacklist bcm43xx
    blacklist garmin_gps
    blacklist asus_acpi
    blacklist snd_pcsp
    blacklist pcspkr
    blacklist amd76x_edac
    blacklist b43
    blacklist ssb
    blacklist bcma
    blacklist brcmsmac



    Sorry that all took so long but I went home for the evening and didn't have the machine handy!

    Many thanks folks,

    Ron
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

  6. #6
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Dell Latitude E6230 Wireless Issues...AGAIN!

    Hi, your last printout shows a working connection (Guest?)
    Just so I'm not confused..when you say..GUEST...is it actually guest?
    as in does your Desktop log on area look like this..

    Rondamado
    [password area]
    Guest

    if thats what you are calling guest...its not...thats normal.
    so set me straight on this and we shall go forward..
    thanks.
    Craving anchovy, herring and squid pizza.....with clam sauce

  7. #7
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues

    Hello,

    No, there is one user in this machine (besides for the root account)--his name is Raju. So at the login screen I click "Raju" and enter password.

    "GUEST" is just the name of our company-wide "guest" wifi network. When I run those modprobes the machine connects to it via wifi first because it has no security.

    The other company-wide wifi networks also show up in the drop-down list but these are all WPA2 and require typing in company username/pw creds to login. Right now I am using the example of "guest" because it is easiest and will probably be the WAP that Raju uses when he gets his new Ubuntu machine.

    Hope I cleared that up for you good sir!

    Ron
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

  8. #8
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Dell Latitude E6230 Wireless Issues

    Hi, Im only slightly confused now..thanks..
    Is this GUEST network on a separate router...or a router that can have 2 connections?

    either way... you should have a separate ap connection defined for it. see attached.
    Screenshot from 2013-06-18 10:11:12.jpg
    Craving anchovy, herring and squid pizza.....with clam sauce

  9. #9
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues

    Hello again,

    Yes, it is set up like that. If I go into Edit Connections>Wireless (forgive me, not in front of it right at this minute) the GUEST connection exists and security is set to NONE...just like in your screenshot. It also shows how many minutes since last connected, etc.

    So yeah, you are NOT confused, you are 100% correct.

    As I said, the networks DO show up in the dropdown, and YES, they all originate from the same WAP (or rather hundreds of WAPs). So I can SEE their names in the dropdown, I can select them, but when I do the icon just "scans" until it finally gives up.

    If I issue the modprobe commands the machine will, within 5 seconds, "lock onto" GUEST and the "scanning" is replaced by a solid wireless icon that shows signal strength, as it should be. BUT, unless I issue the modprobe commands, the machine will not "lock onto" ANY of the WAPs' networks no matter which one I select. It will just "scan" and eventually throw up a message that says "Wireless Networking--You are Disconnected" or something of the sort.

    Hope this helps the confusion but it seems like you DO understand perfectly after re-reading your post. You ARE on track so no worries there!

    Thanks much!

    Ron
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

  10. #10
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Dell Latitude E6230 Wireless Issues

    Hi, I'm here for about an hour then will back late
    this afternoon. Try this, (I want to narrow this down)
    try to connect to your "Guest" access point.
    when it fails, do this..
    Code:
    sudo modprobe -rf wl
    sudo modprobe wl
    does it connect?
    *If yes, then try to connect to "Guest" again..
    this time, no commands, uncheck "ENABLE WIRELESS"
    and then recheck it.....does it connect now?
    thanks.
    Craving anchovy, herring and squid pizza.....with clam sauce

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •