Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Can't install nvidia-319

  1. #1
    Join Date
    Jun 2012
    Beans
    45

    Can't install nvidia-319

    I am trying to install nvidia-319 for bumblebee 3.2. Apparently 319 is the only working driver for bumblebee 3.2. So I tried to install it. :
    Code:
    sudo apt-get install  nvidia-319 nvidia-settings-319
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     nvidia-304 : Conflicts: xorg-driver-binary
     nvidia-319 : Conflicts: xorg-driver-binary
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    Can I just ignore the dependencies temporarily? Just to replace the current nvidia driver with 319?
    HP dv6t-7000 CTO
    i5 2450m 6 GB ram
    Intel HD 3000 Graphics & Nvidia GT 630M
    Oz Unity Development /Windows 7 KDE

  2. #2
    Join Date
    Jun 2005
    Location
    Where?
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Can't install nvidia-319

    I had to use synaptic to make sense of it all.
    But just choose nvidia-319-dev and that should pull in nvidia-settings-319
    If any other Nvidia Drivers are installed it will remove them.
    I did not try "sudo apt-get install nvidia-319-dev && sudo apt-get install nvidia-settings-319"
    So if you want to try that it might go smooth?
    Last edited by runrickus; June 14th, 2013 at 12:38 AM.

  3. #3
    Join Date
    May 2006
    Beans
    17

    Re: Can't install nvidia-319

    I have the same problem with 319. Suggestions? TIA

    db1# apt-get install nvidia-319
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    nvidia-304 : Conflicts: xorg-driver-binary
    nvidia-319 : Recommends: nvidia-settings-319 but it is not going to be installed
    Recommends: nvidia-persistenced but it is not installable
    Conflicts: xorg-driver-binary
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    db1# apt-get install nvidia-319-dev
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    nvidia-319-dev : Depends: nvidia-319 (>= 319.23) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.


    software-properties-gtk says:

    db1> sudo software-properties-gtk
    gpg: /tmp/tmpierrqy/trustdb.gpg: trustdb created
    Warning: install transaction not completed successfully: Transaction failed: Package dependencies cannot be resolved
    The following packages have unmet dependencies:

    nvidia-304: Depends: x11-common (>= 1:7.0.0) but 1:7.7+1ubuntu4 is to be installed
    Depends: libgcc1 (>= 1:4.1.1) but 1:4.8.1-3ubuntu1 is to be installed
    Depends: zlib1g (>= 1:1.1.4) but 1:1.2.8.dfsg-1ubuntu1 is to be installed
    Depends: xorg-video-abi-14 but it is not going to be installed
    nvidia-319: Depends: x11-common (>= 1:7.0.0) but 1:7.7+1ubuntu4 is to be installed
    Depends: zlib1g (>= 1:1.1.4) but 1:1.2.8.dfsg-1ubuntu1 is to be installed
    Depends: xorg-video-abi-14 but it is not going to be installed

  4. #4
    Join Date
    Jun 2005
    Location
    Where?
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Can't install nvidia-319

    Quote Originally Posted by ajmcello View Post
    I have the same problem with 319. Suggestions? TIA

    db1# apt-get install nvidia-319
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    nvidia-304 : Conflicts: xorg-driver-binary
    nvidia-319 : Recommends: nvidia-settings-319 but it is not going to be installed
    Recommends: nvidia-persistenced but it is not installable
    Conflicts: xorg-driver-binary
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    db1# apt-get install nvidia-319-dev
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    nvidia-319-dev : Depends: nvidia-319 (>= 319.23) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.


    software-properties-gtk says:

    db1> sudo software-properties-gtk
    gpg: /tmp/tmpierrqy/trustdb.gpg: trustdb created
    Warning: install transaction not completed successfully: Transaction failed: Package dependencies cannot be resolved
    The following packages have unmet dependencies:

    nvidia-304: Depends: x11-common (>= 1:7.0.0) but 1:7.7+1ubuntu4 is to be installed
    Depends: libgcc1 (>= 1:4.1.1) but 1:4.8.1-3ubuntu1 is to be installed
    Depends: zlib1g (>= 1:1.1.4) but 1:1.2.8.dfsg-1ubuntu1 is to be installed
    Depends: xorg-video-abi-14 but it is not going to be installed
    nvidia-319: Depends: x11-common (>= 1:7.0.0) but 1:7.7+1ubuntu4 is to be installed
    Depends: zlib1g (>= 1:1.1.4) but 1:1.2.8.dfsg-1ubuntu1 is to be installed
    Depends: xorg-video-abi-14 but it is not going to be installed

    Just to be sure, You are using raring (13.10)?
    and make sure your fully updated
    sudo apt-get update
    sudo apt-get upgrade
    If this is the case add these two lines to your ?etc/apt/sources.list

    deb http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ raring main
    deb-src http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ raring main

    sudo apt-get update
    sudo apt-get install nvidia-319

    I supect you are on saucy though.
    regards

  5. #5
    Join Date
    May 2006
    Beans
    17

    Re: Can't install nvidia-319

    I am on saucy (13.10)

  6. #6
    Join Date
    Jul 2010
    Location
    Finland
    Beans
    2,455
    Distro
    Ubuntu

    Re: Can't install nvidia-319

    Please do remove nvidia-304 before attempting to install nvidia-319.
    Only 1 driver should be installed.
    The nvidia-319 in official saucy repo (restricted main) does not have any dependency issues in a pure saucy setup.

  7. #7
    Join Date
    May 2006
    Beans
    17

    Re: Can't install nvidia-319

    I've tried everything I can think of. Here's what I get now:


    apt-get remove nvidia-304

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package 'nvidia-304' is not installed, so not removed
    0 upgraded, 0 newly installed, 0 to remove and 59 not upgraded.


    apt-get install nvidia-319
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    nvidia-304 : Conflicts: xorg-driver-binary
    nvidia-319 : Recommends: nvidia-settings-319 but it is not going to be installed
    Conflicts: xorg-driver-binary
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

    apt-get remove xorg-driver-binary
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Virtual packages like 'xorg-driver-binary' can't be removed
    0 upgraded, 0 newly installed, 0 to remove and 59 not upgraded.

  8. #8
    Join Date
    May 2006
    Beans
    17

    Re: Can't install nvidia-319

    software properties gtk still says this, even after I removed nvidia-304 and what not. Did a apt-get update, apt-get dist-upgrade, reboot.

    for nvidia-319:

    The following packages have unmet dependencies:

    nvidia-304: Depends: x11-common (>= 1:7.0.0) but 1:7.7+1ubuntu4 is to be installed
    Depends: libgcc1 (>= 1:4.1.1) but 1:4.8.1-3ubuntu1 is to be installed
    Depends: zlib1g (>= 1:1.1.4) but 1:1.2.8.dfsg-1ubuntu1 is to be installed
    Depends: xorg-video-abi-14 but it is not going to be installed
    nvidia-319: Depends: x11-common (>= 1:7.0.0) but 1:7.7+1ubuntu4 is to be installed
    Depends: zlib1g (>= 1:1.1.4) but 1:1.2.8.dfsg-1ubuntu1 is to be installed
    Depends: xorg-video-abi-14 but it is not going to be installed

  9. #9
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Can't install nvidia-319

    @ajmcello what command did you use to remove the 304 driver, and did you reboot to make sure you were using the nouveau driver after removing the closed source Nvidia driver?

  10. #10
    Join Date
    May 2006
    Beans
    17

    Re: Can't install nvidia-319

    I use apt-get. Whatever I try, it fails when trying to use 319.

    aptitude search '~i?provides(xorg-driver-binary)'
    i A nvidia-304-updates - NVIDIA binary Xorg driver, kernel module and VDPAU library


    apt-get install nvidia-319
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    nvidia-304 : Conflicts: xorg-driver-binary
    nvidia-319 : Recommends: nvidia-settings-319 but it is not going to be installed
    Conflicts: xorg-driver-binary
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.




    I've tried removing 304, and it installs 310, I remove 310 and it installs 304, all automaticly.

    aptitude search nouveau

    i libdrm-nouveau1a - Userspace interface to nouveau-specific kernel DRM services -- runtime
    p libdrm-nouveau1a:i386 - Userspace interface to nouveau-specific kernel DRM services -- runtime
    i libdrm-nouveau1a-dbg - Userspace interface to nouveau-specific kernel DRM -- debugging symbols
    p libdrm-nouveau1a-dbg:i386 - Userspace interface to nouveau-specific kernel DRM -- debugging symbols
    i libdrm-nouveau2 - Userspace interface to nouveau-specific kernel DRM services -- runtime
    i libdrm-nouveau2:i386 - Userspace interface to nouveau-specific kernel DRM services -- runtime
    p libdrm-nouveau2-dbg - Userspace interface to nouveau-specific kernel DRM -- debugging symbols
    p libdrm-nouveau2-dbg:i386 - Userspace interface to nouveau-specific kernel DRM -- debugging symbols
    i nouveau-firmware - Firmware for nVidia graphics cards
    i xserver-xorg-video-nouveau - X.Org X server -- Nouveau display driver
    p xserver-xorg-video-nouveau:i386 - X.Org X server -- Nouveau display driver
    i xserver-xorg-video-nouveau-dbg - X.Org X server -- Nouveau display driver (debug symbols)
    p xserver-xorg-video-nouveau-dbg:i386 - X.Org X server -- Nouveau display driver (debug symbols)

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •