Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Installing teamviewer on Ubuntu 12.04 LTS 64bit

  1. #1
    Join Date
    Jun 2013
    Beans
    4

    Installing teamviewer on Ubuntu 12.04 LTS 64bit

    Environment: Ubuntu 12.04 LTS 64bit
    Problem: Unable to install teamviewer; error: cannot install lib32asound2

    Tried: sudo get-apt install lib32asound2
    lib32asound2 : Depends: libc6-i386 (>= 2.7) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

    then tried: sudo get-apt install libc6-i386
    libc6-i386 : Depends: libc6 (= 2.15-0ubuntu10.2) but 2.15-0ubuntu10.3 is to be installed
    E: Unable to correct problems, you have held broken packages.

    then tried: sudo get-apt install libc6
    libc6 is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    what to do know? it driving me crazy. please help
    Last edited by howefield; June 15th, 2013 at 02:18 PM. Reason: reset font.

  2. #2
    Join Date
    Feb 2011
    Location
    Somewhere...
    Beans
    1,543
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Installing teamviewer on Ubuntu 12.04 LTS 64bit

    Run these commands one at a time and see if the problem is fixed:
    Code:
    sudo apt-get install -f
    sudo dpkg --configure -a
    sudo apt-get clean
    sudo apt-get update
    sudo apt-get upgrade

  3. #3
    Join Date
    Feb 2012
    Location
    el_GR
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Installing teamviewer on Ubuntu 12.04 LTS 64bit

    You have to know that teamviewer is not FOSS

    Remove any existing instance of teamviewer from your PC.

    Then download teamviewer 8 (newest version) from here

    Download the appropriate architecture (64bit) .deb package.

    Connect to Downloads folder and install it with dpkg

    Code:
    cd Downloads 
    sudo dpkg -i teamviewer_linux_x64.deb
    Probably it will throw a bunch of errors, then run
    Code:
    sudo apt-get install -f
    to correct these errors.

    If not succeed, post back full results of above commands.

    Thanks
    Last edited by NikTh; June 15th, 2013 at 02:18 PM.

  4. #4
    Join Date
    Jun 2013
    Beans
    4

    Re: Installing teamviewer on Ubuntu 12.04 LTS 64bit

    same issue:

    sadiq@sadiq-linux:/Data1/Software$ sudo dpkg --force-depends -i teamviewer_linux_x64.deb
    Selecting previously unselected package teamviewer.
    (Reading database ... 175552 files and directories currently installed.)
    Unpacking teamviewer (from teamviewer_linux_x64.deb) ...
    dpkg: teamviewer: dependency problems, but configuring anyway as you requested:
    teamviewer depends on libc6-i386 (>= 2.4); however:
    Package libc6-i386 is not installed.
    teamviewer depends on lib32asound2; however:
    Package lib32asound2 is not installed.
    teamviewer depends on lib32z1; however:
    Package lib32z1 is not installed.
    teamviewer depends on ia32-libs; however:
    Package ia32-libs is not installed.
    Setting up teamviewer (8.0.17147) ...
    initctl: Job failed to start

  5. #5
    Join Date
    Feb 2012
    Location
    el_GR
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Installing teamviewer on Ubuntu 12.04 LTS 64bit

    Have you ran after dpkg , the
    Code:
    sudo apt-get install -f
    command ?

    I recently installed this tool in 12.04.2 LTS and I've had the same problems, but above command correct them. A bunch of :i386 packages will be installed in your system, but that's the way.

    First be sure that you have completely removed the old-corrupted teamviewer installation

    Code:
    sudo dpkg -P teamviewer_linux_x64.deb


    Thanks

  6. #6
    Join Date
    Oct 2013
    Beans
    10

    Re: Installing teamviewer on Ubuntu 12.04 LTS 64bit

    I understand that this thread is now a couple of months old however it always helps if the OP responds as to whether or not the information given by the respondant solved the issue in question.

    Thankyou very much NikTH - I was looking for this information in Google and came across your posts in regard to this matter - worked perfectly for me by following your instructions - cheers.

    Tested and working on Wubi install of Ubuntu 12.04 LTS w/ Windows 7 Home Premium 64 bit using Teamviewer deb v8.0.20931 downloaded through the link provided in post #3

    Note: Run commands exactly how NikTH has provided them - I typed a lower case d for Dowloads and therefore as Linux is specific with Directory naming I got the error about no such directory - I then used upper case D for cd
    (change directory) Downloads without issue.

    Also NikTH is correct in saying that Teamviewer is not open source however it IS free for non commercial users. I am sure that there are better/ faster tools out there to accomplish the same task but IMO Teamviewer's ease of
    use is a winner - ie: bypass Firewall restrictions etc etc.....

    Thanks very much for the install info again NikTH.
    Last edited by superduper2; October 22nd, 2013 at 01:36 PM.

  7. #7
    Join Date
    Nov 2013
    Beans
    4

    Re: Installing teamviewer on Ubuntu 12.04 LTS 64bit

    Hi,

    I have Ubuntu 13.10

    When I try to install dependencies after typing sudo apt-get install -f, it just uninstalls teamviewer.

    here is the output

    dpkg -i teamviewer_linux_x64.deb
    Selecting previously unselected package teamviewer.
    (Reading database ... 197918 files and directories currently installed.)
    Unpacking teamviewer (from teamviewer_linux_x64.deb) ...
    dpkg: dependency problems prevent configuration of teamviewer:
    teamviewer depends on lib32asound2; however:
    Package lib32asound2 is not installed.
    teamviewer depends on lib32z1; however:
    Package lib32z1 is not installed.
    teamviewer depends on ia32-libs; however:
    Package ia32-libs is not installed.

    dpkg: error processing teamviewer (--install):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    teamviewer



    apt-get install -f
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    The following packages were automatically installed and are no longer required:
    libc6-i386 linux-image-generic
    Use 'apt-get autoremove' to remove them.
    The following packages will be REMOVED:
    teamviewer
    0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 81.9 MB disk space will be freed.
    Do you want to continue [Y/n]? Y
    (Reading database ... 198146 files and directories currently installed.)
    Removing teamviewer ...


    I have also added Wine package

    What am I doing wrong?





    Regards,
    Sheharyar

  8. #8
    Join Date
    Nov 2013
    Beans
    2

    Re: Installing teamviewer on Ubuntu 12.04 LTS 64bit

    I got the same error on my 64bit Ubuntu 13.10. But i managed to install TeamViewer as 32Bit Version! The only function, that will not work is the autostart. But with the 32bit .deb package, it will install perfectly. sorry about my bad english

  9. #9
    Join Date
    Aug 2013
    Beans
    2,135

    Re: Installing teamviewer on Ubuntu 12.04 LTS 64bit


  10. #10
    Join Date
    Aug 2013
    Beans
    2,135

    Re: Installing teamviewer on Ubuntu 12.04 LTS 64bit

    There is a Chrome addon which does similarly things.
    http://www.tejasbarot.com/2013/08/15...hrome-browser/

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •