Results 1 to 6 of 6

Thread: Driver for ATI Mobility Radeon(TM) HD 4650

  1. #1
    Join Date
    Nov 2012
    Beans
    15

    Driver for ATI Mobility Radeon(TM) HD 4650

    How can I instal the driver for my graphics card ATI Mobility Radeon (TM) HD 4650 supporting HyperMemory technology (MT).
    I thank you in advance to all who try to help me
    Last edited by Jose Ponteira; June 15th, 2013 at 01:18 PM.

  2. #2
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Driver for ATI Mobility Radeon(TM) HD 4650

    Hello!

    The answer to your question depends on which version of Ubuntu you are using. Could you let us know what that is?

    Thanks.

  3. #3
    Join Date
    Nov 2012
    Beans
    15

    Re: Driver for ATI Mobility Radeon(TM) HD 4650

    I have instaled ubuntu 13.04 32 bits

  4. #4
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    Re: Driver for ATI Mobility Radeon(TM) HD 4650

    You are already using the only driver available for your graphics card, this is the open source radeon driver that comes built into Ubuntu.

    ATI dropped support for all of the 2/4xxx series cards last summer so they don't write the closed source drivers for them any more.
    Cheesemill

  5. #5
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Driver for ATI Mobility Radeon(TM) HD 4650

    I'm sure that is unhappy news for you.

    Although there is a legacy driver, it will not work with Ubuntu versions 12.04.2 and beyond because of changes to the kernel and X Server.

    There are methods by which your system can be hacked to function, but I so strongly recommend against them that I won't even point you to them. They basically break your installation. I've had to help two people sort things out already.

    If you want to, you can continue to use the open source Radeon driver Ubuntu is using right now. For the vast majority of people it will work just fine.

    If you really must have the proprietary ATI driver, you will need to fall back to 12.04.1 or earlier. Then I would suggest using the proprietary driver in the Precise repo -- but not the fglrx-updates version.

    There is really nothing to be done about this. Neither anyone at Canonical nor any open source developer do anything to change this. The proprietary ATI driver is not open source and can't be modified. This will not change with newer versions of Ubuntu or any updates from the repos.

    12.04 and 12.04.1 are supported until 2017. That means you can enjoy Ubuntu for another four years without the expense of a new card and still use the proprietary driver. Or just continue as you are doing.

    Sorry for the bad news, but that is simply the way it is.

    Best wishes.

  6. #6
    Join Date
    Nov 2012
    Beans
    15

    Re: Driver for ATI Mobility Radeon(TM) HD 4650

    Thankyou. the information You give is very useful. I think i hav to stay like i am now.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •