I have a Virtual Machine (in ESXi 5.1) running Ubuntu Server 12.04. When I try to boot my system I grub2 tells me "error: unknown filesystem". I've tried booting a Live CD then reinstalling grub from both a chrooted environment and by supplying the --root-directory option. I've even tried a boot-repair CD (results here) and reinstalling grub. Whatever I use to fix it, I'm getting the error "Path `/boot/grub' is not readable by GRUB on boot. Installation is impossible. Aborting."

To complicate things I'm running a RAID5 array (5 disks) using mdadm and btrfs for my filesystem. The btrfs tools that ship with Ubuntu 12.04 are really old. I've added ppa:cjwatson/grub and ppa:yofel/btrfs to my software sources to get more up to date utilities, with no help. The system was previously working before switching from a 4 disk RAID0 setup. I think this was the first reboot since the upgrade, but it was running fine for weeks using RAID5.

I had the same problem on a similarly configured workstation running Linux Mint, but it magically went away after a failed grub-install or failed boot-repair. I have no idea what actually made it work again, but it's fine now.