Results 1 to 5 of 5

Thread: Bad probs after partial upgrade

  1. #1
    Join Date
    Apr 2009
    Location
    Decatur, Il.
    Beans
    129
    Distro
    Ubuntu 12.04 Precise Pangolin

    Bad probs after partial upgrade

    Hi, I recently upgraded to 13.04 and only had to fix a few problems after the upgrade, but after that it was working fine. Then yesterday there was an update message and it said it could only do a partial upgrade and like an idiot I did it. There wasn't a reboot message (though I know it's smart to always reboot after any upgrading operation) so I then commenced to install the Intel graphics drivers from here https://01.org/linuxgraphics/downloads. I then rebooted to find I had major problems as you will see in the screenshot below. I sort of assumed it was either my failure to reboot before i installed anything else or that the drivers I installed were screwy and so I went to the forum for those drivers and someone told me that it only updates a certain lib file and that what he seen in the screenshot would have nothing to do with my current issue. So I have come here for help. The Unity bar hides, but leaves a sort of "ghost" background of the bar when it hides and all other animated docks leave a sort of tracer behind as they move... everything is extremely slow and can't be maximized/minimized when in the background, the only way I can alter a window is if I alt-tab through them which takes a long time to do. My guess is that I have done something to Compiz.I have tried uninstalling the graphics drivers and, of course, it didn't fix anything. Please help.
    We are 138

  2. #2
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Bad probs after partial upgrade

    Times should have teached you to mostly use ubuntu archives & trusted sources (like ppa(s) ) only.

    Boot in recovery mode , select the root option after having enabled the network, then clean the system (clean/autoclean/autoremove), update (using the "dpkg" option)
    Try to purge the installed intel driver, then install xserver-xorg-video-intel
    Finally select "resume" to continue booting

  3. #3
    Join Date
    Apr 2009
    Location
    Decatur, Il.
    Beans
    129
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Bad probs after partial upgrade

    Quote Originally Posted by dino99 View Post
    Times should have teached you to mostly use ubuntu archives & trusted sources (like ppa(s) ) only.

    Boot in recovery mode , select the root option after having enabled the network, then clean the system (clean/autoclean/autoremove), update (using the "dpkg" option)
    Try to purge the installed intel driver, then install xserver-xorg-video-intel
    Finally select "resume" to continue booting
    Believe it or not I do know better, but while playing games, especially Minecraft, it is a considerable difference in fps from Windows to Ubuntu... In Windows I can get a steady 30 fps, while in Ubuntu I can barely get more than 20 with and average of 15 and I was hoping anything would work so I tried that driver....

    Anyway, I had done everything you mentioned already up until installing xserver-xorg-video-intel. I'm not as familiar with dpkg as I am with apt-get, so I am not sure what you mean by update with dpkg? I see there is an --update-avail option, but seems to depend on a specific package, but I am not sure what to do there.

    I tried to use apt-get to install xserver-xorg-video-intel and it says a dependency is missing called xorg-video-abi-11 and says it is not installable so I am getting ready to search that issue, or maybe you can shed some light please? Thanks for your help.
    Last edited by Lateralus138; June 14th, 2013 at 08:08 PM.
    We are 138

  4. #4
    Join Date
    Apr 2009
    Location
    Decatur, Il.
    Beans
    129
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Bad probs after partial upgrade

    Anyone please?
    We are 138

  5. #5
    Join Date
    Apr 2009
    Location
    Decatur, Il.
    Beans
    129
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Bad probs after partial upgrade

    You not getting notificationsdino99?
    We are 138

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •