Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Command line confusion.

  1. #11
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Command line confusion.

    Debian-sensible is another internal variable (not an actual browser) that gets resolved via the /usr/bin/sensible-browser script. It would appear that it uses the value stored in x-www-browser. More information about system alternatives and update-alternatives can be found here and here.

    You can view the list of www browser alternatives on your system with this command:
    Code:
    sudo update-alternatives --list x-www-browser
    I know this is confusing. Perhaps we can simplify things. Which browser do you want to make your main browser? We can set up Xfce to make sure it starts regardless of the method you use to initiate it.

  2. #12
    Join Date
    Mar 2009
    Location
    USA
    Beans
    307
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Command line confusion.

    Quote Originally Posted by Toz View Post
    Debian-sensible is another internal variable (not an actual browser) that gets resolved via the /usr/bin/sensible-browser script. It would appear that it uses the value stored in x-www-browser. More information about system alternatives and update-alternatives can be found here and here.

    You can view the list of www browser alternatives on your system with this command:
    Code:
    sudo update-alternatives --list x-www-browser
    I know this is confusing. Perhaps we can simplify things. Which browser do you want to make your main browser? We can set up Xfce to make sure it starts regardless of the method you use to initiate it.
    Code:
    jb@jb-Compaq-PC:~$ sudo update-alternatives --list x-www-browser
    [sudo] password for jb: 
    /usr/bin/google-chrome
    AHAH!! You are so kind and patient. With this new info .. apparently this Xubuntu came with FF on it. Probably, Web Browser pointed to it ... since there is no 'browser' named Debian Sensible. I must have uninstalled FF and installed Chrome deb. That matches the current evidence.

    I have a Chrome icon on desktop. I managed to properly 'command line' it. I click on Web Browser in menu, which is pointed to Debian Sensible .... and I get CHROME but running NONcommand line. THAT'S because of exo-open!! Therefore, if I am correct, and I think I am, all I need to do is delete the CHROME ICON from desktop, and apply command line parameter to WEB BROWSER.

    exo-open --launch [category] [[parameter]...] -------- exo-open -launch Web Browser --allow-outdated-plugins

    and I should get Chrome with command line and no extra browser installations I don't use. Dat's whut I wanted, Boss.

    1. Give your 'approval' ... and I will make the changes.
    2. I have Xfe set as my preferred File Manager. Do you think I can uninstall THUNAR?? I remember now ... last time I did that, I SAW where Synaptics seemed to want to uninstall some dependencies that looked a LOT like stuff NOT related to Thunar ... and that is what (I think) created the chaos. What do you think?

    Thank you. You are one of the Gods.

    EDIT: Thought I had it .... but cannot figure out WHERE/HOW to pass --allow-outdated-plugins to Web Browser or Debian Sensible ... which ever one/ones it needs to pass to. HANG ON ... DON'T REPLY ... I will be right back. I think it may be working.

    Nope. So close. Web Browser from menu ... preferred to Debian Sensible or Google Chrome opens CHROME without command line.

    CHROME from desktop ICON opens CHROME with command line parameters.

    I need to pass --allow-outdated-plugins to Web Browser somehow.

    Chrome ICON properties/launcher says /opt/google/chrome/google-chrome %U --allow-outdated-plugins in the command field.

    If I create a shortcut on desktop for Web Browser, and edit its LAUNCHER .. the command shows exo-open --launch WebBrowser %u
    Last edited by jfbooth; June 14th, 2013 at 01:51 AM.

  3. #13
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Command line confusion.

    Quote Originally Posted by jfbooth View Post
    Chrome ICON properties/launcher says /opt/google/chrome/google-chrome %U --allow-outdated-plugins in the command field.
    Lets try the easy approach first.

    Create the file /usr/local/bin/start_google:
    Code:
    gksu leafpad /usr/local/bin/start_google
    ...copy/paste this code:
    Code:
    #!/bin/bash
    /opt/google/chrome/google-chrome --allow-outdated-plugins
    ...then save the file.

    Next, we have to make that file executable. Issue this command:
    Code:
    sudo chmod +x /usr/local/bin/start_google
    And finally, in Settings Manager -> Preferred Applications, select Other for the Web Browser dropdown and enter in this command:
    Code:
    /usr/local/bin/start_google
    Does this work?

  4. #14
    Join Date
    Mar 2009
    Location
    USA
    Beans
    307
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Command line confusion.

    Quote Originally Posted by Toz View Post
    Does this work?
    perfectly. I can only babble some kind of gratitude. The Ubuntu forum moderators and supportive members are simply fantastic. Thank you.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •