Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 34

Thread: Error while mounting ntfs drive.

  1. #21
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Error while mounting ntfs drive.

    If you click on a partition that is not mounted with Nautilus then it will auto mount it with defaults and will use the label if you have one.
    So it may not be mounted before fstab?

    As soon as you boot run this:
    mount
    cat /etc/mtab



    And that should show what is mounted before you manually mount anything with Nautilus.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  2. #22
    Join Date
    Jun 2013
    Beans
    26

    Re: Error while mounting ntfs drive.

    Yes, I'm aware of that. I don't mount the drive by clicking on it in nautilus - it is already mounted.

    mount
    cat /etc/mtab
    Code:
    tom@Media-PC:~$ mount
    /dev/sda2 on / type ext4 (rw,noatime,discard,errors=remount-ro)
    proc on /proc type proc (rw,noexec,nosuid,nodev)
    sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
    none on /sys/fs/fuse/connections type fusectl (rw)
    none on /sys/kernel/debug type debugfs (rw)
    none on /sys/kernel/security type securityfs (rw)
    udev on /dev type devtmpfs (rw,mode=0755)
    devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
    tmpfs on /tmp type tmpfs (rw,noatime,mode=1777)
    tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
    none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
    none on /run/shm type tmpfs (rw,nosuid,nodev)
    /dev/sda3 on /home type ext4 (rw,noatime,discard)
    /dev/sdb1 on /media/mediahdd type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
    gvfs-fuse-daemon on /home/tom/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=tom)
    tom@Media-PC:~$ cat /etc/mtab
    /dev/sda2 / ext4 rw,noatime,discard,errors=remount-ro 0 0
    proc /proc proc rw,noexec,nosuid,nodev 0 0
    sysfs /sys sysfs rw,noexec,nosuid,nodev 0 0
    none /sys/fs/fuse/connections fusectl rw 0 0
    none /sys/kernel/debug debugfs rw 0 0
    none /sys/kernel/security securityfs rw 0 0
    udev /dev devtmpfs rw,mode=0755 0 0
    devpts /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
    tmpfs /tmp tmpfs rw,noatime,mode=1777 0 0
    tmpfs /run tmpfs rw,noexec,nosuid,size=10%,mode=0755 0 0
    none /run/lock tmpfs rw,noexec,nosuid,nodev,size=5242880 0 0
    none /run/shm tmpfs rw,nosuid,nodev 0 0
    /dev/sda3 /home ext4 rw,noatime,discard 0 0
    /dev/sdb1 /media/mediahdd fuseblk rw,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
    gvfs-fuse-daemon /home/tom/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=tom 0 0
    tom@Media-PC:~$
    This is after boot, with no fstab entry!

  3. #23
    Join Date
    Dec 2009
    Beans
    5,379

    Re: Error while mounting ntfs drive.

    Anything listed here that might automount the partition:
    Code:
    ls -l $HOME/.config/autostart
    Is this an external usb "drive" ?

  4. #24
    Join Date
    Jun 2013
    Beans
    26

    Re: Error while mounting ntfs drive.

    Code:
    tom@Media-PC:~$ ls -l $HOME/.config/autostart
    total 8
    -rw-rw-r-- 1 tom tom 212 Jun 17 12:03 qbittorrent.desktop
    -rw-rw-r-- 1 tom tom 165 Jun  7 18:34 xbmc.desktop
    These are my 2 startup applications, xbmc is disabled though.

    The drive is a SATA drive.

  5. #25
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Error while mounting ntfs drive.

    Repost fstab

    cat /etc/fstab
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  6. #26
    Join Date
    Jun 2013
    Beans
    26

    Re: Error while mounting ntfs drive.

    Code:
    tom@Media-PC:~$ cat /etc/fstab
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    
    proc    /proc    proc    nodev,noexec,nosuid    0    0
    tmpfs    /tmp    tmpfs    defaults,noatime,mode=1777    0    0
    #Entry for /dev/sda2 :
    UUID=5a1e8c36-abdd-496a-8421-e6486df36fc7    /    ext4    noatime,discard,errors=remount-ro    0    1
    #Entry for /dev/sda3 :
    UUID=088cb6f0-84f9-4246-98ae-5d3662d2d8ec    /home    ext4    noatime,discard,defaults    0    2
    #Entry for /dev/sda1 :
    UUID=15dad974-4171-4753-bd9c-f6610589368f    none    swap    sw    0    0

  7. #27
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Error while mounting ntfs drive.

    What you have happening is not possible. Or perhaps Morbius1 has some other ideas.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  8. #28
    Join Date
    Jun 2013
    Beans
    26

    Re: Error while mounting ntfs drive.

    Not possible? But it's really happening. I'm not pulling a show here ... this is actually really frustrating because I want to move on with this and complete this project.

    Tell me if I need to post logs or anything.

  9. #29
    Join Date
    Dec 2009
    Beans
    5,379

    Re: Error while mounting ntfs drive.

    Quote Originally Posted by oldfred View Post
    What you have happening is not possible. Or perhaps Morbius1 has some other ideas.
    The only possibilities I can think of have pretty much been covered already:

    (1) A udisks mount in startup applications.
    (2) I don't think Ubuntu is capable of this anymore but if you could save your session at shutdown I suppose it would come back mounted at login.
    (3) User created his own udev rule but that would have been such an arduous endeavor a person would remember doing it.

    Having said that I have come across this phenomenon once before: http://ubuntuforums.org/showthread.php?t=2143849

    That user insisted there was an option somewhere in System Settings in 12.10:
    I've noticed that System Settings has an entry which sets this partition as "Automount on Login", but it appears there is no way to set the default permissions.
    Maybe someone else can find it but there is no "Automount on Login" on my system. He stated he's using KDE installed on top of Ububntu so maybe it's a KDE thing. In any event as you can see from the link I couldn't answer that one either.
    Last edited by Morbius1; June 18th, 2013 at 12:22 PM.

  10. #30
    Join Date
    Jun 2013
    Beans
    26

    Re: Error while mounting ntfs drive.

    (2) I don't think Ubuntu is capable of this anymore but if you could save your session at shutdown I suppose it would come back mounted at login.
    I unmount the drive before rebooting (or poweroff), and on the next boot it is mounted again. (with no fstab entry)
    (3) User created his own udev rule but that would have been such an arduous endeavor a person would remember doing it.
    I don't even know what that is .

    My system settings doesn't have the "Automount on Login" option. I'm running only 12.04 Ubuntu, no second OS.

    So ... what do we do? Surely there must be a way to find out how it gets mounted via logs or so? Keep in mind that I'm not the most experienced user, I dont have too much experience yet with linux. That being said I also didn't change too much in my installation. So my system shouldn't be too far from standard.





Page 3 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •