Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: problem running winows executabe on ubuntu 12.04 with mono 2.10.8.1

  1. #11
    Join Date
    Oct 2012
    Beans
    37

    Re: problem running winows executabe on ubuntu 12.04 with mono 2.10.8.1

    I will try this. I have ubuntu 12.04. Thanks...

  2. #12
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: problem running winows executabe on ubuntu 12.04 with mono 2.10.8.1

    Is that 12.04/12.04.1 or is it 12.04.2?

  3. #13
    Join Date
    Oct 2012
    Beans
    37

    Re: problem running winows executabe on ubuntu 12.04 with mono 2.10.8.1

    ubuntu version = 12.04
    fglrx version = 2:8.960-0ubuntu1.1

    Not sure if this is helpful, but I ran fglrxinfo and got the following:
    $ fglrxinfo
    X Error of failed request: BadRequest (invalid request code or no such operation)
    Major opcode of failed request: 153 (GLX)
    Minor opcode of failed request: 19 (X_GLXQueryServerString)
    Serial number of failed request: 12
    Current serial number in output stream: 12

    I did as you suggested from the "Enabling Video Hardware Acceleration" and ended up with the following from vainfo:

    $ sudo vainfo
    libva: VA-API version 0.32.0
    Xlib: extension "XFree86-DRI" missing on display ":0".
    libva: va_getDriverName() returns -1
    vaInitialize failed with error code -1 (unknown libva error),exit
    mike@mike-Aspire-7535:~/ardupilot$ ll /usr/lib/x86_64-linux-gnu/dri/fglrx_drv_video.so
    lrwxrwxrwx 1 root root 17 Apr 21 2012 /usr/lib/x86_64-linux-gnu/dri/fglrx_drv_video.so -> xvba_drv_video.so

    Because of the above error I tried suggestions from this site, http://wiki.cchtml.com/index.php/Ubu...allation_Guide, in the section "Using the xvda-va Driver (VA-API)" installing libva-x11-1, unfortunately vainfo still gave the same error messages.

    Any idea what my next steps would be?

    Thanks...

  4. #14
    Join Date
    Oct 2012
    Beans
    37

    Re: problem running winows executabe on ubuntu 12.04 with mono 2.10.8.1

    Quote Originally Posted by QIII View Post
    Is that 12.04/12.04.1 or is it 12.04.2?
    $ lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 12.04.2 LTS
    Release: 12.04
    Codename: precise

  5. #15
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: problem running winows executabe on ubuntu 12.04 with mono 2.10.8.1

    OK.

    What is the model of your GPU?

  6. #16
    Join Date
    Oct 2012
    Beans
    37

    Re: problem running winows executabe on ubuntu 12.04 with mono 2.10.8.1

    Quote Originally Posted by QIII View Post
    OK.

    What is the model of your GPU?
    QIII, what is the command to use to find that out?

    What if I don't have one?
    Last edited by msousa; June 13th, 2013 at 02:53 AM.

  7. #17
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: problem running winows executabe on ubuntu 12.04 with mono 2.10.8.1

    In the terminal, type

    Code:
    lspci
    That's a lower-case "ell", not a "one".

    Scan down until you find a line that has "VGA compatible controller" in it.

    Post that line back here and we'll take a look.

  8. #18
    Join Date
    Oct 2012
    Beans
    37

    Re: problem running winows executabe on ubuntu 12.04 with mono 2.10.8.1

    I think this is what you're looking for:

    01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS780M/RS780MN [Mobility Radeon HD 3200 Graphics]

  9. #19
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: problem running winows executabe on ubuntu 12.04 with mono 2.10.8.1

    Thanks.

    This makes things clear, but I don't think you are going to like the news.

    AMD/ATI stopped continuing development of the fglrx driver for all HD 4000 models and earlier. Those cards will still work with the legacy driver in the 12.04 and 12.04.1 repo. However, beginning with 12.04.2, changes in the kernel and the change from X Server 1.12 to 1.13 mean that the older driver, no longer updated, will not work. You need an HD 5000 or later series.

    There are ways to get those older cards to work, but I recommend against them so strongly that I will not even bother to point them out. They effectively break your system using a kludge that is bound to cause problems with future updates and dependencies. As a matter of fact, I have already worked with two forum users for whom just that happened.

    So...

    I can't tell you what to do, but 12.04 and 12.04.1 are supported until 2017 and the fglrx driver in the 12.04/12.04.1 repo will still work. I won't say to do it, but if you were to reinstall 12.04 or 12.04.1, you would have access to a driver that will work.

    AMD/ATI caught us all off guard with this. This was not a great service to the Linux community -- particularly when there are new systems still on the shelves with some of those GPUs.

    Sorry for the bad news.

  10. #20
    Join Date
    Oct 2012
    Beans
    37

    Re: problem running winows executabe on ubuntu 12.04 with mono 2.10.8.1

    QIII, thanks for your help. It was at least an education in Linux. I guess I will need to find an alternative to the windows executable...

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •