Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Ubuntu not loading after GRUB

  1. #1
    Join Date
    Oct 2007
    Location
    Staten Island, NY
    Beans
    311
    Distro
    Ubuntu 12.04 Precise Pangolin

    Ubuntu not loading after GRUB

    An odd thing happened. I was on call on Skype, and well, for some reason that thing loves to crash my PC whenever I do video chat.. but anyway, it froze up, I rebooted, went in to GRUB, attempted to load Ubuntu and... nothing. It'll go through some steps (I have no idea what they are), the login will flash for a brief second, and then it just hangs after that. I've got no idea what is going on.

    addendum: this is 13.04 (I need to change my version # on here..)
    Last edited by Kymus; June 9th, 2013 at 12:47 PM.

  2. #2
    Join Date
    Oct 2007
    Location
    Staten Island, NY
    Beans
    311
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu not loading after GRUB

    bump.

  3. #3
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu not loading after GRUB

    If system crashed it may have an issue with partition that a fsck would fix.

    #From liveCD so everything is unmounted,swap off if necessary, change example shown with partition sdb1 to your partition(s)
    #e2fsck is used to check the ext2/ext3/ext4 family of file systems. -p trys fixes where response not required
    sudo e2fsck -C0 -p -f -v /dev/sdb1
    #if errors: -y auto answers yes for fixes needing response see man e2fsck
    sudo e2fsck -f -y -v /dev/sdb1
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  4. #4
    Join Date
    Oct 2007
    Location
    Staten Island, NY
    Beans
    311
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu not loading after GRUB

    Hi oldfred, thanks for your help.

    I booted in to Ubuntu from usb (I saw no option to boot to terminal), opened the terminal, ran sudo e2fsck -C0 -p -f -v /dev/sdb1

    and I got the error that sdb1 wasn't found.. so I tried sdb2 and sdb3 for the hell of it. Nothing.

    Where did I screw up?

  5. #5
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu not loading after GRUB

    My example is sdb1, but you have to use your partitions and they must be the ext2, ext3 or ext4 formatted partitions.

    If unsure of which partitions you can run this and it will show which format & UUID.

    sudo blkid -c /dev/null -o list

    Part of mine (its long):

    Code:
    fred@fred-Precise:~$ sudo blkid -c /dev/null -o list
    device     fs_type label    mount point    UUID
    -------------------------------------------------------------------------------
    /dev/sda1  ntfs    WinXP    (not mounted)  04B05B70B05B6768
    /dev/sda2  ext3    backup   (not mounted)  13a684e4-2849-4566-9528-21cd07028a9a
    /dev/sda4  vfat    SHARE    (not mounted)  46CD-C9B2
    /dev/sdb1  vfat    EFI32    (not mounted)  2404-8A43
    /dev/sdb3  ext4    sys      /media/sys     e2156d09-329e-4262-9549-f72a05d97f93
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  6. #6
    Join Date
    Oct 2007
    Location
    Staten Island, NY
    Beans
    311
    Distro
    Ubuntu 12.04 Precise Pangolin
    Ok, I got fsck to run fine, and after it was done, I rebooted, loaded Ubuntu normally from GRUB, and..... same thing. It just hangs.

    It does some stuff after directly telling it to load, and then a login screen (in the terminal, not in the GUI, just to clarify) will flash for a few seconds, then the screen will basically go black and it just hangs there. I watched the data light and it blinks a couple times in the first minute and then after that it just does nothing; there doesn't seem to be any activity.

  7. #7
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu not loading after GRUB

    That sounds like a video issue of some sort.

    I was just updating my Saucy install and have exactly the same error, but it is still in development & I am sure my nVidia is not configured correctly as I has copied Raring into Saucy and I do not think it updated driver.

    Did you update video or change video drivers?
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  8. #8
    Join Date
    Oct 2007
    Location
    Staten Island, NY
    Beans
    311
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu not loading after GRUB

    Not to my knowledge, no.

    I mean, I don't often reboot my system or otherwise exit out of Ubuntu, so unless it just happened to have updated itself along with the other updates that occur, then no, nothing was updated.

  9. #9
    Join Date
    Oct 2007
    Location
    Staten Island, NY
    Beans
    311
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu not loading after GRUB

    addendum: to my knowledge, there was no prompt present to reboot my system (to finish an update) at the time my system was last running (I could be wrong... but I don't think I am). So I think the likelihood of a video update of some sort I would say is slim.

  10. #10
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu not loading after GRUB

    Try recovery mode, if you have several kernels it will be under Advanced Options.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •