Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 39

Thread: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

  1. #11
    Join Date
    Mar 2012
    Beans
    246

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    As they say, if something is going to gone wrong, it would'vegone even worst. After running boot-repair i can't boot to Vista ), can't boot to Slackware 14 and Slackware 13.37 (even when i choose them from the bios by hitting F9), and the same thing happens with Kubuntu - boot-repair destroyed all their bootloader, and new installed bootloader to a Ubuntu system can't detect Vista and Slackware 14. On system list there is only Ubuntu and Slackware 13.37.

    Great God...

  2. #12
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    As long as you can boot Ubuntu and run

    Code:
    sudo update-grub
    it should work again after reboot, at least what worked before the attempt to repair.

    Please explain again

    1. What happens on the screen when you run sudo update-grub

    2. Are there menuentries in /boot/grub/grub.cfg corresponding to what was found according to the screen? Particularly, is there any menuentry for 'Vista' or for 'Windows recovery'?

    3. Are there corresponding menu items (lines) in the grub menu when you have booted? What happens when you select 'Windows recovery' and try to boot from it?

  3. #13
    Join Date
    Mar 2012
    Beans
    246

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    Quote Originally Posted by sudodus View Post
    Please explain again

    1. What happens on the screen when you run sudo update-grub
    Here is what happens

    firekage@deusex:~$ sudo update-grub
    [sudo] password for firekage:
    Generating grub.cfg ...
    Found linux image: /boot/vmlinuz-3.2.0-24-generic-pae
    Found initrd image: /boot/initrd.img-3.2.0-24-generic-pae
    Found linux image: /boot/vmlinuz-3.2.0-24-virtual
    Found initrd image: /boot/initrd.img-3.2.0-24-virtual
    Found linux image: /boot/vmlinuz-3.2.0-24-generic
    Found initrd image: /boot/initrd.img-3.2.0-24-generic
    Found Slackware Linux (Slackware 13.37.0) on /dev/sda2
    Found Windows Vista (loader) on /dev/sdc1
    Found Ubuntu 12.04.2 LTS (12.04) on /dev/sdd1
    Found Slackware Linux (Slackware 14.0) on /dev/sdg1
    done
    firekage@deusex:~$



    2. Are there menuentries in /boot/grub/grub.cfg corresponding to what was found according to the screen? Particularly, is there any menuentry for 'Vista' or for 'Windows recovery'?
    Yes.
    3. Are there corresponding menu items (lines) in the grub menu when you have booted? What happens when you select 'Windows recovery' and try to boot from it?
    [/quote]
    Yes, exept Vista. It is not being shown on grub during boot and list of detected systems to choose.

    BTW - after grub-repair i can't even boot Vista from bios. I think that grub deleted bootloader, i tried to fix it in windows way (bootrec /fixmbr /fixboot /rebuildbcd) but it doesen't work.

  4. #14
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    One of the options in Boot-Repair is to reinstall grub of your Ubuntu install into ALL mbr. I do not like that choice as I have different boot loaders in every MBR and it looks like you did also.

    You want to reinstall lilo into the MBR's of Windows and your Slackware & Windows installs or sda, sdc & sdd.
    The lilo boot loader works just like Windows in finding the boot flag and jumping to the PBR. PBR then has more boot code for Windows or Lilo.

    Restore basic windows boot loader - universe enabled if error on lilo not found
    Simply open Synaptic and Settings > Repositories and tick the box against the Universe repo in the Ubuntu Software tab. Close that window and click on reload before installing lilo with Synaptic or command line.
    sudo apt-get install lilo
    sudo lilo -M /dev/sda mbr
    May show error messages about the rest of lilo missing, ignore, we just want MBR with bootloader. Rerun for sdc & sdd
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  5. #15
    Join Date
    Mar 2012
    Beans
    246

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    Quote Originally Posted by oldfred View Post
    One of the options in Boot-Repair is to reinstall grub of your Ubuntu install into ALL mbr. I do not like that choice as I have different boot loaders in every MBR and it looks like you did also.
    Didn't know that...


    sudo lilo -M /dev/sda mbr
    I should place it in Slackware and Vista? So i should, for an example, choos /dev/sd(Vista), right?

    Rerun for sdc & sdd
    Could you exmplain it again? Rerun? You mean lilo rerun it nerminal?

  6. #16
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    You install from Ubuntu. But all computers boot from MBR and find more boot code.

    After you download lilo into Ubuntu.
    sudo lilo -M /dev/sda mbr
    sudo lilo -M /dev/sdc mbr
    sudo lilo -M /dev/sdd mbr

    While this is Vista it is how BIOS/MBR computers boot. Grub does not use PBR or partition boot sector but Windows & Lilo do.
    Pictures here worth 1000+ words
    http://www.multibooters.co.uk/multiboot.html
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  7. #17
    Join Date
    Mar 2012
    Beans
    246

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    Ok, and what about "rerun" of lilo?

  8. #18
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    Not sure what you mean.

    If you install lilo's boot loader into a MBR, it should then find the bootable install of Windows or other systems using existing boot flag and existing code in PBR which was not overwritten. Only MBR was overwritten with grub2's boot loader.
    But you still have to go into BIOS and choose to boot that drive directly.

    But grub2 should give you the option to boot every system from your grub menu. Some systems may need a littile help or a manual setting in 40_custom to chain boot other systems from grub. Chainbooting to lilo in a PBR is just like chainloading to Windows.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  9. #19
    Join Date
    Mar 2012
    Beans
    246

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    I did what you suggested :

    Quote Originally Posted by oldfred View Post
    You install from Ubuntu. But all computers boot from MBR and find more boot code.

    After you download lilo into Ubuntu.
    sudo lilo -M /dev/sda mbr
    sudo lilo -M /dev/sdc mbr
    sudo lilo -M /dev/sdd mbr

    While this is Vista it is how BIOS/MBR computers boot. Grub does not use PBR or partition boot sector but Windows & Lilo do.
    Pictures here worth 1000+ words
    http://www.multibooters.co.uk/multiboot.html

    And in case of Vista it works, haven't tried other because i don't have right now enough time but i would ask about one thing - it is necessary to write

    sudo lilo -M /dev/sdX mbr
    instead

    sudo lilo -M /dev/sdX
    there must be mbr after device?

    Also, it is possible to install this from another system, like Slackware, to other os, like Vista? I don't know how to do it under Slackware.

  10. #20
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    X is device number, and MBR is what is being installed. I do not know Slackware so maybe installing from inside Slackware does not need that, but if not it then is a default setting. Or it may be doing the full install of Lilo which is not just MBR but also PBR and boot configuration file or menu.
    But you would not want to install the full Lilo to a Windows install as that would overwrite the Windows code in the NTFS PBR or partition boot sector. Windows has to have its code in the PBR.

    Many Repair Linux liveCD have lilo installed already so it often can be installed from any version. It is an old boot loader that has been around for ages. I think recently they started maintaining it again, but it was like old grub legacy and did not work with a lot of newer systems.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







Page 2 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •