Page 1 of 4 123 ... LastLast
Results 1 to 10 of 39

Thread: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

  1. #1
    Join Date
    Mar 2012
    Beans
    246

    Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    Hi!

    I would like to ask for your help. I have problem with Ubuntu, Kubuntu related to not detecting Windows Vista in grub. I run update-grub or update-grub2 and see that on generated cfg there is Windows Vista, also when i use sudo os-prober the same list is being generated with Windows Vista but as soon as i reboot, see purple grub with available systems to boot, there is no Windows Vista.

    I think that it is related to call 30_os-prober in /etc/default/grub or /etc/grub.d/ (im on Windows right now, can't check it). The only way of starting Windows is not from grub but by hitting F8 and selecting hard disk with it.

    Could you help me? I tried to find a solution, few have the same problem but running os-prober in my case didn't helped at all.

    Thanks.

  2. #2
    Join Date
    Mar 2012
    Beans
    246

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    Here are the outputs of update-grub, update-grub2 and os-prober

    Code:
    firekage@deusex:~$ sudo os-prober
    [sudo] password for firekage: 
    /dev/sda2:Slackware Linux (Slackware 13.37.0):Slackware:linux
    /dev/sdc1:Windows Vista (loader):Windows:chain
    /dev/sdd1:Slackware Linux (Slackware 14.0):Slackware1:linux
    /dev/sdf1:Ubuntu 12.04.2 LTS (12.04):Ubuntu:linux
    and
    Code:
    firekage@deusex:~$ sudo update-grub
    Generating grub.cfg ...
    Found linux image: /boot/vmlinuz-3.2.0-24-generic-pae
    Found initrd image: /boot/initrd.img-3.2.0-24-generic-pae
    Found linux image: /boot/vmlinuz-3.2.0-24-virtual
    Found initrd image: /boot/initrd.img-3.2.0-24-virtual
    Found linux image: /boot/vmlinuz-3.2.0-24-generic
    Found initrd image: /boot/initrd.img-3.2.0-24-generic
    Found memtest86+ image: /boot/memtest86+.bin
    Found Slackware Linux (Slackware 13.37.0) on /dev/sda2
    Found Windows Vista (loader) on /dev/sdc1
    Found Slackware Linux (Slackware 14.0) on /dev/sdd1
    Found Ubuntu 12.04.2 LTS (12.04) on /dev/sdf1
    done
    and
    Code:
    firekage@deusex:~$ sudo update-grub2
    Generating grub.cfg ...
    Found linux image: /boot/vmlinuz-3.2.0-24-generic-pae
    Found initrd image: /boot/initrd.img-3.2.0-24-generic-pae
    Found linux image: /boot/vmlinuz-3.2.0-24-virtual
    Found initrd image: /boot/initrd.img-3.2.0-24-virtual
    Found linux image: /boot/vmlinuz-3.2.0-24-generic
    Found initrd image: /boot/initrd.img-3.2.0-24-generic
    Found memtest86+ image: /boot/memtest86+.bin
    Found Slackware Linux (Slackware 13.37.0) on /dev/sda2
    Found Windows Vista (loader) on /dev/sdc1
    Found Slackware Linux (Slackware 14.0) on /dev/sdd1
    Found Ubuntu 12.04.2 LTS (12.04) on /dev/sdf1
    done
    firekage@deusex:~$
    It is, during reboot on purple grub, it isn't.

  3. #3
    Join Date
    Mar 2012
    Beans
    246

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    Help needed

  4. #4
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    7,028

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    Probably another distro is governing grub, I mean, the bootloader points to another system. Then it does not help with update-grub. You need to do from the installed system, that is governing grub.

    See these links for more details

    https://help.ubuntu.com/community/Grub2
    https://help.ubuntu.com/community/Grub2/Installing

    and links from them. Maybe you want to reinstall grub.

  5. #5
    Join Date
    Jan 2008
    Location
    France
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    @firekage: please run Boot-Repair's Recommended Repair, and indicate the URL that will appear.

  6. #6
    Join Date
    Mar 2012
    Beans
    246

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    Funny thing is that i update grub from installed system, from Ubuntu installed on 1TB Samsung drive. I have exacly the same problem with Kubuntu.

  7. #7
    Join Date
    Mar 2012
    Beans
    246

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    Ok, here is the link:

    http://paste.ubuntu.com/5770704/


    Well, still the same problem after doing boot repair. Vista is being present during update-grub, no present, at all, during reboot on purple grub system list.
    Last edited by firekage; June 16th, 2013 at 01:20 PM.

  8. #8
    Join Date
    Jan 2008
    Location
    France
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    You have several disks. Probably your issue is that your BIOS is not booting on the right disk.
    Please look at your BIOS and tell us on which disk it is set up to boot.
    Then change the boot order in order to make it boot on Ubuntu's disk. (1TB)

  9. #9
    Join Date
    Mar 2012
    Beans
    246

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    Samsung 1TB drive with Ubuntu is being set in bios. If it would be different choose than i wouldn't have purple grub on start (it would be either slackware lilo or blue kubuntu grub) so the disk it the one that should be.

  10. #10
    Join Date
    Mar 2012
    Beans
    246

    Re: Ubuntu, Kubuntu, debian based systems can't detect Windows Vista

    Forgot to mention that during running boot-repair i have warning that there is low disk space on Vista destination disk and boot repair told me that there could be problem with running it (starting it?) but i don't believe that amount of space is cruicial to grub-loader.

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •