Results 1 to 9 of 9

Thread: Dell Latitude E6400 - Connects to wireless, but doesn't open pages.

  1. #1
    Join Date
    Jun 2013
    Beans
    7

    Dell Latitude E6400 - Connects to wireless, but doesn't open pages.

    I'm relatively new to linux and ubuntu, but I've heard it's a good starting point so I decided to get it running. I have a fair grasp on setting things up, all the sudo apt-get stuff, and for the most part, it sorted itself out. I had it connected to an ethernet cable during install to get updates before I got it started, and when I unplugged it, it connected fine to the wifi at home, but when I attempted to open google through firefox, it failed to work. I was told to do "sudo modprobe lib80211_crypt" and when I entered that, it says "FATAL: Module lib80211_crypt not found". any help is appreciated, thanks.

    EDIT: I'm also running 12.04, not 13.04.
    Last edited by hking0036; June 8th, 2013 at 03:41 AM.

  2. #2
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,730
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Dell Latitude E6400 - Connects to wireless, but doesn't open pages.

    Hi, copy and paste this command in the terminal (ctrl+alt+t) please:
    Code:
     wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script
    It will download a script and create a file named wireless-info.tar.gz in your home folder with wireless information so we can see the condition of your wireless at this time and the Mac address, WPA key and WEP key are removed for your security, then reply back, click on the paper clip and attach the wireless-info.tar.gz file as a zip file.

    If you do not have ethernet either then follow the directions at this link for running the script without internet.
    http://ubuntuforums.org/showpost.php?p=12350385
    Thanks

  3. #3
    Join Date
    Jun 2013
    Beans
    7

    Re: Dell Latitude E6400 - Connects to wireless, but doesn't open pages.

    Alright, after running the script, it just gave me a .txt, and not a tar.gz, but here it is.
    Attached Files Attached Files

  4. #4
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,730
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Dell Latitude E6400 - Connects to wireless, but doesn't open pages.

    Please do:
    Code:
    echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
    sudo modprobe -rfv iwlwifi
    sudo modprobe -v iwlwifi
    copy and paste one line at a time.

    Also please change your channel to 1 or 11.

    We may have to disable power management.
    Thanks

  5. #5
    Join Date
    Jun 2013
    Beans
    7

    Re: Dell Latitude E6400 - Connects to wireless, but doesn't open pages.

    Alright, followed those commands and then changed the channel to 1, restarting the router now, I'll get back to you in a moment with the results.

    EDIT: Thank you very much, this solved the problem. (You can close the thread now)

  6. #6
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,730
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Dell Latitude E6400 - Connects to wireless, but doesn't open pages.

    Glad it worked.

  7. #7
    ahallubuntu is offline Chocolate-Covered Ubuntu Beans
    Join Date
    Jul 2005
    Beans
    2,050

    Re: Dell Latitude E6400 - Connects to wireless, but doesn't open pages.

    ~
    Last edited by ahallubuntu; June 24th, 2013 at 02:20 AM.

  8. #8
    Join Date
    Jun 2013
    Beans
    7

    Re: Dell Latitude E6400 - Connects to wireless, but doesn't open pages.

    Quote Originally Posted by ahallubuntu View Post
    I don't consider disabling 802.11n on my wireless cards acceptable except as a very last resort, because I don't want to lose 1/2 my local network speed (or more). Transferring files over my local network is important to me. For only browsing the internet, 802.11g is fine I guess. But I've never needed to disable 802.11n on any of my Intel wireless cards running Ubuntu 12.04. (I use the WiFi Link 5100 not 5300 in most of my laptops.)
    If it was upgraded, it wasn't by me. I got my laptop off of ebay... XD
    Last edited by hking0036; June 8th, 2013 at 05:12 AM.

  9. #9
    ahallubuntu is offline Chocolate-Covered Ubuntu Beans
    Join Date
    Jul 2005
    Beans
    2,050

    Re: Dell Latitude E6400 - Connects to wireless, but doesn't open pages.

    ~
    Last edited by ahallubuntu; June 24th, 2013 at 02:20 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •