Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: Get-iplayer now doesn't work for us !

  1. #1
    Join Date
    Apr 2008
    Location
    Norfolk, UK
    Beans
    691
    Distro
    Ubuntu 12.04 Precise Pangolin

    Get-iplayer now doesn't work for us !

    My wife regularly downloads video and radio programmes from the BBC via get-iplayer using 12.04 on a Sony viao, but this morning half way through a download it came up with an error message.
    To check, I tried the same down load on my hp6700, and the first programme downloaded OK, but the second one threw up the same error message ......

    WARNING: ffmpeg does not exist - not converting flv file
    INFO: File name prefix = Sherlock_Series_1_-_2._The_Blind_Banker_b00tc6t2_default
    WARNING: Your version of flvstreamer/rtmpdump does not support SWF Verification
    FLVStreamer v2.1c1
    (c) 2010 Andrej Stepanchuk, Howard Chu, The Flvstreamer Team; license: GPL
    ERROR: Last tag size must be greater/equal zero (prevTagSize=400147357) and smaller then filesize, corrupt file!
    INFO: Command exit code 1 (raw code = 256)
    WARNING: Retry recording for 'Sherlock: Series 1 - 2. The Blind Banker (b00tc6t2)'
    Her laptop downloads radio programmes via get-iplayer OK, but not videos.

    We'd be very grateful if anyone could advise, and guide us towards solving the problem.

    John
    Last edited by grey1beard; June 11th, 2013 at 08:33 PM.
    It's like doing jigsaw puzzles in the dark.

  2. #2
    Join Date
    Apr 2008
    Location
    Norfolk, UK
    Beans
    691
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Get-iplayer now doesn't work for us !

    OK, so my laptop doesn't like me telling tales out of school !
    This time it worked as normal, with the usual error message that seems to be part of the workaround.
    I've no idea why, as I havent done anything differently.
    At both previous attempts, I removed the partial downloads, before trying again, as previous experience has shown that sometimes a restart will pick up where it left off, but sometimes not.

    So at this moment, both laptops are behaving themselves, but if anyone can point out any hidden meaning in the error message, at least I'd have learned something !

    John
    It's like doing jigsaw puzzles in the dark.

  3. #3
    Join Date
    Apr 2008
    Location
    Norfolk, UK
    Beans
    691
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Get-iplayer now doesn't work for us !

    This morning, the same thing has occurred, with the error message as before, the download reaching ~430 Mb out of a total ~560 Mb.
    ERROR: Last tag size must be greater/equal zero (prevTagSize=400147357) and smaller then filesize, corrupt file!
    INFO: Command exit code 1 (raw code = 256)
    She's removed the partial download, and is trying again.
    I have a feeling that the problem is external to the laptop, but have no knowledge to back that up.

    It's just failed again, at 288 Mb, with only the "prevTagSize" figure different.

    Trying for a third time.
    It's like doing jigsaw puzzles in the dark.

  4. #4
    Join Date
    Apr 2008
    Location
    Norfolk, UK
    Beans
    691
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Get-iplayer now doesn't work for us !

    This time a new message has appeared, a window in front of the terminal window (which is showing a simillar message as before) -

    Problem in flvstreamer

    Sorry, the program flvstreamer closed unexpectedly.
    Your computer does not have enough free memory to automatically analyse the problem and send a report to the developers.
    Possibly not significant, but then what do I know

    John
    It's like doing jigsaw puzzles in the dark.

  5. #5
    Join Date
    Jan 2010
    Location
    Hyperborea
    Beans
    1,441
    Distro
    Ubuntu

    Re: Get-iplayer now doesn't work for us !

    WARNING: ffmpeg does not exist - not converting flv file
    See this thread:
    http://ubuntuforums.org/showthread.p...9#post12651629

    I'm not sure about the other errors but it may help if you have the latest version of get_iplayer.
    You have trimmed your output so I cannot see, it should be vers. 2.8.2
    If not go here:
    http://www.infradead.org/get_iplayer...t_iplayer.html
    Download and extract the get_iplayer perl script (348.4kB) and just overwrite the version that you have in /usr/bin.
    Edit: You will need to change the permissions to match the original file.
    Use "gksu nautilus" in a terminal
    Set
    Owner = root (RW)
    Group = root (R)
    Others = Read Only
    Execute = Allow

    To extract just double click the get_iplayer.tar.gz file.
    Last edited by coldraven; May 27th, 2013 at 11:19 AM.

  6. #6
    Join Date
    Jan 2013
    Location
    East Yorkshire
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Get-iplayer now doesn't work for us !

    get-iplayer is working fine here, but I updated get-iplayer & ffmpeg using the following commands:
    Code:
    sudo add-apt-repository ppa:jon-severinsson/ffmpeg
    and
    Code:
    sudo add-apt-repository ppa:jon-hedgerows/get-iplayer
    then
    Code:
    sudo apt-get update && sudo apt-get upgrade
    Everything should now work fine.

  7. #7
    Join Date
    Apr 2008
    Location
    Norfolk, UK
    Beans
    691
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Get-iplayer now doesn't work for us !

    Hi coldraven, and thanks for your help.
    Both our laptops have 2.80 running on them, so I'll try setting mine up first.
    I've downloaded 2.82 and extracted the contents as a folder get_iplayer-2.82 onto my desktop.

    Quote Originally Posted by coldraven View Post
    Edit: You will need to change the permissions to match the original file.
    Use "gksu nautilus" in a terminal
    Set
    Owner = root (RW)
    Group = root (R)
    Others = Read Only
    Execute = Allow

    To extract just double click the get_iplayer.tar.gz file.
    Sorry, coldraven, but this has got me lost. I've never used gksu nautilus before, so when I typed it into Terminal, gave it my password, I was then faced with a Terminal line -"Initialising nautilus-gdu extension " and a window showing my home folder. So my next step is unknown to me.

    I understand what I am trying to do, but not the route !
    So I'd be grateful if you could spell it out for me.
    John
    It's like doing jigsaw puzzles in the dark.

  8. #8
    Join Date
    Apr 2008
    Location
    Norfolk, UK
    Beans
    691
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Get-iplayer now doesn't work for us !

    Hi speartip.
    I used your lines of code on my wifes laptop, and so far all seems well.
    However, something that has happened to me before has re-occurred. Update manager immediately ran and gave me a warning message over the top of the UM window, to the effect that some of the updates were unauthenticated. How do you get round this, as it keeps reappearing ? I tried just unticking the ppa entries which seemed to be the problem, but I'm thinking it will come back again in the future.
    Regards
    John
    It's like doing jigsaw puzzles in the dark.

  9. #9
    Join Date
    Jan 2013
    Location
    East Yorkshire
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Get-iplayer now doesn't work for us !

    Quote Originally Posted by grey1beard View Post
    Hi speartip.
    However, something that has happened to me before has re-occurred. Update manager immediately ran and gave me a warning message over the top of the UM window, to the effect that some of the updates were unauthenticated. How do you get round this, as it keeps reappearing ? I tried just unticking the ppa entries which seemed to be the problem, but I'm thinking it will come back again in the future.
    Regards
    John
    Not too sure, the 2 ppas I gave above should not give that error.
    A quick google brought this up, it may help.
    http://www.answeredubuntu.com/85641/...oftware_center

  10. #10
    Join Date
    Apr 2008
    Location
    Norfolk, UK
    Beans
    691
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Get-iplayer now doesn't work for us !

    Thanks speartip.
    Looks promising, and if the problem persists, I'll try that.
    I'm assuming that approach is universal ?

    Regards
    John
    It's like doing jigsaw puzzles in the dark.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •