Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: Problem with wireless/wired connections.

  1. #21
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Problem with wireless/wired connections.

    Quote Originally Posted by salih1 View Post
    Hmm.. looks much better now. But I couldn't decipher the encryption type from the outputs. So just make sure that the encryption type in the router/access-point is set to pure WPA2-PSK (AES) type, and especially NOT WPA/WPA2 mixed mode.

    Then, do the following -
    Code:
    sudo iwconfig wlan0 power off
    sudo modprobe -rfv rt2800pci
    sudo modprobe -v rt2800pci nohwcrypt=Y
    Then try to connect and see if you can.

    Sometimes it also helps if you 'Save' the correct security type and security-key in the Network Manager itself (under "Wireless Security" tab in your wireless connection settings box in Network Manager).
    Last edited by varunendra; June 9th, 2013 at 09:31 AM. Reason: typo
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  2. #22
    Join Date
    Jun 2013
    Beans
    13

    Re: Problem with wireless/wired connections.

    There were no security enabled for this network...It is open. I dont know why the output shows like that. I eneterd that code and it tried to reconnect but failed. Everything is fine with usb modem. What to do????
    I also tried with security enabled and assignd a paswd(not in mixd mode) but still no change..

  3. #23
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Problem with wireless/wired connections.

    Quote Originally Posted by salih1 View Post
    There were no security enabled for this network...It is open. I dont know why the output shows like that. I eneterd that code and it tried to reconnect but failed. Everything is fine with usb modem. What to do????
    I also tried with security enabled and assignd a paswd(not in mixd mode) but still no change..
    A couple of suggestions, 1st one first, both together if required -

    1) Try changing the channel to 1, 6 or 11 - the one that is least used in your neighborhood (currently you are using channel 4). Channel 6 is something I personally *believe* should be good based on some theoretical knowledge, but have absolutely no practical experience or evidence.

    Those who have both a good level of theoretical knowledge as well as practical experience recommend channels 1 and 11 the most. So try them first.

    2) Try Wicd and remove Network Manager altogether exactly as per steps given here : https://help.ubuntu.com/community/WI...e_.2BAC8_Unity

    Please note that you won't get the tray icon on the top right corner like network manager. Wicd does not have that. It needs to be opened from Applications menu like other normal applications.

    Use the commands in my previous post with wicd as well if required.

    Everything else looks good.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  4. #24
    Join Date
    Jun 2013
    Beans
    13

    Re: Problem with wireless/wired connections.

    Changed channels several times..nothing happened.
    Installed Wicd, did some changes in settings...still nothing.
    It shows a problem in obtaining IP address.( connection is open)
    wired is okey..

    Checked wicd with usb modem..seems fine.
    What is happening with ma lap

  5. #25
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Problem with wireless/wired connections.

    Quote Originally Posted by salih1 View Post
    It shows a problem in obtaining IP address.( connection is open)
    wired is okey..
    Hmm.. okay, please do -
    Code:
    echo "options rt2800pci nohwcrypt=Y" | sudo tee -a /etc/modprobe.d/rt2800pci.conf
    .. do a reboot after this, try to connect, let it fail, then post back the outputs of -

    Code:
    lsmod
    iwconfig
    ifconfig
    cat /etc/resolv.conf
    sudo iwlist wlan0 scan
    dmesg | grep -iE 'rt2|wlan'
    cat /var/log/syslog | grep -iE 'rt2|wlan|dhcp|dhclient|network'
    modinfo rt2800pci
    And keep the security to either pure WPA2-PSK (AES) or disabled in the router.

    EDIT:
    Edited the dmesg command and added cat /etc/resolv.conf
    Please post as per updated commands.
    Last edited by varunendra; June 11th, 2013 at 05:36 AM.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying you? Perhaps this is why.

  6. #26
    Join Date
    Jun 2013
    Beans
    13

    Re: Problem with wireless/wired connections.

    Router security is in disabled mode.
    Outputs are:
    lsmode--->http://paste.ubuntu.com/5755640/

    iwconfig-->http://paste.ubuntu.com/5755657/

    cat /etc/resolv.conf-->http://paste.ubuntu.com/5755663/

    sudo iwlist wlan0 scan-->http://paste.ubuntu.com/5755670/

    dmesg | grep -iE 'rt2|wlan'-->http://paste.ubuntu.com/5755679/

    cat /var/log/syslog | grep -iE 'rt2|wlan|dhcp|dhclient|network'-->http://paste.ubuntu.com/5755697/

    modinfo rt2800pci-->http://paste.ubuntu.com/5755703/
    ------
    Thank u...

  7. #27
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    5,878
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Problem with wireless/wired connections.

    "(reason 3)" in the dmesg-output comes from the network-manager. Remove your current wireless profile and create a new one.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •