Results 1 to 3 of 3

Thread: Help getting serial console running?

  1. #1
    Join Date
    Jun 2013
    Beans
    3

    Help getting serial console running?

    I'm trying to get a serial console working (on linux) and connect to it from windows (trying putty and teraterm). I have a null modem cable that is plugged into serial port of each (both only have 1 port)

    I do this on linux (nothing is setup in inittab yet).
    Code:
    root@test:/var/log# /sbin/getty -L ttyS0 115200 vt100
    No errors, no output. I also tried ttyS1 and ttyS2.

    Then I open Putty (or teraterm) and it opens, but I don't get any output from either linux (getty) or windows (putty). I tried both 11520 and 9600 on both sides.

    For troubleshooting I also tried this (on linux with getty running):

    Code:
    statserial /dev/ttyS0
    It gives this output (doesn't change or update).

    Code:
    Device: /dev/ttyS0
    
    Signal  Pin  Pin  Direction  Status  Full
    Name    (25) (9)  (computer)         Name
    -----   ---  ---  ---------  ------  -----
    FG       1    -      -           -   Frame Ground
    TxD      2    3      out         -   Transmit Data
    RxD      3    2      in          -   Receive  Data
    RTS      4    7      out         1   Request To Send
    CTS      5    8      in          1   Clear To Send
    DSR      6    6      in          1   Data Set Ready
    GND      7    5      -           -   Signal Ground
    DCD      8    1      in          1   Data Carrier Detect
    DTR     20    4      out         1   Data Terminal Ready
    RI      22    9      in          0   Ring Indicator
    This is only thing I can find in /var/log related to serial :

    Code:
    [    0.000000] console [tty0] enabled
    [    0.576339] serial8250: ttyS2 at I/O 0x3e8 (irq = 4) is a 16550A
    [    0.596874] 00:08: ttyS2 at I/O 0x3e8 (irq = 4) is a 16550A
    [    0.617041] 0000:00:03.3: ttyS0 at I/O 0x1240 (irq = 17) is a 16550A
    I've been using this as a rough guide; but seems a bit out of date [last update was in 2003 and has some commands that are no longer in repo?]: http://www.tldp.org/HOWTO/Remote-Ser...WTO/index.html


    Any suggestions on how to troubleshoot this? It's a bit frustrating due to lack of output from either side. Is there any way to get more info to see what might be going on? Any other diagnose programs that might be useful?
    Last edited by feralape; June 7th, 2013 at 01:55 AM.

  2. #2
    Join Date
    May 2010
    Location
    uk
    Beans
    8,077
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Help getting serial console running?

    Hi

    (nothing is setup in inittab yet).
    Ubuntu does not use inittab anymore - not since dapper drake.

    Ditch that tutorial as it is ancient.

    Take a look at

    http://superuser.com/questions/45884...ng-serial-port

    and

    https://help.ubuntu.com/community/SerialConsoleHowto

    Does that get you closer ?

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

  3. #3
    Join Date
    Jun 2013
    Beans
    3

    Re: Help getting serial console running?

    Great, thank you! It's working now

    biggest problem was I was a dork and had the wrong interface (was using ttyS0 instead of ttyS2 - I thought I tried then both, but guess not). But those link were quite useful and helped me sort it out. Thanks for your time, it's working beautifully now.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •