Results 1 to 8 of 8

Thread: External 1T Harddrive won't mount

  1. #1
    Join Date
    Jun 2013
    Beans
    3

    Unhappy External 1T Harddrive won't mount

    Hello.

    My external 1T drive produced an error on my Windows Vista and stopped being accessible. Other computers could access it for a while and then it wasn't accessible to anyone. It wouldn't mount on Gentoo, and it won't mount on my Mint desktop although it does show up as a drive, it just won't mount.

    So I searched the forums and found a post about a similar situation, and the first piece of instruction was the following code and to post the output.

    sudo lshw -C disk

    *-disk
    description: SCSI Disk
    product: 41AS
    vendor: ST315003
    physical id: 0.0.0
    bus info: scsi@5:0.0.0
    logical name: /dev/sdb
    version: 3004
    serial: 00A123457DBB
    size: 1397GiB (1500GB)
    capabilities: gpt-1.00 partitioned partitioned:gpt
    configuration: ansiversion=6 guid=466e3284-ac6a-11e0-a04e-001ff33ea433 sectorsize=512

    Please help a Linux n00b get back her hard drive of squee.
    Last edited by Artificial Intelligence; June 4th, 2013 at 05:05 AM. Reason: added prefix

  2. #2
    Join Date
    Oct 2004
    Location
    Denmark - Scandinavia
    Beans
    17,619
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: External 1T Harddrive won't mount (Mint)

    Thread moved to Other OS/Distro Support.
    elementary OS Luna
    My Screenshot

  3. #3
    Join Date
    Aug 2005
    Beans
    6,022

    Re: External 1T Harddrive won't mount

    First things first, did you remove it from the USB enclosure and connect it to your PC via a SATA interface?

  4. #4
    Join Date
    Jun 2013
    Beans
    3

    Re: External 1T Harddrive won't mount

    Sort of yes. I took it out of the case and put it into a brand new case because I couldn't get my hands on a SATA interface. On my windows laptop I also downloaded a partition repair program and scanned it for repare (unfortunately I can't remember the name of it), and the drive and came out with it being an unformated drive. But then again, the other day an hour or so after I posted this, the drive appeared to work for about five minutes just plugged in to the Mint desktop without doing anything. So I have no idea if it's just stuffed or if my data can be rescued.

  5. #5
    Join Date
    Aug 2005
    Beans
    6,022

    Re: External 1T Harddrive won't mount

    Quote Originally Posted by Keyana View Post
    Sort of yes. I took it out of the case and put it into a brand new case because I couldn't get my hands on a SATA interface.

    plugged in to the Mint desktop without doing anything.
    So that's a no then.

    Open up your desktop and connect the drive to the motherboard via a sata cable. The power & sata connectors on a desktop are the same as on a laptop and they fit without any funny interfaces etc.

    Once you have done that we can run some command to gather info.

  6. #6
    Join Date
    Jun 2013
    Beans
    3

    Re: External 1T Harddrive won't mount

    Unfortunately, my desktop is old. Like, doesn't have any SATA connector cables old. I've only got IDE cables. The only adapters I could find to possibly buy were SATA-to-USB not SATA to IDE, I don't even know if this motherboard takes SATA, granted, my hardware tech knowledge is about as old as this desktop... Lol.

    Does this essentially mean I'm probably going to have to save up and go to a technician?

  7. #7
    Join Date
    Aug 2005
    Beans
    6,022

    Re: External 1T Harddrive won't mount

    Quote Originally Posted by Keyana View Post
    Unfortunately, my desktop is old. Like, doesn't have any SATA connector cables old. I've only got IDE cables. The only adapters I could find to possibly buy were SATA-to-USB not SATA to IDE, I don't even know if this motherboard takes SATA, granted, my hardware tech knowledge is about as old as this desktop... Lol.

    Does this essentially mean I'm probably going to have to save up and go to a technician?
    What motherboard do you have?

  8. #8
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: External 1T Harddrive won't mount

    You seem to be getting some info that drive may be gpt partitioned? That would be a bit unusual with Vista, as only 64 bit Vista can even read gpt partitioned drives. Gpt partitioning is the new partition scheme used with new computers that boot with UEFI or very large drives over 2TB. Most drives were MBR(msdos) partitioned.

    What format was partition(s) on drive? Often external drives get disconnected incorrectly and need chkdsk if NTFS or fsck if a Linux ext2, ext3, or ext4 format.

    Post this, if drive can be seen:
    sudo parted /dev/sdb unit s print

    Otherwise you may want to see if testdisk can see drive:

    https://help.ubuntu.com/community/DataRecovery
    http://www.cgsecurity.org/wiki/TestDisk
    repairs including testdisk info & links
    http://members.iinet.net.au/~herman546/p21.html
    https://help.ubuntu.com/community/Da...st%20Partition
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •