Results 1 to 4 of 4

Thread: Grub recovery menu and boot graphics issues

  1. #1
    Join Date
    Sep 2009
    Location
    London
    Beans
    896

    Grub recovery menu and boot graphics issues

    After upgrading from 12:10 to 13:04 on one of my old laptops (Medion) the image is "fuzzy". The Grub menu is fine, but the recovery menu and the scripts that appear whilst it boots are also unreadable and fuzzy. I originally was unable to boot past Grub on the new kernel, but solved the problem in the upgrade thread by changing the boot commands to "nomodeset", but that only fixed the Login screen. This only affected the new kernel and I was not able to determine if it got bast the login screen, however this is irrelevant as that is now fixed.

    Any ideas, please.
    Attached Images Attached Images
    Last edited by Jonners59; June 1st, 2013 at 05:56 PM.

  2. #2
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Grub recovery menu and boot graphics issues

    Something with the video driver and default screen settings. But if you cannot read screens it becomes difficult to reset.

    What video chip do you have? Some Intel need the exact video mode set as a boot parameter instead of nomodeset.

    Some other settings:
    http://ubuntu-tutorials.com/2010/05/...up-workaround/


    • Older Intel video card: i915.modeset=1 or i915.modeset=0 newer: i915.i915_enable_rc6=1
    • nVidia: nomodeset
    • Generic: xforcevesa or nouveau.modeset=0
    • Radeon: radeon.modeset=0


    Limited resolutions with Sandybridge graphics
    http://ubuntuforums.org/showthread.php?t=2057807
    With 11.04:SandyBridge
    http://ubuntuforums.org/showthread.php?t=1817374
    acpi_osi=linux pci=noacpi

    Newer Intel may need this:

    Force Intel Video mode as boot parameter in grub menu
    video=1280x1024-24@60
    and if that doesn't work you can try
    video=VGA-1:1280x1024-24@60

    For Intel graphics running slow:
    sudo apt-get install mesa-utils
    glxinfo | grep OpenGL | head -n3
    For info on UEFI boot install & repair - Updated Mar 2015:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  3. #3
    Join Date
    Sep 2009
    Location
    London
    Beans
    896

    Re: Grub recovery menu and boot graphics issues

    Hiya Oldfred
    Thanks for below. I know it is an old card, as it is an old machine, if 10 years is old How do I identify the card? Just found the code. Will try it later tonight or weekend.
    Code:
    sudo lshw -C video


    Thought I should add, when I first upgraded this machine from 12:10 to 13:04 it was so bad I could not even get to the Login in screen and was totally un-usable. I managed to fix that myself taking heed of some of the advise you gave me a couple of years back - adding "nomodeset" to the parameters, however the Text and background image during the session between GRUB and Login Screen is still completely distorted and just shows colours and fuzzy text. When in GRUB and select "Advanced", the menu is fuzzy and so is the "Recovery" menu.....

    Whilst trying to fix this I joined another thread which was all about fixing graphics after upgrades (http://ubuntuforums.org/showthread.php?t=1743535) and tried a number of things there as suggested. I started a new thread because this issue had outlived that one. I have pasted below a snapshot of what I did and what information it gave me.

    Code:
    italy@italy:~$
    Code:
    uname-arLinux italy 3.5.0-28-generic #48-Ubuntu SMP Tue Apr 23 23:05:48UTC 2013 i686 i686 i686 GNU/Linux
    
    italy@italy:~$ cat /etc/lsb-releaseDISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=13.04
    DISTRIB_CODENAME=raring
    DISTRIB_DESCRIPTION="Ubuntu13.04"

    Takenfrom working kernel.
    PS:Noteconfig file comment "greeter-session=unity-greeter"Note it talks of unity-I do not use Unity soI changed it to session=xubuntu, itmade no difference.


    Code:
    cat/etc/lightdm/lightdm.conf > ~/Documents/lightdm.conf
    Code:
    sudocat /var/log/lightdm/lightdm.log > ~/Documents/lightdm.log

    [CODE][SeatDefaults]greeter-session=unity-greeter
    user-session=ubuntu
    allow-guest=false[/CODE]

    Code:
    [+0.09s]DEBUG: Logging to /var/log/lightdm/lightdm.log[+0.09s] DEBUG:Starting Light Display Manager 1.6.0, UID=0 PID=1226
    Code:
    [+0.09s]DEBUG: Loaded configuration from /etc/lightdm/lightdm.conf
    [+0.09s]DEBUG: Using D-Bus name org.freedesktop.DisplayManager
    [+0.67s]DEBUG: Registered seat module xlocal
    [+0.67s]DEBUG: Registered seat module xremote
    [+0.67s]DEBUG: Adding default seat
    [+0.67s]DEBUG: Starting seat
    [+0.67s]DEBUG: Starting new display for greeter
    [+0.67s]DEBUG: Starting local X display
    [+0.68s]DEBUG: X server :0 will replace Plymouth
    [+0.71s]DEBUG: Using VT 7
    [+0.71s]DEBUG: Logging to /var/log/lightdm/x-0.log
    [+0.71s]DEBUG: Writing X server authority to/var/run/lightdm/root/:0
    [+0.71s]DEBUG: Launching X Server
    [+0.71s]DEBUG: Launching process 1249: /usr/bin/X :0 -core -auth/var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch -backgroundnone
    [+0.71s]DEBUG: Waiting for ready signal from X server :0
    [+0.84s]DEBUG: Acquired bus name org.freedesktop.DisplayManager
    [+0.84s]DEBUG: Registering seat with bus path/org/freedesktop/DisplayManager/Seat0
    [+4.97s]DEBUG: Got signal 10 from process 1249
    [+4.97s]DEBUG: Got signal from X server :0
    [+4.97s]DEBUG: Stopping Plymouth, X server is ready
    [+5.75s]DEBUG: Connecting to XServer :0
    [+5.75s]DEBUG: Starting greeter
    [+5.76s]DEBUG: Started session 1324 with service 'lightdm-greeter', username'lightdm'
    [+6.28s]DEBUG: Session 1324 authentication complete with return value 0:Success
    [+6.28s]DEBUG: Greeter authorized
    [+6.28s]DEBUG: Logging to /var/log/lightdm/x-0-greeter.log
    [+6.28s]DEBUG: Session 1324 running command/usr/lib/lightdm/lightdm-greeter-session/usr/sbin/unity-greeter
    [+12.16s]DEBUG: Greeter connected version=1.6.0
    [+12.16s]DEBUG: Greeter connected, display is ready
    [+12.16s]DEBUG: New display ready, switching to it
    [+12.16s]DEBUG: Activating VT 7
    [+17.09s]DEBUG: Greeter start authentication for italy
    [+17.09s]DEBUG: Started session 1854 with service 'lightdm', username'italy'
    [+17.19s]DEBUG: Session 1854 authentication complete with return value 0:Success
    [+17.19s]DEBUG: Authenticate result for user italy: Success
    [+17.22s]DEBUG: User italy authorized
    [+17.25s]DEBUG: Greeter start authentication for italy
    [+17.25s]DEBUG: Session 1854: Sending SIGTERM
    [+17.25s]DEBUG: Started session 1866 with service 'lightdm', username'italy'
    [+17.25s]DEBUG: Session 1854 terminated with signal 15
    [+17.34s]DEBUG: Session 1866 authentication complete with return value 0:Success
    [+17.34s]DEBUG: Authenticate result for user italy: Success
    [+17.37s]DEBUG: User italy authorized
    [+924.03s]DEBUG: Greeter requests session xubuntu
    [+924.03s]DEBUG: Using session xubuntu
    [+924.03s]DEBUG: Stopping greeter
    [+924.03s]DEBUG: Session 1324: Sending SIGTERM
    [+925.81s]DEBUG: Greeter closed communication channel
    [+925.81s]DEBUG: Session 1324 exited with return value 0
    [+925.81s]DEBUG: Greeter quit
    [+927.30s]DEBUG: Dropping privileges to uid 1000
    [+927.30s]DEBUG: Calling setresgid
    [+927.30s]DEBUG: Calling setresuid
    [+927.31s]DEBUG: Restoring privileges
    [+927.31s]DEBUG: Calling setresuid
    [+927.31s]DEBUG: Calling setresgid
    [+927.75s]DEBUG: Dropping privileges to uid 1000
    [+927.75s]DEBUG: Calling setresgid
    [+927.76s]DEBUG: Calling setresuid
    [+927.76s]DEBUG: Writing /home/italy/.dmrc
    [+927.86s]DEBUG: Restoring privileges
    [+927.86s]DEBUG: Calling setresuid
    [+927.86s]DEBUG: Calling setresgid
    [+927.99s]DEBUG: Starting session xubuntu as user italy
    [+927.99s]DEBUG: Session 1866 running command /usr/sbin/lightdm-sessionstartxfce4
    [+928.68s]DEBUG: Registering session with bus path/org/freedesktop/DisplayManager/Session0
    Last edited by Jonners59; June 7th, 2013 at 08:31 AM. Reason: Just found the information I wanted...

  4. #4
    Join Date
    Sep 2009
    Location
    London
    Beans
    896

    Re: Grub recovery menu and boot graphics issues

    I have nomodeset and an nVidia card, but it still does not work..

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •