Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Hard Disks not mounting after using Storage Device Manager

  1. #11
    Join Date
    Jun 2013
    Beans
    161

    Re: Hard Disks not mounting after using Storage Device Manager

    Unfortunately theres no way around it other than to format the partition.
    If your Torrents partition isnt too big you can copy over the files to another drive/format/move back i guess.

  2. #12
    Join Date
    Dec 2009
    Beans
    5,370

    Re: Hard Disks not mounting after using Storage Device Manager

    Well, at this point too many cooks will definitely spoil this broth but ....

    UUID=C4808E6A808E6332 /media/Windows ntfs auto,user,exec,rw,windows_names 0 0
    There's no need for auto and rw since they are in the defaults. user is silly, you haven't addressed the inability to send something to the trash correctly, character encoding is missing, and ....
    UUID=70D6-1701 /media/efi nouser,ro,noexec 0 0
    Do you want the system to guess what filesystem to use? And at best I'll give you the benefit of the doubt and guess it's a typo that you used "nouser" and really meant to use "noauto" if it is in fact the "windows boot loader".

  3. #13
    Join Date
    Jun 2013
    Beans
    161

    Re: Hard Disks not mounting after using Storage Device Manager

    yea you're write i wrote pretty hastely. feel free to correct it.

  4. #14
    Join Date
    Jun 2013
    Beans
    10

    Re: Hard Disks not mounting after using Storage Device Manager

    Thanks guys,
    So what I need to do is add the lines MidnightGrey posted, with Morbius1's corrections to fstab?

    Its funny that Morbius mentioned it, but my trash can does have some strange limitations on how much data can be sent there. Does that mean I should or should not add 'user' to the line?

    Thanks again, and sorry my ignorance has dragged this out over a few days.

  5. #15
    Join Date
    Dec 2009
    Beans
    5,370

    Re: Hard Disks not mounting after using Storage Device Manager

    An ntfs line should look something like this which will take care of most contingencies:
    Code:
     UUID=5874C4B574C496E2 /media/FilesPrime ntfs defaults,nls=utf8,umask=000,uid=1000,windows_names 0 0
    Here is the definition of the "user" option:
    user: Allow an ordinary user to mount the filesystem. The name of the mounting user is
    written to mtab so that he can unmount the filesystem again.
    First Sentence: Why do you want an ordinary user to mount the partition. The whole idea of having it in fstab is so the ordinary user doesn't have to do anything.

    Second Sentence and the one most pertinent in this discussion: During the booting process there is only one user at the moment the system reads the instructions in fstab and that is root. Only root will be able to unmount the partition. The user option is meaningless in this situation since that is the default behavior.

    The only practical use of "user" is when you also add "noauto" but that means the partition will not mount at boot forcing the user to mount it manually.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •