Results 1 to 2 of 2

Thread: VMWare Tools 9.2.2 (w/ VMWare Fusion 5.0.3) and Ubuntu 13.04 - FIXED

  1. #1
    Join Date
    May 2013
    Beans
    1

    VMWare Tools 9.2.2 (w/ VMWare Fusion 5.0.3) and Ubuntu 13.04 - FIXED

    Here is a patch to get VMWare Tools 9.2.2 (which comes with VMWare Fusion 5.0.3) working with Ubuntu 13.04 (x64).

    This information is based on a few other threads etc. Links at bottom of post.

    First download the following files (make sure you save them with the names given):
    vmwaretools-fix.sh: http://pastebin.com/k35PzXYU
    vmtools.inode.c.patch: http://pastebin.com/2ewxWAun
    vmtools.linux-driver.c.patch: http://pastebin.com/73rJ3316

    Create a new directory. Copy into it your "VMwareTools-9.x.x.xxxxx.tar.gz" file, and all of the files above you just downloaded

    If needed, do a chmod +x vmwaretools-fix.sh

    Then run: ./vmwaretools-fix.sh

    This patched vmware tools 9.2.2 successfully for me, and there were no compile errors at all during installation.

    Based on http://ubuntuforums.org/showthread.p...6#post12630786 and http://kb.vmware.com/selfservice/mic...rnalId=2050666
    Last edited by nacholito; June 2nd, 2013 at 12:41 AM.

  2. #2
    Join Date
    Jul 2013
    Beans
    1

    Re: VMWare Tools 9.2.2 (w/ VMWare Fusion 5.0.3) and Ubuntu 13.04 - FIXED

    Just wanted to say thanks for compiling this - it fixed my vmware tools install on Fusion 5.03 with Mint 15 x64.

    I did have to run it through dos2unix before I ran it though, cos I got encoding errors:

    Code:
    curl http://pastebin.com/raw.php?i=k35PzXYU | dos2unix > vmwaretools-fix.sh

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •