Page 4 of 4 FirstFirst ... 234
Results 31 to 35 of 35

Thread: Installing Ubuntu 13.04 on a New Asus Q500A Laptop.

  1. #31
    Join Date
    Oct 2005
    Location
    Wabasha MN
    Beans
    2,206
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Installing Ubuntu 13.04 on a New Asus Q500A Laptop.

    I started the install of 13.04 and chose the upgrade. I was thinking it might not change the grub or boot partition. but here is what I got:
    Error when upgrading.png
    I chose the "continue" then got a message
    The attempt to mount a file system with type vfat in scsi(0,0,0), partition (sda) at /boot/ efi failed.
    I continued anyway hopeing that the install would complet and not touch the boot partition or the grub.
    It is deleting file that are not needed in 13.04 right now and I am waiting for the install to finish.
    My hometown on the Mississippi River.
    Using a Asus 3632QM laptop with 8gig RAM, 750gig Hybrid.
    Machine Registered 366271, 366273, 366275.
    Registered Ubuntu user number 18630. Registered Linux user number 458093.

  2. #32
    Join Date
    Mar 2011
    Beans
    433

    Re: Installing Ubuntu 13.04 on a New Asus Q500A Laptop.

    I'd suggest backing up the entire working EFI partition at this point. The partition should be mounted at /boot/efi , and you can copy the files to a thumbdrive. I think the 12.04 install puts the entire grub.cfg into the EFI/ubuntu directory, but the 13.04 just puts in a stub which includes the grub.cfg from the usual /boot/grub location. With the stub in place, the normal kernel updates will be picked up by the efi boot.

  3. #33
    Join Date
    Oct 2005
    Location
    Wabasha MN
    Beans
    2,206
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Installing Ubuntu 13.04 on a New Asus Q500A Laptop.

    This has really been a headache. I ended up with not being able to get into either Ubuntu or Windows. Lucking I had a restore for windows on a USB so I just got done setting my system back to factory. But I notice that I still have the Ubuntu partitions. I plan on booting the Live OS and running gparted and deleting it and growing the windows partition again. I am getting to the point where I am just going to use the Live OS if I need to run Ubuntu and forget about installing it on this machine. Maybe I will wait for the next release and see if it plays better with the new hardware.
    My hometown on the Mississippi River.
    Using a Asus 3632QM laptop with 8gig RAM, 750gig Hybrid.
    Machine Registered 366271, 366273, 366275.
    Registered Ubuntu user number 18630. Registered Linux user number 458093.

  4. #34
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Installing Ubuntu 13.04 on a New Asus Q500A Laptop.

    Are you able to mount the efi partition. Grub has to be able to install its files into it.

    Some system have a issue with the efi partition. Not sure if corruption or somehow they have locked it. The main work around has been to fully back it up, delete it, and then recreate a new FAT32 partition with boot flag and restore all the efi files & folders.

    grub-efi fails to install with Input/output error - locked efi
    https://bugs.launchpad.net/ubuntu/+s...2/+bug/1090829
    cannot mount /sys/firmware/efi/efivars on boot - 13.04 kernel issue
    https://bugs.launchpad.net/ubuntu/+s...x/+bug/1146868
    Some find chkdsk on efi partition helps, others backup, reformat and restore as current work arounds.
    Oldfred on vacation. Back Sept 9. Will not have much if any Internet access.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  5. #35
    Join Date
    Oct 2005
    Location
    Wabasha MN
    Beans
    2,206
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Installing Ubuntu 13.04 on a New Asus Q500A Laptop.

    Quote Originally Posted by oldfred View Post
    Are you able to mount the efi partition. Grub has to be able to install its files into it.

    Some system have a issue with the efi partition. Not sure if corruption or somehow they have locked it. The main work around has been to fully back it up, delete it, and then recreate a new FAT32 partition with boot flag and restore all the efi files & folders.

    grub-efi fails to install with Input/output error - locked efi
    https://bugs.launchpad.net/ubuntu/+s...2/+bug/1090829
    cannot mount /sys/firmware/efi/efivars on boot - 13.04 kernel issue
    https://bugs.launchpad.net/ubuntu/+s...x/+bug/1146868
    Some find chkdsk on efi partition helps, others backup, reformat and restore as current work arounds.
    Oldfred thanks for all the help on this one but I need to put it to rest for awhile. I may come back to this at a later date, but right now I am trying to get all my programs and date back in windows. This may take me awhile. Right now windows is doing some updates seeing I had to start from scratch. I also deleted the Ubuntu partition and expanded the Windows partition for now. I feel there are some really issues with 13.04 install on new hardware. Also I might have to download and create a new USB because it won't even boot any more or maybe it is just a setting in the BIOS.
    Again thanks for the help.
    My hometown on the Mississippi River.
    Using a Asus 3632QM laptop with 8gig RAM, 750gig Hybrid.
    Machine Registered 366271, 366273, 366275.
    Registered Ubuntu user number 18630. Registered Linux user number 458093.

Page 4 of 4 FirstFirst ... 234

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •