Page 1 of 8 123 ... LastLast
Results 1 to 10 of 79

Thread: A Packages Problem,Unable to install anything due to unconfigured and depandesies

  1. #1
    Join Date
    May 2013
    Location
    Newyork
    Beans
    35
    Distro
    Ubuntu Studio 13.10 Saucy Salamander

    A Packages Problem,Unable to install anything due to unconfigured and depandesies

    Hi, I've had 12.10 for four months now, problem for 3 its an amazing OS, but my problem i think is when i left it updating and installing packages and in the middle the electricity went off, i've tried every single command and way on every thread and site, nothing worked.. this is the Line.. please help,Thank you so very much.

    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      linux-headers-3.5.0-17 linux-headers-3.5.0-17-generic ttf-droid ttf-umefont
      ttf-unfonts-core wine-gecko1.4
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 183 not upgraded.
    17 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Setting up ubuntu-drivers-common (1:0.2.71.1) ...
    [Errno 2] No such file or directory: '/usr/share/ubuntu-drivers-common/detect/sl-modem.py'
    [Errno 2] No such file or directory: '/usr/share/ubuntu-drivers-common/detect/arm-gles.py'
    [Errno 2] No such file or directory: '/usr/share/ubuntu-drivers-common/detect/open-vm-dkms.py'
    dpkg: error processing ubuntu-drivers-common (--configure):
     subprocess installed post-installation script returned error exit status 1
    Setting up lsb-release (4.0-0ubuntu26.1) ...
    dpkg (subprocess): unable to execute installed post-installation script (/var/lib/dpkg/info/lsb-release.postinst): Input/output error
    dpkg: error processing lsb-release (--configure):
     subprocess installed post-installation script returned error exit status 2
    dpkg: dependency problems prevent configuration of python3-distupgrade:
     python3-distupgrade depends on lsb-release; however:
      Package lsb-release is not configured yet.
    
    dpkg: error processing python3-distupgrade (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python3-update-manager:
     python3-update-manager depends on python3-distupgrade; however:
      Package python3-distupgrade is not configured yet.
     python3-update-manager depends on lsb-release; however:
      Package lsb-release is not configured yet.
    
    dpkg: error processing python3-update-manager (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of ubuntu-release-upgrader-core:
     ubuntu-release-upgrader-core depends on python3-distupgrade (= 1:0.190.5); however:
      Package python3-distupgrade is not coNo apport report written because the error message indicates its a followup error from a previous failure.
                                                                     No apport report written because MaxReports is reached already
                                                   No apport report written because MaxReports is reached already
                                 No apport report written because MaxReports is reached already
               No apport report written because MaxReports is reached already
                                                                             No apport report written because MaxReports is reached already
                                                           No apport report written because MaxReports is reached already
                                         No apport report written because MaxReports is reached already
                       No apport report written because MaxReports is reached already
     No apport report written because MaxReports is reached already
                                                                   No apport report written because MaxReports is reached already
                                                 nfigured yet.
    
    dpkg: error processing ubuntu-release-upgrader-core (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of update-manager-core:
     update-manager-core depends on python3-update-manager (= 1:0.174.4); however:
      Package python3-update-manager is not configured yet.
     update-manager-core depends on lsb-release; however:
      Package lsb-release is not configured yet.
     update-manager-core depends on ubuntu-release-upgrader-core; however:
      Package ubuntu-release-upgrader-core is not configured yet.
    
    dpkg: error processing update-manager-core (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python3-apport:
     python3-apport depends on lsb-release; however:
      Package lsb-release is not configured yet.
    
    dpkg: error processing python3-apport (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of apport:
     apport depends oNo apport report written because MaxReports is reached already
                                                                                   No apport report written because MaxReports is reached already
                                                                 No apport report written because MaxReports is reached already
                                               No apport report written because MaxReports is reached already
                             n python3-apport (>= 2.6.1-0ubuntu10); however:
      Package python3-apport is not configured yet.
    
    dpkg: error processing apport (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of apport-gtk:
     apport-gtk depends on python3-apport (>= 2.6.1-0ubuntu10); however:
      Package python3-apport is not configured yet.
     apport-gtk depends on apport (>= 0.41); however:
      Package apport is not configured yet.
    
    dpkg: error processing apport-gtk (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of firefox:
     firefox depends on lsb-release; however:
      Package lsb-release is not configured yet.
    
    dpkg: error processing firefox (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of xul-ext-unity:
     xul-ext-unity depends on firefox (>= 10.0); however:
      Package firefox is not configured yet.
    
    dpkg: error processing xul-ext-unity (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of firefox-globalmenu:
     firefox-globalmenu depends on firefox (= 19.0+build1-0ubuntu0.12.10.2); however:
      Package firefox is not configured yet.
    
    dpkg: error processing firefox-globalmenu (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of firefox-gnome-support:
     firefox-gnome-support depends on firefox; however:
      Package firefox is not configured yet.
    
    dpkg: error processing firefox-gnome-support (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-apport:
     python-apport depends on lsb-release; however:
      Package lsb-release is not configured yet.
    
    dpkg: error processing python-apport (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of update-manager:
     update-manager depends on update-manager-core (= 1:0.174.4); however:
      Package update-manager-core is not configured yet.
    
    dpkg: error processing update-manager (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of ubuntu-release-upgrader-gtk:
     ubuntu-release-upgrader-gtk depends on ubuntu-release-upgrader-core (= 1:0.190.5); however:
      Package ubuntu-release-upgrader-core is not configured yet.
     ubuntu-release-upgrader-gtk depends on update-manager; however:
      Package update-manager is not configured yet.
     ubuntu-release-upgrader-gtk depends on python3-distupgrade (= 1:0.190.5); however:
      Package python3-distupgrade is not configured yet.
    
    dpkg: error processing ubuntu-release-upgrader-gtk (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of xdiagnose:
     xdiagnose depends on python3-apport; however:
      Package python3-apport is not configured yet.
    
    dpkg: error processing xdiagnose (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     ubuntu-drivers-common
     lsb-release
     python3-distupgrade
     python3-update-manager
     ubuntu-release-upgrader-core
     update-manager-core
     python3-apport
     apport
     apport-gtk
     firefox
     xul-ext-unity
     firefox-globalmenu
     firefox-gnome-support
     python-apport
     update-manager
     ubuntu-release-upgrader-gtk
     xdiagnose
    Last edited by thekoalover; June 11th, 2013 at 06:19 PM. Reason: added code tags

  2. #2
    Join Date
    May 2013
    Location
    Newyork
    Beans
    35
    Distro
    Ubuntu Studio 13.10 Saucy Salamander

    Re: A Packages Problem,Unable to install anything due to unconfigured and depandesies

    bump

  3. #3
    Join Date
    Apr 2008
    Location
    Norwich CT
    Beans
    1,527
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: A Packages Problem,Unable to install anything due to unconfigured and depandesies

    I saw your request for help. Try this:

    sudo apt-get -f install


    and see what happens

    I drink my Ubuntu black, no sugar.
    Ubuntu user 28819

  4. #4
    Join Date
    May 2013
    Location
    Newyork
    Beans
    35
    Distro
    Ubuntu Studio 13.10 Saucy Salamander

    Re: A Packages Problem,Unable to install anything due to unconfigured and depandesies

    kl
    Last edited by thekoalover; May 30th, 2013 at 12:18 AM.

  5. #5
    Join Date
    May 2013
    Location
    Newyork
    Beans
    35
    Distro
    Ubuntu Studio 13.10 Saucy Salamander

    Re: A Packages Problem,Unable to install anything due to unconfigured and depandesies

    @Oldrocker99 This Happens, Same Thing


    Code:
    thekoalover@Batman:~$ sudo apt-get -f install
    [sudo] password for thekoalover: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      linux-headers-3.5.0-17 linux-headers-3.5.0-17-generic ttf-droid ttf-umefont
      ttf-unfonts-core wine-gecko1.4
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 183 not upgraded.
    17 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Setting up ubuntu-drivers-common (1:0.2.71.1) ...
    [Errno 2] No such file or directory: '/usr/share/ubuntu-drivers-common/detect/sl-modem.py'
    [Errno 2] No such file or directory: '/usr/share/ubuntu-drivers-common/detect/arm-gles.py'
    [Errno 2] No such file or directory: '/usr/share/ubuntu-drivers-common/detect/open-vm-dkms.py'
    dpkg: error processing ubuntu-drivers-common (--configure):
     subprocess installed post-installation script returned error exit status 1
    Setting up lsb-release (4.0-0ubuntu26.1) ...
    dpkg (subprocess): unable to execute installed post-installation script  (/var/lib/dpkg/info/lsb-release.postinst): Input/output error
    dpkg: error processing lsb-release (--configure):
     subprocess installed post-installation script returned error exit status 2
    dpkg: dependency problems prevent configuration of python3-distupgrade:
     python3-distupgrade depends on lsb-release; however:
      Package lsb-release is not configured yet.
    
    dpkg: error processing python3-distupgrade (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python3-update-manager:
     python3-update-manager depends on python3-distupgrade; however:
      Package python3-distupgrade is not configured yet.
     python3-update-manager depends on lsb-release; however:
      Package lsb-release is not configured yet.
    
    dpkg: error processing python3-update-manager (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of  ubuntu-release-upgradNo apport report written because the error message  indicates its a followup error from a previous failure.
                      No apport report written because MaxReports is reached already
    No apport report written because MaxReports is reached already
                                                                  No apport report written because MaxReports is reached already
                                                No apport report written because MaxReports is reached already
                              No apport report written because MaxReports is reached already
            No apport report written because MaxReports is reached already
                                                                          No  apport report written because MaxReports is reached already
                                                        No apport report written because MaxReports is reached already
                                      No apport report written because MaxReports is reached already
                    No apport report written because MaxReports is reached already
                                                                                  er-core:
     ubuntu-release-upgrader-core depends on python3-distupgrade (= 1:0.190.5); however:
      Package python3-distupgrade is not configured yet.
    
    dpkg: error processing ubuntu-release-upgrader-core (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of update-manager-core:
     update-manager-core depends on python3-update-manager (= 1:0.174.4); however:
      Package python3-update-manager is not configured yet.
     update-manager-core depends on lsb-release; however:
      Package lsb-release is not configured yet.
     update-manager-core depends on ubuntu-release-upgrader-core; however:
      Package ubuntu-release-upgrader-core is not configured yet.
    
    dpkg: error processing update-manager-core (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python3-apport:
     python3-apport depends on lsb-release; however:
      Package lsb-release is not configured yet.
    
    dpkg: error processing python3-apport (--No apport report written because MaxReports is reached already
                           No apport report written because MaxReports is reached already
         No apport report written because MaxReports is reached already
                                                                       No  apport report written because MaxReports is reached already
                                                     configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of apport:
     apport depends on python3-apport (>= 2.6.1-0ubuntu10); however:
      Package python3-apport is not configured yet.
    
    dpkg: error processing apport (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of apport-gtk:
     apport-gtk depends on python3-apport (>= 2.6.1-0ubuntu10); however:
      Package python3-apport is not configured yet.
     apport-gtk depends on apport (>= 0.41); however:
      Package apport is not configured yet.
    
    dpkg: error processing apport-gtk (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of firefox:
     firefox depends on lsb-release; however:
      Package lsb-release is not configured yet.
    
    dpkg: error processing firefox (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of xul-ext-unity:
     xul-ext-unity depends on firefox (>= 10.0); however:
      Package firefox is not configured yet.
    
    dpkg: error processing xul-ext-unity (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of firefox-globalmenu:
     firefox-globalmenu depends on firefox (= 19.0+build1-0ubuntu0.12.10.2); however:
      Package firefox is not configured yet.
    
    dpkg: error processing firefox-globalmenu (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of firefox-gnome-support:
     firefox-gnome-support depends on firefox; however:
      Package firefox is not configured yet.
    
    dpkg: error processing firefox-gnome-support (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-apport:
     python-apport depends on lsb-release; however:
      Package lsb-release is not configured yet.
    
    dpkg: error processing python-apport (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of update-manager:
     update-manager depends on update-manager-core (= 1:0.174.4); however:
      Package update-manager-core is not configured yet.
    
    dpkg: error processing update-manager (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of ubuntu-release-upgrader-gtk:
     ubuntu-release-upgrader-gtk depends on ubuntu-release-upgrader-core (= 1:0.190.5); however:
      Package ubuntu-release-upgrader-core is not configured yet.
     ubuntu-release-upgrader-gtk depends on update-manager; however:
      Package update-manager is not configured yet.
     ubuntu-release-upgrader-gtk depends on python3-distupgrade (= 1:0.190.5); however:
      Package python3-distupgrade is not configured yet.
    
    dpkg: error processing ubuntu-release-upgrader-gtk (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of xdiagnose:
     xdiagnose depends on python3-apport; however:
      Package python3-apport is not configured yet.
    
    dpkg: error processing xdiagnose (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     ubuntu-drivers-common
     lsb-release
     python3-distupgrade
     python3-update-manager
     ubuntu-release-upgrader-core
     update-manager-core
     python3-apport
     apport
     apport-gtk
     firefox
     xul-ext-unity
     firefox-globalmenu
     firefox-gnome-support
     python-apport
     update-manager
     ubuntu-release-upgrader-gtk
     xdiagnose
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Last edited by oldos2er; May 30th, 2013 at 01:59 AM. Reason: Please use code tags to contain large terminal output.

  6. #6
    Join Date
    Apr 2008
    Location
    Norwich CT
    Beans
    1,527
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: A Packages Problem,Unable to install anything due to unconfigured and depandesies

    Well, it looks like your system may be hosed beyond my ability to help. It it had happened to me, I would simply reinstall the system. This is a LOT faster if your /home is on another partition, otherwise you should back up your /home folder and reinstall.


    Sorry to be the bearer of bad news...

    I drink my Ubuntu black, no sugar.
    Ubuntu user 28819

  7. #7
    Join Date
    May 2013
    Location
    Newyork
    Beans
    35
    Distro
    Ubuntu Studio 13.10 Saucy Salamander

    Re: A Packages Problem,Unable to install anything due to unconfigured and depandesies

    nah it's okay thank you very much, ill keep this thread and spreading around till i get an answer, reinstalling is not an option right now thanks a lot,Friend

  8. #8
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    7,801
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: A Packages Problem,Unable to install anything due to unconfigured and depandesies

    thekoalover;

    What ya got here 'pears to be what is termed "dependency hell" ! As (re-)installing is not an option, perhaps with time and patience we can work through it, For starters, get rid of obsolete files and related dunnage :
    Code:
     sudo apt-get autoclean
    sudo apt-get autoremove
    sudo apt-get clean
    And now to start the descent, do some pok'n at "apport-gtk" :
    Post the output of terminal code:
    Code:
    dpkg - L apport-gtk
    , try'n to get down to the base of one dependency, work our way around. Tackle these things - one thing-at-a-time ....

    Looks like if we can fix "apport-gtk" may make a lot of packages happy.

    wont know 'till we try

    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  9. #9
    Join Date
    May 2013
    Location
    Newyork
    Beans
    35
    Distro
    Ubuntu Studio 13.10 Saucy Salamander

    Re: A Packages Problem,Unable to install anything due to unconfigured and depandesies

    Bashing-om;
    So I Tried All The Codes, And This Happens, Now What,And Thank You For The Reply
    Code:
     thekoalover@Batman:~$ dpkg -L apport-gtk
    /.
    /usr
    /usr/share
    /usr/share/doc
    /usr/share/doc/apport-gtk
    /usr/share/doc/apport-gtk/copyright
    /usr/share/apport
    /usr/share/apport/apport-gtk.ui
    /usr/share/apport/apport-gtk
    /usr/share/applications
    /usr/share/applications/apport-gtk-mime.desktop
    /usr/share/doc/apport-gtk/changelog.Debian.gz

  10. #10
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,918
    Distro
    Ubuntu Development Release

    Re: A Packages Problem,Unable to install anything due to unconfigured and depandesies

    Hi

    dpkg (subprocess): unable to execute installed post-installation script (/var/lib/dpkg/info/lsb-release.postinst): Input/output error
    This is your main problem and is the reason why you are having most of the dependencies problems you are having.

    We need to take a look at this file.

    Please post the output of

    Code:
    stat /var/lib/dpkg/info/lsb-release.postinst
    Code:
    ls -li /var/lib/dpkg/info/lsb-release.postinst
    Code:
    file /var/lib/dpkg/info/lsb-release.postinst
    Code:
    df -h | grep /$
    Have you tried to run fsck on the partition from a LiveCD/USB or from recovery mode yet ?

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

Page 1 of 8 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •