Results 1 to 4 of 4

Thread: Déjà Dup doesn't ask for password for FTP, CIFS, WebDAV or SSH backups

  1. #1
    Join Date
    Jan 2011
    Beans
    7

    Question Déjà Dup doesn't ask for password for FTP, CIFS, WebDAV or SSH backups

    Hello

    I'd like to backup my laptop to my local NAS (a Synology DS212). The Syno supports FTP, WebDAV, CIFS or SSH. For backup, I'd like to use Déjà Dup.

    In Deja Dup, I configured it to use FTP, like so: Backup (519×429) @ 2013-05-26 12.33.46.png

    I also tried SSH, WebDAV and CIFS. The FTP target directory does exist: a@ask-home: ~ (644×455) @ 2013-05-26 12.40.53.png

    But when I then try to run a backup, it never passes beyond this screen: Back Up (390×395) @ 2013-05-26 12.33.55.png

    And it also never asked for a password. I guess, it should've, shouldn't it?

    When I run "deja-dup --backup" from the command line, I don't see any error or so. Just that window shown in the 3rd screenshot pops up, and that's that.


    Well - what did I do wrong and how do I use deja-dup to do backups to FTP/SSH/SFTP/CIFS/WebDAV?

    Thanks,
    Alexander

  2. #2
    Join Date
    Apr 2005
    Beans
    13

    Re: Déjà Dup doesn't ask for password for FTP, CIFS, WebDAV or SSH backups

    Same thing here, did you find any workaround?

  3. #3
    Join Date
    Apr 2005
    Beans
    13

    Re: Déjà Dup doesn't ask for password for FTP, CIFS, WebDAV or SSH backups

    I found a solution. deja actually works with sftp. You need to add sftp support to your ssh server by adding the following line to the sshd_config file:

    Code:
    Subsystem sftp /usr/libexec/openssh/sftp-server
    And restart your sshd server.

    HTH, cheers,

    Pedro.

  4. #4
    Join Date
    Aug 2013
    Beans
    1

    Unhappy Re: Déjà Dup doesn't ask for password for FTP, CIFS, WebDAV or SSH backups

    Well, if it were that easy…


    I do have sftp enabled:

    Code:
    root@Speicher ~ # grep sftp /etc/ssh/sshd_config 
    #Subsystem    sftp    /usr/libexec/sftp-server
    #Subsystem       sftp    internal-sftp -f DAEMON -l VERBOSE -u 000
    Subsystem       sftp    internal-sftp -f DAEMON -u 000
    #Subsystem       sftp    /usr/syno/sbin/sftp-server -l DEBUG3
    And sure enough, sftp works from the command line:

    Code:
    (1)9:52% sftp admin@disk
    Connected to disk.
    sftp> pwd
    Remote working directory: /
    sftp> cd home
    sftp> mkdir Sicherung
    sftp> cd Sicherung/
    sftp> mkdir DejaDup
    sftp> cd DejaDup
    sftp> pwd
    Remote working directory: /home/Sicherung/DejaDup
    sftp> ^D



    And it does not work.



    To be honest, I gave up on Deja Dup. I contacted the dev but didn't get a good, concrete answer. Seems nobody cares. Time to move on to something, which DOES work. Deja Dup obviously does not and nobody cares.

    OTOH - if somebody knows how to make Deja Dup work with SSH, I'd be very happy to know! Simply enabling sftp is not the answer.

    Cheers,
    Alexander

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •