Results 1 to 5 of 5

Thread: Can't install anything...

Hybrid View

  1. #1
    Join Date
    Aug 2012
    Beans
    110
    Distro
    Ubuntu 12.04 Precise Pangolin

    Exclamation Can't install anything...

    Hi,
    I need to install some software on Xubuntu Quantal. As I'm relatively comfortable with the command line, I tried to use apt-get, but it returned an error. The software centre just hangs on a loading window when I open it. I have been able to install software before, but the last time I tried on this system was a while ago.

    The error from apt-get:
    Code:
    Reading package lists... Error!
    E: Encountered a section with no Package: header
    E: Problem with MergeList /var/lib/apt/lists/gb.archive.ubuntu.com_ubuntu_dists_quantal_main_i18n_Translation-en
    E: The package lists or status file could not be parsed or opened.
    Also I want to install Google Earth; I have the .deb file from the Google Earth website, but I can't install it using either the software centre or dpkg, with similar errors returned.

    Help? Thanks in advance...
    Last edited by 25tom; May 26th, 2013 at 08:30 AM.
    I am an Ubuntu Padawan.

  2. #2
    Join Date
    Jul 2005
    Location
    England
    Beans
    Hidden!

    Re: Can't install anything...

    The commands
    Code:
    sudo rm /var/lib/apt/lists/gb.archive.ubuntu.com_ubuntu_dists_quantal_main_i18n_Translation-en
    sudo apt-get update
    sudo apt-get upgrade
    should help out here
    DISTRO: Xubuntu 12.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo

  3. #3
    Join Date
    Aug 2012
    Beans
    110
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't install anything...

    That threw up this error:

    Code:
    Reading package lists... Error!
    W: GPG error: http://gb.archive.ubuntu.com quantal Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
    E: Encountered a section with no Package: header
    E: Problem with MergeList /var/lib/apt/lists/gb.archive.ubuntu.com_ubuntu_dists_quantal_main_i18n_Translation-en%5fGB
    E: The package lists or status file could not be parsed or opened.
    What should I do? It seems to me that the problems lie with many if not all of the files in the /var/lib/apt/lists directory. Is it safe to delete all of them? And should I try to? And I don't know what the GPG error is at all...

    EDIT: Software Updater just popped up with the same errors as in my first post and said that it was an 'unresolvable error'... I hope that it can be resolved somehow!
    Last edited by 25tom; May 24th, 2013 at 08:36 PM.
    I am an Ubuntu Padawan.

  4. #4
    Join Date
    Jul 2005
    Location
    England
    Beans
    Hidden!

    Re: Can't install anything...

    I think you can remove all the list files in that folder and then run the update and upgrade command again. Try
    Code:
    sudo apt-get clean
    cd /var/lib/apt
    sudo mv lists lists.old
    sudo mkdir -p lists/partial
    sudo apt-get clean
    sudo apt-get update
    DISTRO: Xubuntu 12.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo

  5. #5
    Join Date
    Aug 2012
    Beans
    110
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't install anything...

    That fixed it, thank you very much!

    I am an Ubuntu Padawan.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •