Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Today's update remove gedit (saucy-proposed enabled).

  1. #1
    Join Date
    Aug 2012
    Beans
    242
    Distro
    Ubuntu Development Release

    Today's update remove gedit (saucy-proposed enabled).

    sudo apt-get -V dist-upgrade

    Code:
    Calculating upgrade... Done
    The following packages will be REMOVED:
       gedit (3.6.2-0ubuntu1)
       libgtksourceview-3.0-0 (3.6.3-0ubuntu1)
    The following NEW packages will be installed:
       libgtksourceview-3.0-1 (3.8.0-1)
    The following packages have been kept back:
       usb-modeswitch-data (20120815-2 => 20121109-3)
    The following packages will be upgraded:
       e2fslibs (1.42.5-1ubuntu4 => 1.42.5-1.1ubuntu1)
       e2fsprogs (1.42.5-1ubuntu4 => 1.42.5-1.1ubuntu1)
       gir1.2-gtksource-3.0 (3.6.3-0ubuntu1 => 3.8.0-1)
       grep (2.14-1 => 2.14-2)
       libcomerr2 (1.42.5-1ubuntu4 => 1.42.5-1.1ubuntu1)
       libgd3 (2.1.0~alpha1-5 => 2.1.0~alpha1-6)
       libgtksourceview-3.0-common (3.6.3-0ubuntu1 => 3.8.0-1)
       libsemanage-common (2.1.6-6ubuntu1 => 2.1.10-2)
       libsemanage1 (2.1.6-6ubuntu1 => 2.1.10-2)
       libss2 (1.42.5-1ubuntu4 => 1.42.5-1.1ubuntu1)
       unity-webapps-facebookmessenger (2.4.16daily13.05.22-0ubuntu1 => 2.4.16daily13.05.23-0ubuntu1)
       unity-webapps-gmail (2.4.16daily13.05.22-0ubuntu1 => 2.4.16daily13.05.23-0ubuntu1)
       unity-webapps-googleplus (2.4.16daily13.05.22-0ubuntu1 => 2.4.16daily13.05.23-0ubuntu1)
       unity-webapps-launchpad (2.4.16daily13.05.22-0ubuntu1 => 2.4.16daily13.05.23-0ubuntu1)
       unity-webapps-reddit (2.4.16daily13.05.22-0ubuntu1 => 2.4.16daily13.05.23-0ubuntu1)
       unity-webapps-tumblr (2.4.16daily13.05.22-0ubuntu1 => 2.4.16daily13.05.23-0ubuntu1)
       unity-webapps-youtube (2.4.16daily13.05.22-0ubuntu1 => 2.4.16daily13.05.23-0ubuntu1)
    17 upgraded, 1 newly installed, 2 to remove and 1 not upgraded.
    Need to get 2,248 kB of archives.
    After this operation, 2,552 kB disk space will be freed.
    Do you want to continue [Y/n]? Y
    sudo apt-get install gedit

    Code:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     gedit : Depends: libgtksourceview-3.0-0 (>= 3.0.0) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    apt-cache policy libgtk-3.0

    Code:
    libgtk-3-0:
      Installed: 3.8.2-0ubuntu1
      Candidate: 3.8.2-0ubuntu1
      Version table:
     *** 3.8.2-0ubuntu1 0
            500 http://my.archive.ubuntu.com/ubuntu/ saucy-proposed/main i386 Packages
            100 /var/lib/dpkg/status
         3.6.4-0ubuntu8 0
            500 http://my.archive.ubuntu.com/ubuntu/ saucy/main i386 Packages

  2. #2
    Join Date
    Jul 2010
    Location
    Finland
    Beans
    2,455
    Distro
    Ubuntu

    Re: Today's update remove gedit (saucy-proposed enabled).

    Quote Originally Posted by serdotlinecho View Post
    sudo apt-get -V dist-upgrade
    ...
    Yes this happens because of the gtksourceview3 (3.8.0-1).
    It has a new so-name.

    We have to loosen the dependencies of the gtksourceview (like it is done in the Gnome3 Staging PPA) or better, have a new gedit built against new gtksourceview3.

  3. #3
    Join Date
    Jul 2010
    Location
    Finland
    Beans
    2,455
    Distro
    Ubuntu

    Re: Today's update remove gedit (saucy-proposed enabled).

    This issue is fixed now with a new gedit build (3.8.2-0ubuntu1) in Saucy proposed repos.

  4. #4
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Today's update remove gedit (saucy-proposed enabled).

    If you aren't willing to put up with breakage, I'd suggest you disable the proposed archives, as the developers have warned us all that proposed will break your distribution more often then not. the proposed repositories don't work the same way during the development cycle as they do for a released version. They are used as a holding area for new packages that are waiting for dependencies to be built before being moved into the regular repositories.

  5. #5
    Join Date
    Aug 2009
    Beans
    3,382
    Distro
    Ubuntu Development Release

    Re: Today's update remove gedit (saucy-proposed enabled).

    Quote Originally Posted by cariboo907 View Post
    If you aren't willing to put up with breakage, I'd suggest you disable the proposed archives, as the developers have warned us all that proposed will break your distribution more often then not. the proposed repositories don't work the same way during the development cycle as they do for a released version. They are used as a holding area for new packages that are waiting for dependencies to be built before being moved into the regular repositories.
    This did not happen to me but, cariboo907 while asking what appears to be a dumb question which are "the proposed archives"?

    I see a key Ubuntu Archive, but that is all I see mentioning archive in my software sources.
    Check Java Version | Install Java via WEB UPD8 PPA
    Creating a Custom Maintenance Free GRUB2 Screen Community Wiki
    Ubuntu 12.04 | 14.04 | 14.10 | 14.10 Mate | Mint 13 | Mint 17 | Windows 7 | All 64 bit

  6. #6
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Today's update remove gedit (saucy-proposed enabled).

    @Cavsfan, see the screenshot of Software & Updates, on how to enable/disable the proposed repositories.
    Attached Images Attached Images

  7. #7
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    4,450
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Today's update remove gedit (saucy-proposed enabled).

    @cavsfan, you can also comment the proposed-updates lines in the sources.list, if you want.

    But +1 to disabling proposed in development, it's not used like normal proposed in the stable releases.
    They don't do solid testing like stable proposed, it's more like a staging area now.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  8. #8
    Join Date
    Aug 2009
    Beans
    3,382
    Distro
    Ubuntu Development Release

    Re: Today's update remove gedit (saucy-proposed enabled).

    Quote Originally Posted by cariboo907 View Post
    @Cavsfan, see the screenshot of Software & Updates, on how to enable/disable the proposed repositories.
    Glad I asked because I had Pre-released updates checked! Not sure If I checked it myself or what.

    I got confused when you said
    I'd suggest you disable the proposed archives
    But, then again I am easily confused.

    Quote Originally Posted by deadflowr View Post
    @cavsfan, you can also comment the proposed-updates lines in the sources.list, if you want.

    But +1 to disabling proposed in development, it's not used like normal proposed in the stable releases.
    They don't do solid testing like stable proposed, it's more like a staging area now.
    Thanks deadflowr but, as you said unchecking the box was the easiest thing possible.

    Think I am good to go now. Good thing I spotted this.
    Thanks!
    Check Java Version | Install Java via WEB UPD8 PPA
    Creating a Custom Maintenance Free GRUB2 Screen Community Wiki
    Ubuntu 12.04 | 14.04 | 14.10 | 14.10 Mate | Mint 13 | Mint 17 | Windows 7 | All 64 bit

  9. #9
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    7,129
    Distro
    Ubuntu Development Release

    Re: Today's update remove gedit (saucy-proposed enabled).

    The proposed repositories make the difference between the Edge and the Bleeding Edge in running Ubuntu development. The blood on the bleeding Edge has to come from someone.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  10. #10
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    4,450
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Today's update remove gedit (saucy-proposed enabled).

    Quote Originally Posted by grahammechanical View Post
    The proposed repositories make the difference between the Edge and the Bleeding Edge in running Ubuntu development. The blood on the bleeding Edge has to come from someone.
    There is still a good amount of blood on the edge, without proposed.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •