Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: Can't resume from suspend

  1. #21
    Join Date
    Nov 2009
    Location
    Waterford, Ireland
    Beans
    320
    Distro
    Ubuntu Development Release

    Re: Can't resume from suspend

    On battery power heres the output of:

    Code:
    sudo tlp stat
    Code:
    --- TLP 0.3.9 --------------------------------------------
    
    +++ Configured Settings: /etc/default/tlp
    TLP_ENABLE=1
    DISK_IDLE_SECS_ON_AC=0
    DISK_IDLE_SECS_ON_BAT=2
    MAX_LOST_WORK_SECS_ON_AC=15
    MAX_LOST_WORK_SECS_ON_BAT=60
    SCHED_POWERSAVE_ON_AC=0
    SCHED_POWERSAVE_ON_BAT=1
    NMI_WATCHDOG=0
    DISK_DEVICES="sda sdb"
    DISK_APM_LEVEL_ON_AC="254 254"
    DISK_APM_LEVEL_ON_BAT="128 128"
    SATA_LINKPWR_ON_AC=max_performance
    SATA_LINKPWR_ON_BAT=min_power
    PCIE_ASPM_ON_AC=performance
    PCIE_ASPM_ON_BAT=powersave
    RADEON_POWER_PROFILE_ON_AC=high
    RADEON_POWER_PROFILE_ON_BAT=low
    WIFI_PWR_ON_AC=1
    WIFI_PWR_ON_BAT=5
    WOL_DISABLE=Y
    SOUND_POWER_SAVE=1
    SOUND_POWER_SAVE_CONTROLLER=Y
    BAY_POWEROFF_ON_BAT=0
    BAY_DEVICE="sr0"
    RUNTIME_PM_ON_AC=on
    RUNTIME_PM_ON_BAT=auto
    RUNTIME_PM_ALL=0
    USB_AUTOSUSPEND=1
    RESTORE_DEVICE_STATE_ON_STARTUP=0
    
    
    +++ System Info
    System         = TOSHIBA PSKFWE-00K00REN SATELLITE L855
    BIOS           = 6.60
    Release        = Ubuntu 13.04
    Kernel         = 3.8.0-22-generic x86_64
    /proc/cmdline  = BOOT_IMAGE=/boot/vmlinuz-3.8.0-22-generic root=UUID=f299c4ae-e565-473c-8633-bb4faef42c39 ro radeon.audio=1 "acpi_osi=!Windows 2012" quiet splash vt.handoff=7
    
    
    +++ System Status
    TLP power save = enabled
    power source   = battery
    
    
    +++ Processor
    CPU Model      = Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz
    
    
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor  = ondemand
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq  =  1200000 [kHz]
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq  =  2401000 [kHz]
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies = 2401000 2400000 2300000 2200000 2100000 2000000 1900000 1800000 1700000 1600000 1500000 1400000 1300000 1200000 [kHz]
    
    
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor  = ondemand
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_min_freq  =  1200000 [kHz]
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq  =  2401000 [kHz]
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_available_frequencies = 2401000 2400000 2300000 2200000 2100000 2000000 1900000 1800000 1700000 1600000 1500000 1400000 1300000 1200000 [kHz]
    
    
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_governor  = ondemand
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_min_freq  =  1200000 [kHz]
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_max_freq  =  2401000 [kHz]
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_available_frequencies = 2401000 2400000 2300000 2200000 2100000 2000000 1900000 1800000 1700000 1600000 1500000 1400000 1300000 1200000 [kHz]
    
    
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_governor  = ondemand
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_min_freq  =  1200000 [kHz]
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_max_freq  =  2401000 [kHz]
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_available_frequencies = 2401000 2400000 2300000 2200000 2100000 2000000 1900000 1800000 1700000 1600000 1500000 1400000 1300000 1200000 [kHz]
    
    
    /sys/devices/system/cpu/cpu4/cpufreq/scaling_governor  = ondemand
    /sys/devices/system/cpu/cpu4/cpufreq/scaling_min_freq  =  1200000 [kHz]
    /sys/devices/system/cpu/cpu4/cpufreq/scaling_max_freq  =  2401000 [kHz]
    /sys/devices/system/cpu/cpu4/cpufreq/scaling_available_frequencies = 2401000 2400000 2300000 2200000 2100000 2000000 1900000 1800000 1700000 1600000 1500000 1400000 1300000 1200000 [kHz]
    
    
    /sys/devices/system/cpu/cpu5/cpufreq/scaling_governor  = ondemand
    /sys/devices/system/cpu/cpu5/cpufreq/scaling_min_freq  =  1200000 [kHz]
    /sys/devices/system/cpu/cpu5/cpufreq/scaling_max_freq  =  2401000 [kHz]
    /sys/devices/system/cpu/cpu5/cpufreq/scaling_available_frequencies = 2401000 2400000 2300000 2200000 2100000 2000000 1900000 1800000 1700000 1600000 1500000 1400000 1300000 1200000 [kHz]
    
    
    /sys/devices/system/cpu/cpu6/cpufreq/scaling_governor  = ondemand
    /sys/devices/system/cpu/cpu6/cpufreq/scaling_min_freq  =  1200000 [kHz]
    /sys/devices/system/cpu/cpu6/cpufreq/scaling_max_freq  =  2401000 [kHz]
    /sys/devices/system/cpu/cpu6/cpufreq/scaling_available_frequencies = 2401000 2400000 2300000 2200000 2100000 2000000 1900000 1800000 1700000 1600000 1500000 1400000 1300000 1200000 [kHz]
    
    
    /sys/devices/system/cpu/cpu7/cpufreq/scaling_governor  = ondemand
    /sys/devices/system/cpu/cpu7/cpufreq/scaling_min_freq  =  1200000 [kHz]
    /sys/devices/system/cpu/cpu7/cpufreq/scaling_max_freq  =  2401000 [kHz]
    /sys/devices/system/cpu/cpu7/cpufreq/scaling_available_frequencies = 2401000 2400000 2300000 2200000 2100000 2000000 1900000 1800000 1700000 1600000 1500000 1400000 1300000 1200000 [kHz]
    
    
    /sys/devices/system/cpu/cpufreq/boost                  = 1
    /proc/sys/kernel/nmi_watchdog                          = 0
    
    
    +++ Undervolting
    PHC kernel not available.
    
    
    +++ Temperatures
    CPU temp               =    49 [°C]
    Fan speed              = (not available)
    
    
    +++ File System
    /proc/sys/vm/laptop_mode               =     2
    /proc/sys/vm/dirty_writeback_centisecs =  6000
    /proc/sys/vm/dirty_expire_centisecs    =  6000
    /proc/sys/vm/dirty_ratio               =    60
    /proc/sys/vm/dirty_background_ratio    =    40
    /proc/sys/fs/xfs/age_buffer_centisecs  = (not available)
    /proc/sys/fs/xfs/xfssyncd_centisecs    = (not available)
    /proc/sys/fs/xfs/xfsbufd_centisecs     = (not available)
    
    
    +++ Storage Devices
    /dev/sda:
              Model     = Hitachi HTS547575A9E384                 
              Firmware  = JE4OA60B
              APM Level = 128
              Status    = active/idle
              scheduler = deadline
    
    
            SMART info:
                4 Start_Stop_Count          =      690 
                5 Reallocated_Sector_Ct     =        0 
                9 Power_On_Hours            =      524 [h]
              193 Load_Cycle_Count          =     6823 
              194 Temperature_Celsius       =       32 (Min/Max 12/48)  [°C]
    
    
    /dev/sdb:
              Model     = Hitachi HTS545032B9A300                 
              Firmware  = PB3OC60N
              APM Level = 128
              Status    = active/idle
              scheduler = deadline
    
    
            SMART info:
                4 Start_Stop_Count          =     2498 
                5 Reallocated_Sector_Ct     =        0 
                9 Power_On_Hours            =     4432 [h]
              193 Load_Cycle_Count          =    23010 
              194 Temperature_Celsius       =       26 (Min/Max 5/50)  [°C]
    
    
    
    
    +++ SATA Aggressive Link Power Management
    /sys/class/scsi_host/host0/link_power_management_policy  = min_power
    /sys/class/scsi_host/host1/link_power_management_policy  = min_power
    /sys/class/scsi_host/host2/link_power_management_policy  = min_power
    /sys/class/scsi_host/host3/link_power_management_policy  = min_power
    /sys/class/scsi_host/host4/link_power_management_policy  = min_power
    /sys/class/scsi_host/host5/link_power_management_policy  = min_power
    
    
    +++ PCIe Active State Power Management
    /sys/module/pcie_aspm/parameters/policy = default (using bios preferences)
    
    
    +++ Wireless
    bluetooth = on
    wifi      = on
    wwan      = none (no device)
    
    
    wlan0(ath9k): power management = on
    
    
    +++ Audio
    /sys/module/snd_hda_intel/parameters/power_save            = 1
    /sys/module/snd_hda_intel/parameters/power_save_controller = Y
    
    
    +++ Battery Status
    /sys/class/power_supply/BAT0/manufacturer                   = (not available)
    /sys/class/power_supply/BAT0/model_name                     = PA5024U-1BRS
    /sys/class/power_supply/BAT0/cycle_count                    = (not supported)
    /sys/class/power_supply/BAT0/energy_full_design             =  47520 [mWh]
    /sys/class/power_supply/BAT0/energy_full                    =  42800 [mWh]
    /sys/class/power_supply/BAT0/energy_now                     =  32529 [mWh]
    /sys/class/power_supply/BAT0/power_now                      =  15735 [mW]
    /sys/class/power_supply/BAT0/status                         = Discharging
    
    
    +++ Runtime Power Management
    /sys/bus/pci/devices/0000:00:00.0/power/control = auto (0x060000 Host bridge)
    /sys/bus/pci/devices/0000:00:01.0/power/control = on   (0x060400 PCI bridge)
    /sys/bus/pci/devices/0000:00:14.0/power/control = on   (0x0c0330 USB controller)
    /sys/bus/pci/devices/0000:00:16.0/power/control = on   (0x078000 Communication controller)
    /sys/bus/pci/devices/0000:00:1a.0/power/control = on   (0x0c0320 USB controller)
    /sys/bus/pci/devices/0000:00:1b.0/power/control = auto (0x040300 Audio device)
    /sys/bus/pci/devices/0000:00:1c.0/power/control = on   (0x060400 PCI bridge)
    /sys/bus/pci/devices/0000:00:1c.1/power/control = on   (0x060400 PCI bridge)
    /sys/bus/pci/devices/0000:00:1d.0/power/control = on   (0x0c0320 USB controller)
    /sys/bus/pci/devices/0000:00:1f.0/power/control = on   (0x060100 ISA bridge)
    /sys/bus/pci/devices/0000:00:1f.2/power/control = on   (0x010601 SATA controller)
    /sys/bus/pci/devices/0000:00:1f.3/power/control = on   (0x0c0500 SMBus)
    /sys/bus/pci/devices/0000:01:00.0/power/control = on   (0x030000 VGA compatible controller)
    /sys/bus/pci/devices/0000:01:00.1/power/control = auto (0x040300 Audio device)
    /sys/bus/pci/devices/0000:07:00.0/power/control = auto (0x020000 Ethernet controller)
    /sys/bus/pci/devices/0000:08:00.0/power/control = auto (0x028000 Network controller)
    
    
    +++ USB
    tlp usb autosuspend = enabled
    tlp usb blacklist   = (not configured)
    
    
    Bus 001 Device 002 ID 8087:0024 control = auto, autosuspend_delay_ms =  2000 -- Intel Corp. Integrated Rate Matching Hub (hub)
    Bus 002 Device 002 ID 8087:0024 control = auto, autosuspend_delay_ms =  2000 -- Intel Corp. Integrated Rate Matching Hub (hub)
    Bus 001 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =  2000 -- Linux Foundation 2.0 root hub (hub)
    Bus 002 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =  2000 -- Linux Foundation 2.0 root hub (hub)
    Bus 003 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =  2000 -- Linux Foundation 2.0 root hub (hub)
    Bus 004 Device 001 ID 1d6b:0003 control = auto, autosuspend_delay_ms =  2000 -- Linux Foundation 3.0 root hub (hub)
    Bus 001 Device 003 ID 0bda:0129 control = auto, autosuspend_delay_ms =  2000 -- Realtek Semiconductor Corp.  (rts5139)
    Bus 001 Device 007 ID 0930:0219 control = auto, autosuspend_delay_ms =  2000 -- Toshiba Corp.  (btusb)
    Bus 001 Device 004 ID 10f1:1a43 control = auto, autosuspend_delay_ms =  2000 -- Importek  (uvcvideo)
    I can't seem to reproduce the problem at all now it's frustrating but fingers crossed it doesn't happen again.

    Sorry if I went about the wrong procedure reporting the issue and a big thank you to all for your time and effort

  2. #22
    Join Date
    Sep 2010
    Location
    Germany
    Beans
    83
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't resume from suspend

    No need to say "sorry" .

    Suspend/resume problems are notoriously hard to isolate and fix. Because of the black screen upon resume i guess fglrx is the main suspect here. The tlp-stat output doesn't show anything exceptional.

    I wish you good luck.

    ps. do you have the latest BIOS version installed?
    Last edited by linrunner; May 25th, 2013 at 11:51 PM.

  3. #23
    Join Date
    Nov 2009
    Location
    Waterford, Ireland
    Beans
    320
    Distro
    Ubuntu Development Release

    Re: Can't resume from suspend

    Yeah updated the bios 3-4 weeks ago I will go check the toshiba website to be double sure

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •