Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Can't get "Bridged Adapter" to work in VirtualBox Network Settings

  1. #11
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't get "Bridged Adapter" to work in VirtualBox Network Settings

    Quote Originally Posted by dragonfly41 View Post
    But I am using NAT as Adapter1 and Host-only as Adapter2.

    Are you suggesting disabling Host-only and using only NAT?

    Thanks.
    Correct.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  2. #12
    Join Date
    Mar 2011
    Location
    U.K.
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    [SOLVED] Re: Can't get "Bridged Adapter" to work in VirtualBox Network Settings

    I did try with only NAT adapter and could ping from guest to Internet .. but that meets only part of my requirement.

    I then found this video which explains how to configure Internet <--> Host <--> Guest <--> Internet.

    http://www.youtube.com/watch?v=Jk5Kfm2-Muk

    But note that the two adapters are setup in this sequence:-

    Adapter 1 Host-only
    Adapter 2 NAT

  3. #13
    Join Date
    Oct 2013
    Beans
    1

    Re: Can't get "Bridged Adapter" to work in VirtualBox Network Settings

    I was struggling with a very similar issue for hours.

    My situation:
    Host: 32-bit Windows 7 Professional
    VirtualBox v:4.2.18
    Guest: 64-bit Ubuntu 12.04 server / bitnami redmine 2.3.3 virtual appliance (don't worry too much about the appliance part)

    I also have a 32-bit 12.04 Desktop Guest.
    The desktop guest had the bridge adapter network setting and could host servers like a champ.

    The 64-bit server however couldn't ever establish the network config and I got the "Waiting for network Configuration....waiting 60 seconds..." etc message on boot.
    It would boot and I had no network capabilities.

    I tried the poster's recommendations and also followed the video to no avail. Finally I came to this link.

    I'll summarize here:

    - Let it boot up without the network config.
    - run: ifconfig -a
    - note the first adapter mentioned (It will be of the form "eth#")
    - cd to /etc/network/
    - use an editor with root privileges and open the "interfaces" file. (i.e. sudo nano interfaces)
    - enter your password if necessary.

    Under "# The primary network interface", you'll see two lines starting with: "auto" and "iface".
    - If the adapters listed after "auto" and "iface" are different from the one you noted from ifconfig -a then change them to the adapter you noted.
    - save the file and reboot.

    Your server should now be able to configure the network via "Bridged Adapter".

    If the adapters in the /etc/network/interface file were not different from your ifconfig -a,then I am sorry. I do not how to help you there.

    Hope this helps a few more people with similar issues.

  4. #14
    Join Date
    May 2014
    Beans
    1

    Thumbs up Re: Can't get "Bridged Adapter" to work in VirtualBox Network Settings

    Thanks astoutj, your solution worked for me.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •