Results 1 to 6 of 6

Thread: Disable the console switching by pressing CTRL-ALT-F1

  1. #1
    Join Date
    Aug 2006
    Beans
    462
    Distro
    Ubuntu 11.04 Natty Narwhal

    Disable the console switching by pressing CTRL-ALT-F1

    Hi

    Howto disable the console switching by pressing CTRL-ALT-F1...F6 under LXDE?

  2. #2
    Join Date
    Jul 2011
    Beans
    3,037
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Disable the console switching by pressing CTRL-ALT-F1

    Why would you want to do that? It may be your last option to get into the system if the desktop environment doesn't start or won't let you login.

  3. #3
    Join Date
    Feb 2012
    Location
    Los Angeles, CA
    Beans
    138
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Disable the console switching by pressing CTRL-ALT-F1

    Quote Originally Posted by 2F4U View Post
    Why would you want to do that? It may be your last option to get into the system if the desktop environment doesn't start or won't let you login.
    Isn't console switching available on Ctrl-Alt-<F1-F7>? Surely, having one down is ok.
    John J. Kim (IRC: kotux)
    High School Senior / Ubuntu User # 35405
    www.launchpad.net/~kotux
    "Let your performance do the thinking." --Charlotte Bronte


  4. #4
    Join Date
    Aug 2006
    Beans
    462
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Disable the console switching by pressing CTRL-ALT-F1

    Quote Originally Posted by 2F4U View Post
    Why would you want to do that? It may be your last option to get into the system if the desktop environment doesn't start or won't let you login.
    I would like to disable, because I try to create a very simple Thin Client and I don't need to switch into the system.

  5. #5
    Join Date
    Feb 2011
    Location
    Somewhere...
    Beans
    1,559
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Disable the console switching by pressing CTRL-ALT-F1

    NOTE: Be very careful
    As root, in the folder /usr/share/X11/xorg.conf.d, create a new file named 50-novtswitch.conf, with its content being:
    Code:
     Section "ServerFlags"
    Option "DontVTSwitch" "true"
    EndSection
    Save, reboot.

    Of course, like others have said, it may be the only way to recover your system when X fails, so consider yourself before doing.

  6. #6
    Join Date
    Aug 2006
    Beans
    462
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Disable the console switching by pressing CTRL-ALT-F1

    Quote Originally Posted by zombifier25 View Post
    NOTE: Be very careful
    As root, in the folder /usr/share/X11/xorg.conf.d, create a new file named 50-novtswitch.conf, with its content being:
    Code:
     Section "ServerFlags"
    Option "DontVTSwitch" "true"
    EndSection
    Save, reboot.

    Of course, like others have said, it may be the only way to recover your system when X fails, so consider yourself before doing.
    Thx a lot, I've done and it works well now.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •