Results 1 to 4 of 4

Thread: 13.04 No Video Thumbnails in Thunar

Threaded View

  1. #1
    Join Date
    Apr 2006
    Beans
    538

    13.04 No Video Thumbnails in Thunar

    First, some background.

    I was running 12.10, which was a normal installation of Ubuntu. I then installed XFCE4 alongside it. In that configuration, Thunar could load all the thumbnails that Nautilus created, and it could also generate new thumbnails on brand-new files itself.

    Then I did a clean install of Xubuntu 13.04, and nothing.

    I installed gstreamer-bad, gstreamer-bad-multiverse, and gstreamer-ugly, and still nothing. I installed tumbler-plugins-extra, and ffmpegthumbnailer, and nothing. I went to delete the ~/.thumbnails directory to see if that would help, and the ~/.thumbnails directory doesn't even exit.

    I logged out and back in. I even rebooted. And still, no video thumbnails in Thunar. Any ideas?

    I should add that I'm using the 64-bit version.

    Update:

    I think what we might be dealing with here is a good old-fashioned bug.

    I did another clean install and before even doing any system updates, I downloaded a video. When I browsed to the video in Thunar, I got a crash report from tumblerd. Of course it wouldn't submit the crash report because my system wasn't updated. So I updated my system and rebooted. The crash report was gone, but still no thumbnails.

    I then tried to play the video and Parole wanted to download gstreamer-ffmpeg to do so, so I let it. Then the video played fine, but still no thumbnails.

    I went to:

    Code:
    /usr/lib/x86_64-linux-gnu/tumbler-1
    And ran "tumblerd" there directly. It ran okay but as soon as I then opened a directory with video files in it in Thunar, tumblerd crashed with this message:

    Code:
    (tumblerd:1910): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed
    
    (tumblerd:1910): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed
    
    (tumblerd:1910): GStreamer-CRITICAL **: gst_element_get_bus: assertion `GST_IS_ELEMENT (element)' failed
    
    (tumblerd:1910): GStreamer-CRITICAL **: gst_bus_timed_pop_filtered: assertion `GST_IS_BUS (bus)' failed
    Segmentation fault (core dumped)
    I then downloaded a variety of files... videos of different codecs and different types of image files... and put them in a directory together. I ran tumblerd again and went to the directory. The thumbnails generated on the first few image files but then when the process hit the video files tumblerd crashed again and didn't process any of the remaining graphic files. Out of curiosity I then went into the /usr/lib/x86_64-linux-gnu/tumbler-1/plugins directory and deleted the tumbler-gst-thumbnailer.so file. Ran it again and this time all the image files had their thumbnails generated properly. The video files were skipped over, but no crash.

    Then I installed the tumbler-plugins-extra package to use ffmpeg to generate the thumbnails. All of the video files had their thumbnails generated properly except for the .ogv file, and all of that with no crash. Then I uninstalled tumbler-plugins-extra, re-installed tumbler to get the gst-thumbnailer file back and tested it again. Once again we were back to crashing with no video thumbnails.

    So, it seems that the version of tumbler that comes with Xubuntu 13.04 is buggy and will not generate video thumbnails using GStreamer. GStreamer can decode the files fine as you can play videos using the GStreamer libraries, but tumbler simply will not generate the video thumbnails with GStreamer as the back-end.
    Last edited by Gannin; May 19th, 2013 at 10:27 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •