Results 1 to 1 of 1

Thread: 503 5.5.1 Error: authentication not enabled - POSTFIX HELP PLZ

  1. #1
    Join Date
    May 2013
    Beans
    1

    Thumbs up 503 5.5.1 Error: authentication not enabled - POSTFIX HELP PLZ

    SOLUTION
    I had smtpd_tls_auth_only = yes - when I enables tls on the client everything worked perfectly.



    Hi Guys,
    I haven't set up a linux machine for a while, and the last one I did was a centos. But after spending 2 weeks on Ubuntu so far, I wish my last was an Ubuntu.

    But I have a problem, and I tried everything, and I need help if it is possible.
    I have installed webmin and virtualmin.

    I have installed Postfix/Dovecot - I can login to my email to view (IMAP) - but I cannot send authunticated mail- i have enabled SASL, and set up all the files (which are all below) - however when I telnet to my server this is the result:

    Code:
    telnet localhost 25
    EHLO localhost
    250-mydomain.com
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTTLS
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DNS
    There is no 250-AUTH anywhere.

    my tail on /var/log/mail.log shows no errors except connects and disconnects


    my /etc/postfix/main.cf
    Code:
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu) 
    biff = no 
    append_dot_mydomain = no 
    delay_warning_time = 4h 
    readme_directory = no  
    smtpd_tls_cert_file = /etc/ssl/certs/ssl-mail.pem 
    smtpd_tls_key_file = /etc/ssl/private/ssl-mail.key 
    smtpd_use_tls = yes 
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache 
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache  
     myhostname = mydomain.com
     alias_maps = hash:/etc/aliases 
    alias_database = hash:/etc/aliases 
    myorigin = /etc/mailname 
    mydestination = mydomain.com, localhost.com, , localhost
     relayhost =  
    mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
     mailbox_size_limit = 0 
    recipient_delimiter = + 
    inet_interfaces = all 
    inet_protocols = all 
    home_mailbox = Maildir/ smtpd_sasl_auth_enable = yes 
    smtpd_sasl_security_options = noanonymous 
    smtpd_recipient_restrictions = reject_unknown_sender_domain, reject_unknown_recipient_domain, reject_unauth_pipelining, permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination 
    smtp_tls_security_level = may
     smtpd_tls_security_level = may 
    smtpd_tls_auth_only = yes
     smtp_tls_note_starttls_offer = yes
     smtpd_tls_CAfile = /etc/ssl/certs/cacert.pem 
    smtpd_tls_loglevel = 1 
    smtpd_tls_received_header = yes 
    smtpd_tls_session_cache_timeout = 3600s tls_random_source = dev:/dev/urandom
     transport_maps = hash:/etc/postfix/transport 
    virtual_alias_maps = hash:/etc/postfix/virtual 
    smtpd_sasl_type = dovecot 
    smtpd_sasl_path = private/dovecot-auth 
    smtpd_sasl_authenticated_header = yes smtpd_sasl_local_domain = $myhostname broken_sasl_auth_clients = yes 
    smtpd_sender_restrictions = reject_unknown_sender_domain mailbox_command = /usr/lib/dovecot/deliver -c /etc/dovecot/conf.d/01-mail-stack-delivery.conf -m "${EXTENSION}" smtp_use_tls = yes
     smtpd_tls_mandatory_protocols = SSLv3, TLSv1 
    smtpd_tls_mandatory_ciphers = medium
    my /etc/defaiult/saslauthd
    Code:
    START=yes 
    DESC="SASL Authentication Daemon" 
    NAME="saslauthd" 
    MECHANISMS="pam" 
    MECH_OPTIONS=""   
    THREADS=5   
    OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd"
    my /etc/postfix/sasl/smtpd.conf
    Code:
    pwcheck_method: saslauthd 
    mech_list: plain login 
    allow_plaintext: true
    Last edited by dotmoe; May 19th, 2013 at 12:20 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •