Results 1 to 9 of 9

Thread: 13.10 kubuntu -depency problem

  1. #1
    Join Date
    Jan 2013
    Beans
    105

    13.10 kubuntu -depency problem

    I upgraded files from channel and installed steam. It said something about depency problem dont\t remember anymore what it said. I rebooted and now I have lost minimize, maximize and close buttons and all programs start on the left top corner.

  2. #2
    Join Date
    Jun 2005
    Location
    Where?
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: 13.10 kubuntu -depency problem

    Quote Originally Posted by deri View Post
    I upgraded files from channel and installed steam. It said something about depency problem dont\t remember anymore what it said. I rebooted and now I have lost minimize, maximize and close buttons and all programs start on the left top corner.

    I have had zero luck with kbuntu Upgrading to saucy!
    Unity & Gnome-Shell however is coming along nicely.
    Last edited by runrickus; June 26th, 2013 at 02:36 AM. Reason: More Info

  3. #3
    Join Date
    Jun 2006
    Location
    Queensland Australia
    Beans
    712
    Distro
    Kubuntu Development Release

    Re: 13.10 kubuntu -depency problem

    It is the plasma-widget-networkmanagement this is the error...
    This update was issued on 18/06/13 08:19 AM
    * New upstream release.
    * Upgraded build-dep to network-manager-dev >= 0.9.8 per
    upstream instructions.
    * Breaks/replaces old kde-workspace-data for moved icon
    Ubuntu user 7859 registered Linux user 470405
    The Ubuntu Counter Project - user number # 7859"
    Lenovo T510 Kubuntu Trusty 64bit, Intel Core i5-560M, 8GB PC3-DDR3 SDRAM - 1067 MHz,
    NVIDIA NVS 3100m PCI Express, Wireless Centrino N 6300

  4. #4
    Join Date
    Jan 2013
    Beans
    105

    Re: 13.10 kubuntu -depency problem

    I have had this problem now 2 times. I don't have all the details what really happens. I have some old (I say old because there is daily build) 13.04 64bit kubuntu install. I used that. Upgraded all files from 13.04 source. Installed steam, installed playonlinux. Installed ati drivers from earlier used and selfmade deb files which do work. Then I upgraded reposity to saucy (which has been worked before) I had hundredes of megabytes of updates (even 13.04 channel, but saucy too). And then the depency hell starts. All upgrades are not able to finnish because of depency problems. I try go own with sudo dpkg --configure -a and it installs/sets some files and I go with sudo apt-get upgrade and distro-upgrade. But the kde root becomes blank.

    But I think one problem is going directly to dist-upgrade maybe I should have just made update sources and then upgrade and then distro-upgrade?

  5. #5
    Join Date
    Jan 2013
    Beans
    105

    Re: 13.10 kubuntu -depency problem

    But I do confirm that upgrading from 13.04 to 13.10 (kubuntu) has worked before. I have done it earlier.

  6. #6
    Join Date
    Jan 2013
    Beans
    105

    Re: 13.10 kubuntu -depency problem

    There is something really wrong now. I downloaded a new 13.10 daily build. Installed it on usb. Installed it on hard drive, installed updates. In somepoint it just breaks again. Plenty of updates that are unable to install.
    The following packages will be upgraded:
    calligra-data dragonplayer kaccessible kamera kcalc kde-config-telepathy-accounts
    kde-telepathy-auth-handler kde-telepathy-contact-list kde-telepathy-desktop-applets
    kde-telepathy-filetransfer-handler kde-telepathy-integration-module
    kde-telepathy-send-file kde-zeroconf kdegames-card-data kdegames-data
    kdegraphics-strigi-analyzer kdemultimedia-kio-plugins kdenetwork-filesharing kmag kmix
    kmousetool kpat kppp krita-data ksnapshot ksystemlog kwalletmanager libkdcraw-data
    libkdcraw22 libkdegames6 libkexiv2-11 libkexiv2-data libkipi-data libkolabxml0
    libksane-data libksane0 libnepomukwidgets4 libsmokekdecore4-3 libsmokekdeui4-3
    libsmokekfile3 libsmokekhtml3 libsmokekio3 libsmokeknewstuff2-3 libsmokeknewstuff3-3
    libsmokekparts3 libsmokektexteditor3 libsmokekutils3 libsmokenepomuk3 libsmokeplasma3
    libsmokesolid3 lightdm-kde-greeter openoffice.org-hyphenation plasma-dataengines-addons
    plasma-scriptengine-superkaramba plasma-widget-kimpanel playonlinux print-manager
    57 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
    Need to get 0 B/39,0 MB of archives.
    After this operation, 5 296 kB disk space will be freed.
    Do you want to continue [Y/n]? y
    Extracting templates from packages: 100%
    dpkg: considering deconfiguration of krita-data, which would be broken by installation of calligra-data ...
    dpkg: yes, will deconfigure krita-data (broken by calligra-data)
    (Reading database ... 151958 files and directories currently installed.)
    Preparing to replace calligra-data 1:2.6.3-0ubuntu2 (using .../calligra-data_1%3a2.6.92-0ubuntu3_all.deb) ...
    De-configuring krita-data ...
    Unpacking replacement calligra-data ...
    dpkg: error processing /var/cache/apt/archives/calligra-data_1%3a2.6.92-0ubuntu3_all.deb (--unpack):
    trying to overwrite '/usr/share/kde4/servicetypes/calligradb_driver.desktop', which is also in package kexi 1:2.6.3-0ubuntu2
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    dpkg: considering deconfiguration of calligra-data, which would be broken by installation of krita-data ...
    dpkg: yes, will deconfigure calligra-data (broken by krita-data)
    Preparing to replace krita-data 1:2.6.3-0ubuntu2 (using .../krita-data_1%3a2.6.92-0ubuntu3_all.deb) ...
    De-configuring calligra-data ...
    Unpacking replacement krita-data ...
    Replacing files in old package calligra-data ...
    dpkg: error processing /var/cache/apt/archives/krita-data_1%3a2.6.92-0ubuntu3_all.deb (--unpack):
    trying to overwrite '/usr/share/icons/hicolor/1024x1024/apps/calligrakrita.png', which is also in package krita 1:2.6.3-0ubuntu2
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Processing triggers for hicolor-icon-theme ...
    Errors were encountered while processing:
    /var/cache/apt/archives/calligra-data_1%3a2.6.92-0ubuntu3_all.deb
    /var/cache/apt/archives/krita-data_1%3a2.6.92-0ubuntu3_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  7. #7
    Join Date
    Sep 2010
    Beans
    3

    Re: 13.10 kubuntu -depency problem

    Quote Originally Posted by deri View Post
    There is something really wrong now. I downloaded a new 13.10 daily build. Installed it on usb. Installed it on hard drive, installed updates. In somepoint it just breaks again. Plenty of updates that are unable to install.
    I had this too a couple of days ago.

    The solution is to remove krita and krita-data packages to allow upgrade to proceed, then afterwards reinstall.

    sudo aptitude remove krita krita-data
    sudo aptitude update && sudo aptitude safe-upgrade
    sudo aptitude install krita krita-data

  8. #8
    Join Date
    Jan 2013
    Beans
    105

    Re: 13.10 kubuntu -depency problem

    I did almost the same thing. I purged calligra data and it wanted to remove 3 files. I removed them all and upgraded system, but I did not reinstall calligra back. Also I installed some of the deb files (before i purged those files) that upgrade downloaded to the cache. I don't know if my system is 100% as it should be because I somepoint used sudo apt-get autoremove command.

  9. #9
    Join Date
    Jun 2005
    Location
    Where?
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: 13.10 kubuntu -depency problem

    Quote Originally Posted by deri View Post
    I did almost the same thing. I purged calligra data and it wanted to remove 3 files. I removed them all and upgraded system, but I did not reinstall calligra back. Also I installed some of the deb files (before i purged those files) that upgrade downloaded to the cache. I don't know if my system is 100% as it should be because I somepoint used sudo apt-get autoremove command.
    Seems like everything landed today! Giving it a go now! (For Saucy Flavors KDE)
    Will Report back..

    Went without a hitch..
    Now its a toss between KDE and Gnome-Shell (maybe Ill just keep both)
    KDE has come along way since I last used it!
    Attached Images Attached Images
    Last edited by runrickus; June 29th, 2013 at 03:23 PM. Reason: Added Info

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •