Results 1 to 10 of 10

Thread: Function keys don't work, but brightness slider does. Eh?

  1. #1
    Join Date
    Jul 2006
    Beans
    4,599

    Function keys don't work, but brightness slider does. Eh?

    I'm on a Lenovo E430 laptop with 13.04 installed. When I adjust the function brightness keys, it will decrease my brightness with one tap to 1% brightness. If I try to bump the brightness up it does nothing at all. On the flip side, if I go into system settings and adjust the brightness slider, it works fine. What's the difference? Clearly these two things aren't tied together since one works and the other does not... is there a way to tie in the brightness slider in system settings to the function keys instead?
    HOW TO - Set up video surveillance with "Motion"

    Buying a Lenovo? Do your research first!
    Some Lenovos have a whitelisted BIOS which prevents you from changing the wifi card.

  2. #2
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Function keys don't work, but brightness slider does. Eh?

    Does using the acpi_osi=\"!Windows 2012\" kernel parameter to help?

    To set up your system to use this parameter:
    1. Edit /etc/default/grub:
    Code:
    gksu gedit /etc/default/grub
    2. Change the line that reads:
    GRUB_CMDLINE_LINUX=""
    ...to read:
    Code:
    GRUB_CMDLINE_LINUX="acpi_osi=\"!Windows 2012\""
    3. Save the file.

    4. Run:
    Code:
    sudo update-grub
    5. Reboot.

  3. #3
    Join Date
    Jul 2006
    Beans
    4,599

    Re: Function keys don't work, but brightness slider does. Eh?

    Wow. That worked. It's flawless now. Thank you so much!

    For the sake of me understanding, as well as the fact I want to update the bug report I submitted with as many details as possible, can you tell me what exactly that did? I find it insanely strange that something entitled Windows 2012 was what fixed it for me... I'd really appreciate it. Thanks again!
    HOW TO - Set up video surveillance with "Motion"

    Buying a Lenovo? Do your research first!
    Some Lenovos have a whitelisted BIOS which prevents you from changing the wifi card.

  4. #4
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Function keys don't work, but brightness slider does. Eh?

    As I understand it, Windows 8 changed the way it addresses brightness (See: http://msdn.microsoft.com/en-us/libr.../jj159305.aspx). Laptop manufacturers have updated their acpi tables to accomodate (I'm guessing for newer Windows 8-capable devices - involving the second bit of the ACPI _DOS method). This parameter ("!Windows 2012") tells the bios that you are not Windows 8 (Windows 2012), so a different set of acpi tables are loaded. This different set of tables then allows the bios to control the brightness again.

  5. #5
    Join Date
    Nov 2011
    Beans
    1

    Re: Function keys don't work, but brightness slider does. Eh?

    I had a similar problem on my ProBook 6570b: Brightness OSD appeared but brightness didn't change. Brightness slider in settings didn't work either. Solution posted above worked flawlessly for me! Thanks a lot!

  6. #6
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Function keys don't work, but brightness slider does. Eh?

    Quote Originally Posted by Firstl4rs View Post
    I had a similar problem on my ProBook 6570b: Brightness OSD appeared but brightness didn't change. Brightness slider in settings didn't work either. Solution posted above worked flawlessly for me! Thanks a lot!
    Glad to hear. And welcome to the forums.

  7. #7
    Join Date
    Jun 2013
    Location
    Skyrim
    Beans
    32
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Function keys don't work, but brightness slider does. Eh?

    Quote Originally Posted by Toz View Post
    Does using the acpi_osi=\"!Windows 2012\" kernel parameter to help?

    To set up your system to use this parameter:
    1. Edit /etc/default/grub:
    Code:
    gksu gedit /etc/default/grub
    2. Change the line that reads:

    ...to read:
    Code:
    GRUB_CMDLINE_LINUX="acpi_osi=\"!Windows 2012\""
    3. Save the file.

    4. Run:
    Code:
    sudo update-grub
    5. Reboot.
    Hello! I've got quite a similar problem using an AsusX501A, with Xubuntu 13.04 running on it! Normally brightness values decrease while typing fn+f5 and increase by typing fn+f6 but now nothing seems to work anymore, i have to decrease brightness by using xrandr at every reboot!
    I tried the path you suggested by typing in a terminal window
    Code:
    gksudo gedit /etc/default/grub
    so i modified the file like this:
    Code:
    # If you change this file, run 'update-grub' afterwards to update# /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    #   info -f grub -n 'Simple configuration'
    
    
    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT= "splash quiet acpi_osi="
    GRUB_CMDLINE_LINUX="acpi_osi=\"!Windows 2012\"
    
    
    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
    
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    but, by updating in terminal, i got back this error:
    Code:
    Searching for GRUB installation directory ... found: /boot/grub
    /etc/default/grub: line 11: splash quiet acpi_osi=: command not found
    ...

    can you please understand the problem and help me somehow? this brightness is killing me :(

  8. #8
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Function keys don't work, but brightness slider does. Eh?

    Hello and welcome to the forums.

    First, you're missing a quote on the GRUB_CMDLINE_LINUX line. It should read:
    Code:
    GRUB_CMDLINE_LINUX="acpi_osi=\"!Windows 2012\""
    Secondly, I would recommend removing the acpi_osi= parameter, as it will be redundant. That line should read:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT= "splash quiet"
    And finally, what kind of video card(s) do you have? This command will help identify them:
    Code:
    sudo lspci -vnn | grep -A12 VGA

  9. #9
    Join Date
    Jun 2013
    Location
    Skyrim
    Beans
    32
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Function keys don't work, but brightness slider does. Eh?

    The answer to the command you asked me is:
    Code:
    00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0106] (rev 09) (prog-if 00 [VGA controller])    Subsystem: ASUSTeK Computer Inc. Device [1043:14f7]
        Flags: bus master, fast devsel, latency 0, IRQ 45
        Memory at f7800000 (64-bit, non-prefetchable) [size=4M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at f000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [a4] PCI Advanced Features
        Kernel driver in use: i915
    
    
    00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04) (prog-if 30 [XHCI])
    i'm fixing the syntax problem, let's see what's up *thank you*

    edit:
    by editing this way:
    Code:
    # If you change this file, run 'update-grub' afterwards to update# /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    #   info -f grub -n 'Simple configuration'
    
    
    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT= "splash quiet"
    GRUB_CMDLINE_LINUX="acpi_osi=\"!Windows 2012\""
    
    
    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
    
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"
    
    
    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"
    and then updating, the answer is:

    Code:
    Searching for GRUB installation directory ... found: /boot/grub/etc/default/grub: line 11: splash quiet: command not found
    Last edited by dovah; July 1st, 2013 at 12:42 AM.

  10. #10
    Join Date
    Jun 2013
    Location
    Skyrim
    Beans
    32
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Function keys don't work, but brightness slider does. Eh?

    That's ok, I reinstalled the system and edit ONLY the line you suggested, this way:
    Code:
    GRUB_CMDLINE_LINUX="acpi_osi=\"!Windows 2012\""
    but, in
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT= "splash quiet"
    i edited this way:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT= ""
    Everything's working fine!! ^^

    Huge thanks!
    Last edited by dovah; July 16th, 2013 at 08:34 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •