Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: fn brightness keys doesn't work - Nvidia driver

  1. #1
    Join Date
    Dec 2012
    Beans
    6

    fn brightness keys doesn't work - Nvidia driver

    Hi there,

    I just installed most recent version of nvidia drivers 304.64 which (probably) caused my brightness fn keys to stop working.
    Other fn keys are fine. I have did some searching but none of proposed solutions worked for me.

    I'm using S Vaio vgn-fz31z, system version is 12.10. The fn keys are "communicating with the system" so nothing is broken.

    Thanks in advance!

  2. #2
    Join Date
    Jul 2006
    Location
    Castrum, Germania Secunda
    Beans
    1,071

    Re: fn brightness keys doesn't work - Nvidia driver

    You could use the terminal:
    https://sites.google.com/site/easyli...not-adjustable
    (item 2.5, right column)
    Tips, tweaks and how-to's for Ubuntu and Mint:
    http://sites.google.com/site/easylinuxtipsproject
    In for a pleasant surprise? Give Xubuntu a try:
    http://sites.google.com/site/easylin...roject/xubuntu

  3. #3
    Join Date
    Dec 2012
    Beans
    6

    Re: fn brightness keys doesn't work - Nvidia driver

    I just tried that: entered everything in console, however with no response: I can get the BUS id but I cannot change the brightness.

  4. #4
    Join Date
    Feb 2012
    Location
    el_GR
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: fn brightness keys doesn't work - Nvidia driver

    Hi ,
    lets try some parameters.

    Open a terminal and apply this command
    Code:
    gksudo gedit /etc/default/grub
    Scroll down and find the line
    GRUB_CMDLINE_LINUX_DEFAULT= "quiet splash"
    now modify the line and add the parameter acpi_osi=
    The line now should be exactly like this
    GRUB_CMDLINE_LINUX_DEFAULT= "quiet splash acpi_osi="
    Save the document and now run in terminal
    Code:
    sudo update-grub
    Reboot your system and check again the Fn (for brightness) keys.

    Thanks

  5. #5
    Join Date
    Dec 2012
    Beans
    6

    Re: fn brightness keys doesn't work - Nvidia driver

    NikTh: You, sir, are awesome! Thank you for that!

    I have previously tried various changes within the same file but only this one proved successful.

    I'll just take advantage of an open post and ask one quick question:
    When I start the system, once it is fully booted (desktop visible, etc.) it takes an awful long time to start up Thunar 1.4.0 (about 40 seconds from the keystroke), afterwards everything opens smoothly. How can I fix that?

  6. #6
    Join Date
    Feb 2012
    Location
    el_GR
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: fn brightness keys doesn't work - Nvidia driver

    Quote Originally Posted by morphyrichards View Post

    I'll just take advantage of an open post and ask one quick question:
    When I start the system, once it is fully booted (desktop visible, etc.) it takes an awful long time to start up Thunar 1.4.0 (about 40 seconds from the keystroke), afterwards everything opens smoothly. How can I fix that?
    Try this workaround

    Open this file
    Code:
    gksudo gedit /usr/share/gvfs/mounts/network.mount
    and change the
    AutoMount=true
    to
    AutoMount=false
    See now if Thunar opens faster.

    Be aware that this is not a solution , is just a workaround. The delay now will show up when you click the "Network" tab on the left sidebar . But if you not using the "Network" tab, this workaround can be a good standing.

    Thanks
    Last edited by NikTh; December 23rd, 2012 at 06:22 PM. Reason: Update

  7. #7
    Join Date
    Dec 2012
    Beans
    6

    Re: fn brightness keys doesn't work - Nvidia driver

    It worked again! Now Thunar opens instantaneous.

    Thank you sir.

  8. #8
    Join Date
    Jul 2011
    Beans
    9

    Re: fn brightness keys doesn't work - Nvidia driver

    Worked like a charm on Asus K55VM with Linux Mint 14 Cinnamon.


    By the way, for those who are searching for a solution for the FN keys to work on K55V's, take the risk to change to Linux Mint 14 Cinnamon.
    You won't regret it

  9. #9
    Join Date
    Jan 2013
    Beans
    17

    Re: fn brightness keys doesn't work - Nvidia driver

    Quote Originally Posted by NikTh View Post
    Hi ,
    lets try some parameters.

    Open a terminal and apply this command
    Code:
    gksudo gedit /etc/default/grub
    Scroll down and find the line

    now modify the line and add the parameter acpi_osi=
    The line now should be exactly like this
    Save the document and now run in terminal
    Code:
    sudo update-grub
    Reboot your system and check again the Fn (for brightness) keys.

    Thanks
    Hi! Thanks a lot, it worked with the tips above, but with this change I have a little bug here, after reboot the browser chromium starts with a very small size and cannot be maximized (just on first open) , it stay like that, i have to close it and open again then it restore to normal size.

    like that: https://www.dropbox.com/s/v0dy33kc1f54slt/screen.png

    Do you or someone have an idea what could be that?

    Thanks!

  10. #10
    Join Date
    Jul 2011
    Beans
    9

    Re: fn brightness keys doesn't work - Nvidia driver

    instead of using chromium, try using chrome

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •