Page 4 of 4 FirstFirst ... 234
Results 31 to 38 of 38

Thread: 4OD, Demand 5

  1. #31
    Join Date
    Aug 2013
    Beans
    3,030

    Re: 4OD, Demand 5

    Quote Originally Posted by onefthemany View Post
    I made a clean install on my laptop and then installed hal... now I can watch 4oD and Demand 5, but only in Firefox... if in doubt clean it out

    Note: I am on 13.10 not 13.04 and pipelight does not work for me when using Chrome
    Hal doesn't work on pepper flash (Chrome). Pipelight should work on Chrome, but then it won't be for long because google is going to ban all NNAPI plugins and extensions on Chromium/Chrome for Linux after April, so I would just stick to Firefox.

  2. #32
    Join Date
    Oct 2008
    Location
    PDX OR
    Beans
    31
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: 4OD, Demand 5

    Hello and thank you for your post. I followed your directions (minus numbers 5 and 6) and now seem able to rent YouTube and Amazon movies once again. (This is in Firefox, running Ubuntu 13.10.)
    Does anyone have any thoughts on why it seems to be more challenging to access this kind of content in 13.10 than it was in previous versions? My hope, of course, would be that Ubuntu would be moving towards greater compatibility with these kinds of sites.
    Thanks.

  3. #33
    Join Date
    Apr 2012
    Beans
    2

    Re: 4OD, Demand 5

    Many thanks for this - worked for me!

  4. #34
    Join Date
    Jun 2014
    Beans
    4

    Re: 4OD, Demand 5

    Quote Originally Posted by a-ciccantelli View Post
    The problem is that demand 5 and 4od and google play use flash DRM.

    You can get these sites working in Ubuntu but it is gettting harder and harder
    e.g. the 'hal' packages have now been deleted from the ubuntu 13.10 repos !

    here is what you need to do:

    1) make sure you are using firefox or chromium
    if you are using chrome make sure the pepper flash plugin is turned off

    2) if using ubuntu version 13.10 must download and install these raring(13.04) .debs because they have been deleted from the 13.10 repos:

    libhal1:
    http://packages.ubuntu.com/raring/libhal1

    libhal-storage1:
    http://packages.ubuntu.com/raring/libhal-storage1

    hal:
    http://packages.ubuntu.com/raring/hal


    3) Once the debs are installed, then patch hal by executing the following shell commands::

    sudomkdir/etc/hal/fdi/preprobe
    sudomkdir/etc/hal/fdi/information
    /usr/sbin/hald --daemon=yes--verbose=yes

    4) close the browser and clear the Adobe Access directories by executing the following shell commands:
    cd ~/.adobe/Flash_Player
    rm -rf NativeCache AssetCache APSPrivateData2
    rm-rf ~/.adobe

    5) need to reset licence files (this is critical too !):
    http://www.macromedia.com/support/do...manager08.html

    6)
    test via:
    http://drmtest2.adobe.com:8080/SVP/S...Player_FP.html


    paste in this video url:
    http://drmtest2.adobe.com:8080/Content/anonymous.f4v

    I am new to Ubuntu and I do not understand how to download libhal1, libhal-storage1, hal. Can you pleas give a step by step?

  5. #35
    Join Date
    Nov 2014
    Beans
    8

    Re: 4OD, Demand 5

    Quote Originally Posted by j.j.veilleux View Post
    I confirm that the procedure in a-ciccantelli's post solves the problem. I have just use this procedure to get Amazon Instant Videos working on my laptop running Ubuntu 13.10. I am a very happy camper!

    A couple of comments/clarifications:

    As also mentioned by others above, in step 2, there are actually two ways to do this:

    1. Get the deb's from the 13.04 repository locations mentioned in a-ciccantelli's post, and install them using 'sudo dpkg -i <deb-filenames>'. -- but, this does not totally seem to work; it works as far as fixing the DRM problem and allowing you to watch DRM-protected videos, but causes a problem at startup as mentioned in muppet317 above.

    2. The solution which seems to fix the DRM issue and not cause the problem at startup is to add an alternate repo, where hal is apparently still being maintained, to your list of apt repositories, then install hal more simply by just using apt-get:

    sudo add-apt-repository ppa:mjblenner/ppa-hal
    sudo apt-get update
    sudo apt-get install hal

    NOTE: I cannot take credit for this information; I found it in a post by 'noobninja' here: http://askubuntu.com/questions/36225...to-ubuntu-13-1. (I subsequently also noticed it in the subsequent comments above; doh! That's what I get for reading only the part of the thread that I thought I needed! Next time I'll read the whole thing).

    In step 3, the commands shown above are a little bit mangled (missing spaces). The commands should actually be:

    sudo mkdir /etc/hal/fdi/preprobe
    sudo mkdir /etc/hal/fdi/information
    /usr/sbin/hald --daemon=yes --verbose=yes

    In step 4, you only have to execute the last command ('rm -rf ~/.adobe'). The two commands above that one are redundant and unnecssary, since they're just deleting lower-level directories that would also be deleted by the last command. So -- just do 'rm -rf ~/.adobe'.
    For reference, I am on a brand-new Ubuntu install, Ubuntu 14.04.1 LTS, and the above suggestion worked perfectly for me.

    Prior to fix, problem manifested itself in all three browsers installed - Chromium, Chrome, and Firefox (all up to date as of this minute...)

    Problem exhibited as the video would load, appear to be about to start, then stop. It never actually WOULD start, clock would show 0:00. In some browsers (I think Chromium, but I did not keep notes) it appeared to be continuing to cycle through attempting to start (see timeline showing 0:00 with "pause" icon evident, as if it were playing, then black screen, then timeline shows up again with same display, then black, then timeline, etc...)

    After going through the above instructions I now find that I CAN play Amazon Instant Video, however ONLY in Firefox. Chromium and Chrome still do not work, still exhibit same error behaviour described above.

    Don't care, will use Firefox....

    Now, if only they had a nice plugin for MythTV...

  6. #36
    Join Date
    Jul 2008
    Beans
    Hidden!

    Re: 4OD, Demand 5

    I can use 40D fine but not demand5 I'm using Ubuntu 14.04 64 bit. Advice please

  7. #37
    Join Date
    Jan 2015
    Beans
    1

    Re: 4OD, Demand 5

    Quote Originally Posted by UncleMonty View Post
    I can use 40D fine but not demand5 I'm using Ubuntu 14.04 64 bit. Advice please
    Yes I find exactly the same thing on 14.04 64bit. It's frustrating, and the sort of thing that makes it hard to advocate Ubuntu to users of other OS's

  8. #38
    Join Date
    Jan 2016
    Beans
    1

    Re: 4OD, Demand 5

    Quote Originally Posted by stevebrodie View Post
    Yes I find exactly the same thing on 14.04 64bit. It's frustrating, and the sort of thing that makes it hard to advocate Ubuntu to users of other OS's
    Same here

    I have a machine here in the workshop that had Vista on it, I persuaded the owner that Linux was the way forward, but she uses it a lot for catch up TV.
    ITV hub does not work (just gives a black screen) 5OD just gives the loading circle, but never loads.
    This is getting silly what with all this flash and hal issues now.
    I have tried all the usual things, manually putting the newest version of flash that is available to "us" in place, but still no go.

    I can see that his one will have to go back to Windows

    The (LOTS) of other machines I have done recently (for customers) will almost certainly have the same issues, it's just that those customers have likely not tried to use catchup TV (btw, the BBC one, and Youtube do work). What will I tell them when they ring up and ask me to get ITV and 5OD working?

    This is becoming a major stumbling block. If I cannot find a reliable fix, I may well have to bow out of doing Linux installs

Page 4 of 4 FirstFirst ... 234

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •