Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: 4OD, Demand 5

  1. #1
    Join Date
    May 2013
    Beans
    1

    Unhappy 4OD, Demand 5

    Hi All,
    I'm new to all of this but my boyfriend installed ubuntu on my laptop and since then I've not been able to watch anything on 4OD or Demand 5.
    I've googled it till I'm blue in the face and all sources tell me to download HAL then clear the Flash cache folder.
    I've done this, Another guide told me to totally remove flash and then re-install it. I've done that also.

    Every time even if I reboot on every step I get the same error messages.

    Everything loads, On demand 5 i click the play button in the middle of the screen and straight afterwards a box appears that says

    "This player is unable to play protected content at this time."

    If I try 4OD, the same happens again

    "A digital rights error 3322 has occurred..."

    Its a pain in the bum because I watch lots of content on the on demand services and now they just wont play.
    When I was on ubuntu 12.10 it seemed to work fine, now I'm on 13.04 it doesn't work at all!

    Any help would be very much appriciated

    Many Thanks

    Holly

  2. #2
    Join Date
    May 2012
    Beans
    2

    Re: 4OD, Demand 5

    I'm in the same boat as you well apart from the boyfriend and being a girl
    Can anyone help? 4OD ( www.channel4.com) has always been flakey with my Ubuntu installs. I started with 12.04 and it works one month then doesnt the next. In softwareCentre it says I have HAL installed and I have deleted the .adobe folder numerous times but to no avail. It is Big Bang Theory I am trying to watch and yes I am in UK. Is there another .adobe folder I should be deleting instead of just the one in my home directory?
    Oh and before I have had to make sure im signed into 4OD or it wouldnt work but clearing my cookies and cache then signing back in didnt do anything.

    Thanks for any input folks.

    GeetFai
    Last edited by GeetFai; May 19th, 2013 at 03:35 AM.

  3. #3
    Join Date
    Jan 2010
    Location
    Hyperborea
    Beans
    1,443
    Distro
    Ubuntu

    Re: 4OD, Demand 5

    4OD is working for me at the moment. All I did was to install hal.
    Using Firefox with AdblockPlus it even skips the adverts. This is an improvement because for a while it would play the adverts but not the content
    Chromium also works, I do not have any add-ons so I see adverts.
    I'm running Ubuntu 12.10.

    Edit: FWIW In Firefox I also have these add-ons
    Ghostery
    Flash-aid
    RefControl
    Better Privacy
    NoScript
    Last edited by coldraven; May 19th, 2013 at 09:53 AM.

  4. #4
    Join Date
    Oct 2006
    Beans
    45

    Re: 4OD, Demand 5

    This problem with 4OD and Demand5 on 13.04 also applies to Chrome in my case.

  5. #5
    Join Date
    Feb 2010
    Beans
    6

    Re: 4OD, Demand 5

    Close all browser windows and then:

    Remove the adobe cache:

    rm ~/.adobe -rf

    Install hal & hal-info:

    sudo apt-get install hal hal-info

    Reinstall adobe player:

    sudo apt-get install flashplugin-installer --reinstall

    All should be well...

  6. #6
    Join Date
    Mar 2012
    Beans
    15

    Re: 4OD, Demand 5

    Quote Originally Posted by hyattjon View Post
    Close all browser windows and then:

    Remove the adobe cache:

    rm ~/.adobe -rf

    Install hal & hal-info:

    sudo apt-get install hal hal-info

    Reinstall adobe player:

    sudo apt-get install flashplugin-installer --reinstall

    All should be well...
    dont work for me

    still cant watch 4oD on Firefox, Chromium or Chrome

  7. #7
    Join Date
    Feb 2010
    Beans
    29
    Distro
    Ubuntu

    Re: 4OD, Demand 5

    Quote Originally Posted by hyattjon View Post
    Close all browser windows and then:

    Remove the adobe cache:

    rm ~/.adobe -rf

    Install hal & hal-info:

    sudo apt-get install hal hal-info

    Reinstall adobe player:

    sudo apt-get install flashplugin-installer --reinstall

    All should be well...
    I also tried this and I still get the same error messages using firefox and chromium.

    Any other suggestions?

  8. #8
    Join Date
    Dec 2007
    Location
    Preston, UK
    Beans
    10
    Distro
    Ubuntu Development Release

    Re: 4OD, Demand 5

    After yesterday's update to Flash this has started happening to me, too. hal packages were already installed, cleared the adobe cache too but got nothing as a result.

  9. #9
    Join Date
    Oct 2013
    Beans
    3

    Re: 4OD, Demand 5

    The problem is that demand 5 and 4od and google play use flash DRM.

    You can get these sites working in Ubuntu but it is gettting harder and harder
    e.g. the 'hal' packages have now been deleted from the ubuntu 13.10 repos !

    here is what you need to do:

    1) make sure you are using firefox or chromium
    if you are using chrome make sure the pepper flash plugin is turned off

    2) if using ubuntu version 13.10 must download and install these raring(13.04) .debs because they have been deleted from the 13.10 repos:

    libhal1:
    http://packages.ubuntu.com/raring/libhal1

    libhal-storage1:
    http://packages.ubuntu.com/raring/libhal-storage1

    hal:
    http://packages.ubuntu.com/raring/hal


    3) Once the debs are installed, then patch hal by executing the following shell commands::

    sudomkdir/etc/hal/fdi/preprobe
    sudomkdir/etc/hal/fdi/information
    /usr/sbin/hald --daemon=yes--verbose=yes

    4) close the browser and clear the Adobe Access directories by executing the following shell commands:
    cd ~/.adobe/Flash_Player
    rm -rf NativeCache AssetCache APSPrivateData2
    rm-rf ~/.adobe

    5) need to reset licence files (this is critical too !):
    http://www.macromedia.com/support/do...manager08.html

    6)
    test via:
    http://drmtest2.adobe.com:8080/SVP/S...Player_FP.html


    paste in this video url:
    http://drmtest2.adobe.com:8080/Content/anonymous.f4v
    Last edited by a-ciccantelli; October 9th, 2013 at 10:02 AM.

  10. #10
    Join Date
    Dec 2008
    Beans
    10

    Re: 4OD, Demand 5

    I can confirm that following a-ciccantelli's steps works. I was unable to view anything on 4od for months, and now it works perfectly. Thanks!

    - r

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •