Results 1 to 7 of 7

Thread: problem in installing Firefox20

  1. #1
    Join Date
    Aug 2010
    Beans
    49

    problem in installing Firefox20

    Hi frinds !
    I m a newcomer in Linux world.
    I have just installed Ubuntu 13.04.
    On some website I read about Firefox20. So I want to upgrade my firefox. But in help there is
    one step in that I have to move firefox directory ( which actually came after extracting file firefox-21.ob7.tar.bz2)
    to /opt folder. For that , 1st if u have previous firefox version remove it by following command :

    sudo rm -r /opt/firefox

    and then move firefox directory to /opt with follwing command :

    sudo mv firefox /opt/firefox20

    But in both the cases I got error like there is no such file or directory.

    So I tried manually but I think there is no copy/cut paste option in /opt. ( I saw /opt properties and got
    following message :
    " U r not the owner so u can't change the permission "

    So can anyone help me in installing firefox20 ?
    Thank u in advance.

  2. #2
    hakermania's Avatar
    hakermania is offline Τώρα ξέρεις τι γράφω εδώ!
    Join Date
    Aug 2009
    Location
    Greece
    Beans
    1,704
    Distro
    Ubuntu Development Release

    Re: problem in installing Firefox20

    Hi tusharkoshti!

    Can you please link us to the page where you get your information about installing firefox 20?

    Also, please try extracting firefox-21.ob7.tar.bz2 (also, it says firefox 21, which version are you finally trying to install?) in your home folder, try opening a terminal through Ctrl+Alt+T and then give the second command,
    Code:
    sudo mv firefox /opt/firefox20
    Website

    Wallch (Wallpaper Changer): Sourceforge | Launchpad

  3. #3
    Join Date
    Aug 2011
    Location
    52° N 6° E
    Beans
    2,869
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: problem in installing Firefox20

    Firefox 20 is the current version, it should be installed by default (if it wasn't yet in the disk image (I don't remember when FF20 came out) you should get an update automatically). The firefox-21.ob7.tar.bz2 archive contains firefox 21, wich is the beta version. So if you want firefox 20 you don't have to do anything. If you want the beta version, you'll have to install 21.

    That page that told you about FF20 may have been outdated, written when FF20 was still in beta.

  4. #4
    Join Date
    Feb 2008
    Beans
    4,448
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: problem in installing Firefox20

    You might have saved yourself a lot of trouble by running Firefox and clicking Help/About.

  5. #5
    Join Date
    Aug 2010
    Beans
    49

    Re: problem in installing Firefox20

    Hi ,
    I tried to extract but error is " U dont have the right to extract this archieve .... "
    I am giving the link :

    http://www.libre-software.net/how-to-install-firefox-on-ubuntu-linux-mint

    I think link is outdated as per
    "Impavidus"saying.
    Last edited by tusharkoshti; May 12th, 2013 at 06:51 AM.

  6. #6
    Join Date
    Feb 2011
    Location
    Somewhere...
    Beans
    1,559
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: problem in installing Firefox20

    The package provided on Mozilla's website contains the entire prepackaged binary of Firefox, like a portable version. You needn't, and shouldn't use it. Unless you are using an unsupported Ubuntu version (which means you need to upgrade ASAP), Firefox will be upgraded automatically by Ubuntu, and you don't need to do anything more.

  7. #7
    Join Date
    Aug 2010
    Beans
    49

    Re: problem in installing Firefox20

    Thank you Zombifier25

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •